Epson XP 231 printer not working (Rolling)

Great work!
I followed all the procedure and the system is working fine, but I encountered one weird issue and I would like to know if someone else has seen it: the plasma system settings for “printers” says “printer service is unavailable” because of a “bad file descriptor”. I wonder what went wrong there… I use an EPSON XP 231 scanner/printer and I managed to get the scanner working, but I cannot do anything with the printer.
Any recommendation?

Hi @mechatotoro.

OpenMandriva does not install all printer driver software by default so many users need to install software specific to their printer. This is described here.

How to configure printer

Turn your printer on and see if it is automatically configured. Pay attention to whether the right driver was installed. If printer was auto configured and you have correct driver then great, you are all set.
If it was not, turn off your printer. Open Printer Settings aka SystemSettings>Hardware>Printers and remove your printer. You can also acess the Printer Settings from Konsole (terminal) with:

$ kcmshell5 kcm_printer_manager

If the correct driver was not installed by default we will need to add a software package.

The next step is to determine what software to add for your printer.

In OpenMandriva Lx this is most likely to be a ‘task-printing’ package specific to your printer brand. The packages are:

  • task-printing-canon
  • task-printing-epson
  • task-printing-hp
  • task-printing-lexmark
  • task-printing-okidata
  • task-printing-misc

Install the package that matches your brand or the misc package if none do. Example using okidata:

$ sudo dnf install task-printing-okidata

Now turn printer on again and it should then automatically configure itself (sometimes you might need to reboot for auto config to work).

If not seek help here

Note: The Errata page is for OM Lx 4.2. Other than driver software upgrades there have been no changes to printer support for Rolling/OM Lx 4.3.

Hello, ben79,
Thank you for your fast reply!
I am afraid that the problem is not that I am missing the drivers… I already installed the package task-printing-epson and the printer drivers:
dnf install epson-inkjet-printer-201204w-1.0.0-1lsb3.2.x86_64.rpm
Last metadata expiration check: 2:13:02 ago on mié 17 nov 2021 19:47:06 CST.
Package epson-inkjet-printer-201204w-1.0.0-1lsb3.2.x86_64 is already installed.
Dependencies resolved.
Nothing to do.

This is the output when I run $ kcmshell5 kcm_printer_manager:
kf.coreaddons: "Could not load plugin from "
libkcups: IPP_INTERNAL_ERROR: clearing cookies and reconnecting
libkcups: Failed to reconnect Invalid argument
libkcups: IPP_INTERNAL_ERROR: clearing cookies and reconnecting
libkcups: Failed to reconnect Invalid argument
libkcups: IPP_INTERNAL_ERROR: clearing cookies and reconnecting
libkcups: Failed to reconnect Invalid argument
Then a window opens with the problem I described:

Systemd reports that cups.service is dead and the three units org.cups.cupsd.path/service/socket are not found.

I am truly lost here…

Where did that package come from, I do not see it in OM Lx repositories?

What does sudo systemctl status cups show? On a working system it should look like:

That probably come from the Epson website?

I missed that and that tells us that cups is not working.

A bad file descriptor could be because of something in the Epson driver package. I would try removing that, rebooting, and see if cups is working again. It that gets results then try installing the OM package epson-inkjet-printer-escpr and hope that has the correct driver.

By now it should be apparent that I am just another user trying to help, not a developer, and we may need developer help for this.

Post-edit: Another guess. Did you try re-installing the driver package after upgrading to Rolling? Any 3rd party software should be re-installed to update any dependencies. Though if already installed the dnf disto-sync should have done that.

Hello, ben79,

First of all, I really appreciate it that you took your time to look into this.
I installed the package epson-inkjet-printer-201204w-1.0.0-1lsb3.2.x86_64.rpm (taken from the Epson website) after finishing with the upgrade. Back then, the only problem I noticed was the pulseaudio situation that you described, so that was taken care of quickly. I did not look into the printer then. So, I am not sure if the package taken from the Epson site caused the problem with cups or if it was already there as a result of the Plasma upgrade.

I removed the package from the Epson site, but cups is not working.
The packages from the repo (task-printing-epson and epson-inkjet-printer-escpr) were already there, so I removed them and put them back. Unfortunately, cups is not working.

So, since I have some free time, I am going to reinstall OMV and perform the rolling upgrade again. This at least will tell me that it wasn’t I causing the issue with the Epson package.

Once again, thank you very much for kindness in trying to help! I’ll post back with the findings of the experiment.

@mechatotoro It would be better to just install Rolling. The latest x86_64 iso. If you use znver1 it is here.

Thank you once again! Yes, that’s much better!
Downloading the rolling snapshot! :grinning:

There is more information about Rolling here and here.

Edit: Worth mentioning for all users, a fresh install is always preferred over a distribution upgrade.

Thanks! Reading while downloading!

Good point! I did not know there was a rolling snapshot, hehe. My bad. :sweat_smile:

I downloaded the .iso and checked that System settings was operational. Then, I performed the fresh install and the problem with the printer was gone. To use the printer, I just installed the OM task-printing-epson package (epson-inkjet-printer-escpr was already installed).

So, I am going with my usual suspect in this case… Myself! :stuck_out_tongue_winking_eye:
I guess the epson package that I had installed caused all the conflict.

@ben79 , thank you very much for pointing me to the solution of this situation!
How do I marked this as SOLVED?

I found the same culprit at the end of many problems of my own! To mark as solved underneath the post with the solution click on the three dots and select Solution.