SDDM login screen incorrect after upgrading to ROME

Hi again guys.
So I just finished upgrading to ROME. I have got some good and some bad news:
The good: In contrast to my last try in January where I got only a black screen of death after upgrading complted. (I used this instructions: How to upgrade Rock/OMLx 4.3 to ROME (rolling)) It works now, however, the logon screen is defaced, keyboard layout is wrong on it, and instead of Plasma-KDE I only got the horrible MATE (Looks like Gnome to me?)

Also Steam still doesn’t start still so no juice there.

In the package manager the KDE Plasma packages still appear installed so no idea why it only gives me MATE as a selection now.

There are 3 error messages on the login screen, they are in red and very hard to read but hope it helps to decipher anyway:

(From what I could read it says the following:

"The current theeme cannmot be loaded due to the errors below

Please select another theme

Type WallpaperFader unavailable

module “org.lde.plasma.private.sessions” is not installed.

thanks in advance!

Moderator: Started a new thread with this post because this is a separate issue.

@Nafcom let’s talk about Steam here and talk about the sddm login in this thread. Doing it this way makes it possible for other users to find the separate issues if they have the same or similar issue. Thanks in advance.

First I have no idea of what would cause this either. Can’t see your computer from here…

Don’t know if the following is a point or a question: The login screen probably would not offer the choice of Mate unless Mate was installed?

Can you select Plasma X11 or Plasma Wayland and login? You should be able to login from that screen. To change the login screen theme is in SystemSettings>Startup and Shutdown>Login Screen (SDDM). The default is to select Breeze. One might install om-midna-sddm and use that if one wished.

A guess: Open Konsole and run rpm -qa | grep mate which will show any packages installed with mate in the name. If there are any remove them unless you use Mate. Reboot and see what transpires.

This may remove Mate also:

$ sudo dnf rm mate* lib64mate*

For all users trying to upgrade OMLx from one version to another: We do test that this works on default or close to default systems. More customized systems and/or systems with a lot of other software installed may have issues. We try to help and work through these as well as we can but each such case is different.

I can only select MATE in the login screen, there is no other choice in dropdown menu. I am sure if I delete MATE I will 100% destroy my ability to login to anything like a desktop environment at all.

I did have MATE (Gnome?) and Plasma KDE installed before the upgrade.
Isn’t it better to provide some help how to restore Plasma KDE instead of removing the only thing that is selectable for now (Mate/Gnome?).

I did however figure out, I can change the US keyboard layout back to DE by pressing ‘D’ on the keyboard.

I don’t know. So don’t do that.

So if you want to use SDDM login then sddm has to be installed. But you seem to also have lightdm installed, probably that comes with Mate. I asked this:

So what if user has has KDE Plasma and Mate installed do they also have sddm and lightdm installed? What tells the system to use one or the other?

In OpenMandriva Cooker channel at OpenMandriva Chat.

ok :slight_smile:
I wrote the error messages in plain text below the screenshot, do they give some clues why KDE Plasma stopped working?

Honestly, I never cared whether SSDM or Lightdm is installed. I will check that out and let you know, thanks!

Just so you know: I barely touched or modified anything major after my initial install of OpenMandriva 4.1

I simply made sure the hardware works and the basic programs I use.
I do remember that LX 4.1 came preinstalled with a couple of desktop environments, but only Plasma worked to my satisfaction in LX 4.1 and LX 4.2


I checked: Lightdm is not installed.

+SDDM is installed.
-However the plasma6-sddm-kcm = Systemsettingsmodule for configurating the SDDM Display Manager
& plasma6-sddm-theme-breeze = KDE Breeze Theme for the SSDM Display Manager are not installed.

Could this be a clue?

Part of what makes this difficult is my lack of knowledge regarding this specific circumstance. And I do not want to lead you or any user down the path of breaking a working system. I am used to fixing things I break and sometimes lose sight that users in the forum are not so used to that.

I would check whether you have sddm and/or lightdm installed. That is safe to do.

The following suggestions are more risky but you should be able to undo anything by booting in to console mode and reinstalling any removed software.

If both are installed you could try removing lightdm and rebooting. If system does not boot graphically you can boot in to console mode and reinstall lightdm.

Or. If only lightdm is installed you could try to remove it and install sddm and reboot.

Or. Wait for help from Mate package maintainer. I am not sure if that is @AngryPenguin or @rugyada or @unknown_contributor.

Yes. You probably have Plasma6 packages installed and you don’t want those.

To check:

$ rpm -qa | grep 5.240.0

Or maybe you have plasma6-sddm instead of sddm ?

Edit: So what does rpm -qa | grep sddm show?

@Nafcom we need to stop any upgrading, installing of software for ROME now. Because of this:

@bero is about to start the process of copying cooker repos to rolling repos and you do not want to be doing package upgrading or installing at this time.

The problem you are having is solvable I am sure of that but we need to find the cause.

1 Like

Apologies for so many posts.

Where do you see this, need to see the context. Can you copy and paste or take a screen shot and post all the information? Anything over about 20 lines just put in a .txt file and post that.

Also can you run this and post the file rpms_installed.txt that the command witll create?

$ rpm -qa | tee rpms_installed.txt

And finally can you post the entire output tof this command?

$ dnf repolist

1 Like

I actually seem to have it the other way round

If I try to switch it around (unselecting what I currently have installed and select the “plasma6” items instead I get a box with tons of package conflict errors and it doesn’t install it.

As said earlier, I do not have Lightdm installed.

If I uninstall SDDM and install Lightdm instead, I end up in a login screen the next boot like in a terminal.

In the end I restored it from a backup to the point before I installed Lightdm

I am not interested in Mate Gnome at all, it is messy to me and I can barely use it for anything, I want Plasma KDE back.

I used to use Mandriva and gave Linux a couple of tries between 1998 and 2010 but I always ended up with a kernal panicl just trying to get my hardware working in Linux.

My try in 2021 with OpenMandriva so far resulted in not breaking the kernal at least.

I will reply later with the repolist as requested above.

@ben79 we need to stop any upgrading, installing of software for ROME now . Because of this:

Point taken, thanks!

You have the correct packages installed. Keep those.

There is a reason why I keep saying that you do not want plasma6 packages. They are not ready for users yet. They are being staged for future use only. So seeing all those errors when you try to install them is expected.

Since you have the correct packages installed then next thing to look at is configuration files for sddm and see if something happened to them.

Now to get more information from your ROME system do you have access to Konsole or some other terminal? Are are you comfortable running some commands I post here for you to copy and paste and run on your ROME system? Edit: These commands will be for purpose of gathering information only, they will not change or affect your system.

For @Nafcom and all users another way to approach this problem is to log in using console mode:

Select Advanced Options:

Select Console Mode:

Login as your regular user:

Type startx /usr/bin/startplasma-x11:

That should log you in to plasma desktop. If it does not then either something is missing from your system or a config file is messed up or missing.

hi @ben79 : First of all, sorry for the late reply. I have spent the last 3 days (what a weekend) trying to recover my backup I did from the state of my last post.

However, the file system got corrupted (Partition error: “Inconsistent Link Count”) so I had to go back to the backup from before upgrading Rock to Rolling, but then I had the issue again that I already encountered back in January at my first try: black screen with flashing coursor.

I have found, that I can boot in emergency mode at a lower res and only 1 of my 3 screens active. I found in the Welcome Center a new icon “Install Nvidia” drivers, did that, found to be booting normal then, but constantly crashing and kicking me out back to the SDDM Login Screen every 2-3 minutes. I found that the Hz setting was wrong, I set them to the max the monitors can handle and it remains stable by then.

I also went to the package manager as I got the error when clicking on the downer left corner “No package manager installed.”

I went do that and now SDDM hows next to Mate the following Options:

“Gome (Wayland)” (crashing)
"Gnome on Wayland (also crashing)
Gnome (that looks like a mobile OS but at least it allows me to do multitasking whcih I need to open the browser copy the commands into konsole and answer your questions).

So now I am exactly seeing the same thing as on my inital post.

rpms_installed.txt (102.2 KB)

repo id repo name
google-earth-pro google-earth-pro
microsoft-edge-beta microsoft-edge-beta
opera Opera packages
rolling-x86_64 OpenMandriva Rolling - x86_64
rolling-x86_64-non-free OpenMandriva Rolling - Non-free - x86_64
rolling-x86_64-restricted OpenMandriva Rolling - Restricted - x86_64
rolling-x86_64-unsupported OpenMandriva Rolling - Unsupported - x86_64
teamviewer TeamViewer - x86_64
vivaldi vivaldi
yandex-browser-beta yandex-browser-beta
[nafcom@nafcomsdesktop ~]$ rpm -qa | grep sddm

I have waited with re-upgrading until the post was updated that it is safe now again to upgrade

shows nothing


Before going any further the fastest way to get a working ROME system would be to do a fresh install of ROME. Something about your system is obviously causing problems with upgrading from Rock to ROME. So far I can not tell what that is. Repos are correct. Have not seen any problem in list of installed packages so far.

Edit: A fresh install is always preferred over upgrading from one version of an operating system to another.

Before doing that you need to try booting as described in this post. That should result in booting to plasma desktop.

One other thing we can look at is the config files for sddm.

can’t do that, no console window is opening, I only see pink flowers as a background