SDDM login screen incorrect after upgrading to ROME

Yes. You probably have Plasma6 packages installed and you don’t want those.

To check:

$ rpm -qa | grep 5.240.0

Or maybe you have plasma6-sddm instead of sddm ?

Edit: So what does rpm -qa | grep sddm show?

@Nafcom we need to stop any upgrading, installing of software for ROME now. Because of this:

@bero is about to start the process of copying cooker repos to rolling repos and you do not want to be doing package upgrading or installing at this time.

The problem you are having is solvable I am sure of that but we need to find the cause.

1 Like

Apologies for so many posts.

Where do you see this, need to see the context. Can you copy and paste or take a screen shot and post all the information? Anything over about 20 lines just put in a .txt file and post that.

Also can you run this and post the file rpms_installed.txt that the command witll create?

$ rpm -qa | tee rpms_installed.txt

And finally can you post the entire output tof this command?

$ dnf repolist

1 Like

I actually seem to have it the other way round

If I try to switch it around (unselecting what I currently have installed and select the “plasma6” items instead I get a box with tons of package conflict errors and it doesn’t install it.

As said earlier, I do not have Lightdm installed.

If I uninstall SDDM and install Lightdm instead, I end up in a login screen the next boot like in a terminal.

In the end I restored it from a backup to the point before I installed Lightdm

I am not interested in Mate Gnome at all, it is messy to me and I can barely use it for anything, I want Plasma KDE back.

I used to use Mandriva and gave Linux a couple of tries between 1998 and 2010 but I always ended up with a kernal panicl just trying to get my hardware working in Linux.

My try in 2021 with OpenMandriva so far resulted in not breaking the kernal at least.

I will reply later with the repolist as requested above.

@ben79 we need to stop any upgrading, installing of software for ROME now . Because of this:

Point taken, thanks!

You have the correct packages installed. Keep those.

There is a reason why I keep saying that you do not want plasma6 packages. They are not ready for users yet. They are being staged for future use only. So seeing all those errors when you try to install them is expected.

Since you have the correct packages installed then next thing to look at is configuration files for sddm and see if something happened to them.

Now to get more information from your ROME system do you have access to Konsole or some other terminal? Are are you comfortable running some commands I post here for you to copy and paste and run on your ROME system? Edit: These commands will be for purpose of gathering information only, they will not change or affect your system.

For @Nafcom and all users another way to approach this problem is to log in using console mode:

Select Advanced Options:

Select Console Mode:

Login as your regular user:

Type startx /usr/bin/startplasma-x11:

That should log you in to plasma desktop. If it does not then either something is missing from your system or a config file is messed up or missing.

hi @ben79 : First of all, sorry for the late reply. I have spent the last 3 days (what a weekend) trying to recover my backup I did from the state of my last post.

However, the file system got corrupted (Partition error: “Inconsistent Link Count”) so I had to go back to the backup from before upgrading Rock to Rolling, but then I had the issue again that I already encountered back in January at my first try: black screen with flashing coursor.

I have found, that I can boot in emergency mode at a lower res and only 1 of my 3 screens active. I found in the Welcome Center a new icon “Install Nvidia” drivers, did that, found to be booting normal then, but constantly crashing and kicking me out back to the SDDM Login Screen every 2-3 minutes. I found that the Hz setting was wrong, I set them to the max the monitors can handle and it remains stable by then.

I also went to the package manager as I got the error when clicking on the downer left corner “No package manager installed.”

I went do that and now SDDM hows next to Mate the following Options:

“Gome (Wayland)” (crashing)
"Gnome on Wayland (also crashing)
Gnome (that looks like a mobile OS but at least it allows me to do multitasking whcih I need to open the browser copy the commands into konsole and answer your questions).

So now I am exactly seeing the same thing as on my inital post.

rpms_installed.txt (102.2 KB)

repo id repo name
google-earth-pro google-earth-pro
microsoft-edge-beta microsoft-edge-beta
opera Opera packages
rolling-x86_64 OpenMandriva Rolling - x86_64
rolling-x86_64-non-free OpenMandriva Rolling - Non-free - x86_64
rolling-x86_64-restricted OpenMandriva Rolling - Restricted - x86_64
rolling-x86_64-unsupported OpenMandriva Rolling - Unsupported - x86_64
teamviewer TeamViewer - x86_64
vivaldi vivaldi
yandex-browser-beta yandex-browser-beta
[nafcom@nafcomsdesktop ~]$ rpm -qa | grep sddm

I have waited with re-upgrading until the post was updated that it is safe now again to upgrade

shows nothing


Before going any further the fastest way to get a working ROME system would be to do a fresh install of ROME. Something about your system is obviously causing problems with upgrading from Rock to ROME. So far I can not tell what that is. Repos are correct. Have not seen any problem in list of installed packages so far.

Edit: A fresh install is always preferred over upgrading from one version of an operating system to another.

Before doing that you need to try booting as described in this post. That should result in booting to plasma desktop.

One other thing we can look at is the config files for sddm.

can’t do that, no console window is opening, I only see pink flowers as a background

considering how much time I spent getting all my hardware to work, and the intention of moving to Roling was because Steam was supposed to work again (which it doesn’t) perhaps I would rather go back to the old Rock and wait till 5.0 turned from Rolling into Rock.

Perhaps the Steam problem finds a solution in the other thread though :slight_smile:

I am down to look into the GDDM config files though if it is any help :slight_smile:

Rock 5.0 is going to be what ROME is now plus any bugfixes or upgrades we make before 5.0. Normal workflow in OpenMandriva is Cooker>ROME>Rock. Sort of like Fedoara Rawhide>Fedora>RedHat or openSUSE Factory>openSUSE>SLES/SLED.

Likely something you did during getting all that hardware to work has led to the issues you are having. We would need to know, step by step, what you did to problem solve this. Otherwise the problem is likely to repeat.

At this point I would say looking at sddm config files is attacking the symptom not the real problem. We need to problem solve the cause not the symptom.

well, the symptoms I had so far where actually really easy to fix. Once I understood what was going on, troubleshooting it went quite successful. If I spend a bit more time into it, I will certainly find out why KDE Plasma cannot be choosen in the SDDM Login Screen :slight_smile:

OpenMandriva is not my main productive OS, (that is Windows 11).
I have OpenMandriva on a separated SSD with a separated boot loader entry

I am quite happy how far I have gotten today within 1 hour of troubleshooting already.

Perhaps the last two things (KDE Plasma) and Steam can also be fixed.

I am not in a dire need or time restriction here to get this right ASAP again.

So far I am happy I did get everything working without compiling any packages or so, as I said earlier, I didn’t really much fiddling compared to what I had to do back in the ealier days :slight_smile:

Edit: I can’t really help much to troubleshoot this without knowing what has been done to your system. Would need to know what changes were made to the system and exactly how the system was upgraded from Rock/4.3 to ROME.

The main sddm configuration file is /etc/sddm.conf. 2 other related files are /usr/lib/sysusers.d/sddm.conf and /var/lib/sddm/state.conf. Mine look like this:

⁄etc⁄sddm.conf.txt (850 Bytes)

⁄usr⁄lib⁄sysusers.d⁄sddm.conf.txt (113 Bytes)

⁄var⁄lib⁄sddm⁄state.conf.txt (279 Bytes)

The system is ROME Plasma desktop.

@Nafcom another thought is that since you have a ROME system I would not hurt to do this:

$ sudo dnf clean all ; sudo dnf --allowerasing dsync

and to keep your ROME system up to date:

$ sudo dnf clean all ; sudo dnf dsync

Do not upgrade your ROME system with dnfdragora or Discover.

OK now I may be getting somewhere with this. You have gdm-44.1-1.x86_64 and sddm-0.20.0-4.x86_64. gdm=gnome display manager. sddm=simple desktop display manager. I think these are controlled by systemd. So you would need to disable the gdm service and enable the sddm service.

Post the complete output of each of these commands as code (use the </> icon):

$ sudo systemctl status gdm

$ sudo systemctl status sddm

or gdm might be:

$ sudo systemctl status gdm3

Those are status commands they do not do or change anything regarding your system.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.