Updated Plasma and KDE Framework packages for OM Lx 3

On my system If I install Plasma 5.9 then task manager is borked:

Error loading QML file: file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/main.qml:338:5: Type ToolTipDelegate unavailable
file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/ToolTipDelegate.qml:23:1: module “QtQuick” version 2.7 is not installed

Late edit: Probably because of this “Unfortunately it looks like it needs Qt 5.7 or newer version, and 3.0 tree does have only 5.6.2 version.”.

It has been said that Qt 5.8 is in cooker and should work pretty fine.

Yes, but meanwhile we may have KDE/Plasma packages that we should wait to install until we get QT 5.8 or 5.7.

I think that you are right :slight_smile:

OMLx 3.02 development release build 834.
18 Feb 2017 - Fully updated, repo /testing enabled.


20 Feb 2017 - build 834 fully updated, repo /testing enabled.


OMLx 3.02 development release build 891.
08 March 2017


I only tested live mode in vbox and Calamares didn’t start. :frowning:

Haven’t tried in VBox yet but I have installed on 2 computers (hardware). Seems working well here.

So here now! I tried to start from terminal because I need to see its output but I types the wrong command. The working one is pkexec /usr/bin/calamares.

1 Like

OMLx 3.02 development release build 927.
26 March 2017


But just try updating packages from main-testing repo… :smirk:

The # 927 .iso works OK for me as does installed system as long as I don’t enable main-testing repo. #913 worked well also here. My installs are on hardware (usually) on 2 different computers.

I have noticed recently far fewer (almost none) segfaults, screen flashes, crashes, ect. Anyone else noticed this (hopefully) improvement. Seems I’ve noticed this since Qt 5.8.0. :alien:

1 Like

OK, If I put these:


in ‘/etc/urpmi/skip.list’ everything else in main-testing installed.

Imho as regular users should NOT have repo /testing enabled then that’s OK. In view of official release, with standard repositories enabled, I think we should test this kind of configuration.
Please correct me if I’m wrong :slight_smile:

You are correct we should test install and configure with standard repos. And I’ll try to confine any other conversation about testing repos to ‘Development Testing’ form category.

1 Like

927 doesn’t work for me. I have to download intel driver and modify xorg.conf by hand (Short version of what I did ) for to have OM Lx working.

A normal user is unable to do this

OMLx 3.02 development release build 993.
30 April 2017


Build 993 in vbox in live mode calamares aborts with the following error

QxcbConnection: could not connect to display

I’m the only one?

There is an i586 ISO # 994 also.

I have been “told” by calamares about no network :smile: Rarely, some times it complains about not enough memory, or space, or such…
Reboot always solved. Don’t know if this is your case :slight_smile:

1 Like