OMLx 4.0 Pre-Alpha ISO Plasma development builds

alpha
iso
plasma
omlx-4
Tags: #<Tag:0x00007ff2bb519310> #<Tag:0x00007ff2bb518fc8> #<Tag:0x00007ff2bb518b90> #<Tag:0x00007ff2bb518348>

(Tomasz Paweł Gajc) #41

Plasma Wayland is our default setting. if Wayland does not start for you, please provide logs, and detailed data.


(Tomasz Paweł Gajc) #42

Found the culprit. It is our ISO building tool. Can you please change in /etc/calamares/modules/displaymanager.conf:

executable to startplasmacompositor


(rugyada) #43

Frankly, @TPG with all my due respect to you I don’t remember any decision to be taken on this specific topic.
But I may have missed something…


(Tomasz Paweł Gajc) #44

I meant that for now Plasma Wayland is set as default. I think we need to check it, and give it some testing so before beta we may decide either we go back to X11 or stay with Wayland for Plasma desktop.


(Ben Bullard) #45

You mean like this:

Did not work here:


(Colin Close) #46

A new iso will be available soon. If it builds ok you should find that the xserver is working properly and it’s now possible to do an EFI install.

Colin


(Ben Bullard) #47

This be what @Colin is talking about. Please test and report issues here.


(Ben Bullard) #48

A positive step forward.

Regarding Plasma ISO build ID # 2274 in VBox. Booting to Live is still very slow, like 5 min 23 sec. It is possible and indeed probable that if I had done the trick (let it boot for say 30-45 sec. and then switch to a VT and back) that it would boot sooner. But this needs to be fixed or we’ll have reports of “ISO doesn’t work” or “ISO boots to black screen” because not many users will wait 5 minutes or longer for an ISO to boot. Alternatively if we publicize that you have to use a trick to get it to boot that would lead to bad publicity. Anyway this is a well known issue.

I’m given to understand that this ISO has a fix for “Xorg crashing”. But I was not experiencing Xorg crashes with earlier ISO’s so can not verify.

A minor complaint is the screen locking is enabled on Live mode. This is not good design in my opinion. Enabling screen locker for an installed system does make sense (if you assume users are to stupid to enable it for themselves) but makes no sense on a Live ISO does it?

Next I attempt to install with no tricks or workarounds. Since I am testing I do start Calamares from Konsole thus:

$ pkexed /usr/bin/calamares -d

to enable recover of output of the above command in the event of an issue. Since erase disk wants to make my 15 GB VM disk have a 6.4 GB swap I will use manual partitioning so I can make a smaller swap partition. I make a 300MB fat16 /boot/efi, a 13GB /, and 1.7GB swap.

Install was successful and took about 2 min. And that is with no tricks or workarounds applied. So that means about 3 or 4 different problems in Calamares configuration have been fixed in the last 10 days. Thanks to @Colin, and all others involved with that effort.

After install boot remains either slow or you have to use the switch to VM VT and back trick. So that needs fixing. But this ISO represents substantial progress.

That’s all I have on this so far. If you test this remember there is a thread about OM-Welcome so post any issues you find with that in that thread. Other issues can be posted in this thread.


(rugyada) #49

Of course agree that needs to be fixed but not 100% agree on that would lead to bad publicity.
It’s an Alpha release after all, so the trick can be an item for Errata.

Well, like a good number of things it has been reported more than once. The last in cooker chan a few days ago:

:grin:

However my last message may have been missed (by @bero or anyone supposed to be able to commit fixes), given the huge work that our devs are doing lately.

This be what @Colin is talking about.

Ok, downloaded. Going to test.


(rugyada) #50

Plasma ISO build ID 2274
Testing in VBox virtual machines.

- Calamares install (manual partitioning) successful
- Network working
- Firefox working
- Falkon working
- Libreoffice: wowowow working without any crash
- All the applications I started are opening without any issue. Not deep tested though
- Long time before desktop show up, still need the Alt+F2/Alt+F1 trick (as said above)
- Default desktop session is wisely set back to Plasma (no wayland default, since there will be an ISO wayland specific)
- LXQt dropped from the ISO, as Plasma finally has become Plasma-only \o/
- fcitx, cjk, thai, and friends dropped as well \o/ Notably fcitx issued many problems since the beginning; some bugreports are fcitx related so we may want to have a look at them to see if they are solved now.

:+1:


(rugyada) #51

Forgot to mention this:

Not sure to what extent it’s a true current issue or expected behaviour.
KMail is known to be someway bugged, at least until some time ago.


(rugyada) #52

Kind remind @tpg


#53

For me this ISO 2274 still not working. I left this ISO booting into VirtualBox for an hour and there was still a black screen. Switching to tty allows me to log in into text mode as live user but starting session “startplasmacompositor” gives me illegal instruction error and “startx” show me xorg crash.

Anyway in coredumpctl I see 6 error in sddm and 6 in xorg. Unfortunately, I can not dump it into a text file. I see lz4 files but I can’t dump it in any way, even with gdb.
This is for VirtualBox machine but I also observe something similar on real hardware (the same symptoms).

BTW. does anyone have access to a computer with Radeon graphics using the r600 driver?

If so, I would ask for a test, maybe the problem is only for r600.


(Ben Bullard) #56

Plasma ISO Build ID 2274 installed to hardware with no issue that would affect most users. So far nothing has crashed and things are working much more normally than my most recent Cooker/Lx 4 install for about a week or so ago.

This one affects me and my way of doing things but is easy to workaround:

Issue: Allow for users to mount /Data partitions. Post-edit: Work around/works for me

And these are also not very big issues but should be fixed:

Os-prober is missing from packages on ISO # 2274. Post-edit: Fixed by @TPG

Plasma Login/Logout sound files are incorrectly named. Post-edit: Fixed by @TPG


(Ben Bullard) #57

It seems rather likely that @AngryPenguin’s issue is graphics related. Here’s hoping our developers can get it sorted out and fixed soon.


(Ben Bullard) #58

More issues in hardware install:

1. There is a notification every time I boot into Plasma desktop:

“VBoxClient: the VirtualBox kernel service is…”

This isn’t a VBox client it is a hardware install so maybe whatever is triggering that notification needs to be modified.


(Ben Bullard) #59

2. system-config-printer is broken:

# system-config-printer
Traceback (most recent call last):
  File "/usr/share/system-config-printer/system-config-printer.py", line 84, in <module>
    import jobviewer
  File "/usr/share/system-config-printer/jobviewer.py", line 57, in <module>
    gi.require_version('Secret', '1')
  File "/usr/lib64/python3.7/site-packages/gi/__init__.py", line 127, in require_version
    raise ValueError('Namespace %s not available' % namespace)
ValueError: Namespace Secret not available
OT

Off topic: What the heck is it with Discourse and putting a period after a number? Why does that completely change how code icon works? I don’t hate Discourse but I can’t stand it for technical problems. I want to be able to do my numbers like

Dadgummit! Discourse is disrespecting me and ruining my highly refined style! It was good enough when I was in school in the 1850’s it should be good enough today.

:hear_no_evil::see_no_evil::speak_no_evil:

.
Edit by rugyada - Quick and dirty hint: use code tag for the numbers


(Ben Bullard) #60

3. HPLIP appears broken as well:

# rpm -qa | grep hplip
hplip-3.17.10-1.x86_64
hplip-gui-3.17.10-1.x86_64
hplip-model-data-3.17.10-1.x86_64
hplip-hpijs-3.17.10-1.x86_64
hplip-hpijs-ppds-3.17.10-1.x86_64

# hp-setup
Traceback (most recent call last):
  File "/usr/sbin/hp-setup", line 48, in <module>
    from base import device, utils, tui, models, module, services, os_utils
  File "/usr/share/hplip/base/device.py", line 42, in <module>
    from . import status
  File "/usr/share/hplip/base/status.py", line 33, in <module>
    import cupsext
ModuleNotFoundError: No module named 'cupsext' 

So I’m probably out of the printing business in Cooker/Lx4. localhost:631 lets me add printer but it doesn’t print. So useless.

$ systemctl status cups
● cups.service - CUPS Scheduler
   Loaded: loaded (/lib/systemd/system/cups.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2018-10-19 19:39:43 CDT; 1h 26min ago
     Docs: man:cupsd(8)
 Main PID: 4677 (cupsd)
   Status: "Scheduler is running..."
    Tasks: 2 (limit: 4915)
   Memory: 99.3M
   CGroup: /system.slice/cups.service
           ├─ 4677 /usr/sbin/cupsd -l
           └─11253 /usr/lib/cups/notifier/dbus dbus://

Oct 19 19:39:43 ben79-pc systemd[1]: Starting CUPS Scheduler...
Oct 19 19:39:43 ben79-pc systemd[1]: Started CUPS Scheduler.
Oct 19 21:00:46 ben79-pc /hpfax[11204]: [11204]: error: Failed to create /var/spool/cups/tmp/.hplip

the 2 tasks listed are not running, they are print jobs that aren’t printing.

$ groups ben79
ben79 : ben79 lp wheel audio video users network storage sambashare

$ groups root
root : root

:monkey:

Post-edit: The printing issues appear to be related to python somehow. I was hoping python stuff would be working better in Cooker/Lx4. Maybe this is a series of issues that will be fixed during the mass rebuild?


(rugyada) #61

Whether it’s good or bad, I put it in Errata.
Let’s hope it brings good luck :hot_pepper: :slight_smile:


#62

Yes, hplip need to be rebuild and even better - need update to latest version (for bug fixing and support new hp devices). I need “hplip” for my packages myself, that’s why I tried to update it, but when I saw how much it contained patches, I gave up… Just look: https://github.com/OpenMandrivaAssociation/hplip Some of this patches need to be removed, other rebased and other maybe imported. So many work.

I do not have a working cooker installation to check it out but I think it should not be difficult to fix it.
I saw something similar on Debian front.

Here: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=892256
and here: https://bugs.launchpad.net/ubuntu/+source/system-config-printer/+bug/1709572

I dont have cooker instalation working, so I have to ask @ben79 , can you check this solution from debian?
If it working, then we can fast fix it.