OMLx 4.0 Pre-Alpha ISO Plasma development builds

alpha
iso
plasma
omlx-4
Tags: #<Tag:0x00007ff2b7aeb9b8> #<Tag:0x00007ff2b7aeb878> #<Tag:0x00007ff2b7aeb738> #<Tag:0x00007ff2b7aeb5a8>

(Tomasz Paweł Gajc) #21

Why ? Can you provide more details, logs etc?
Calamares user KDE’s partitionmanager and kpmcore for managing partitioning.


(Colin Close) #22

The latest LxQt 4.0 alpha should now install in virtualnox in BIOS mode (EFI not tested) however I got a black screen after sddm has done it’s login bit. I think the vboxvideo module may be giving trouble as 3d rendering appears to be broken in VB
I can get the desktop to start but then it crashes with a segfault in libc. I am trying a rebuild on the package that is causing the issue (lxqt-globalkeys).
After fixing the above pcmanfm failed with the same problem. Looks like most LxQt apps will have to be rebuilt.
Don’t bother with the iso.


(rugyada) #23

Random thoughts:

Calamares seems setting by default swap size 2x the detected RAM. It may make sense or not, afaik the swap is used for the feature “Suspend”. While in real hw with large storage devices 8GB swap may be insignificant, in virtual machines, say you set around 20GB of hard disk, swap size may matter.
It’s the reason why I usually pick manual partitioning so I set 1024MB swap and the rest free for the virtual hard disk.

About Calamares error, it’s better to create a new virtual machine as IIRC to install on an existant already partitioned virtual HD may not be perfectly working. For my experiment, to be on the safe side I deleted the old vm and created a new one.

Also, not sure if it matters to your issue, I noticed that the mount point / was not selected by default, I had to pick it manually.
Maybe you noticed it too, or maybe you overlooked. Anyway that’s so :smile:

Just another glitch I noticed the default desktop session is set to Plasma Wayland


(Ben Bullard) #24

The partitioning error I had was on hardware. You can work around this by deleting partitions and creating new ones.


(Ben Bullard) #25

New Plasma ISO build ID 2242 today. Thanks for making the ISO @fedya. Calamares still not ready.

$ rpm -qa calamares
calamares-3.2.2-3.x86_64

Install fails in VBox:

Konsole out put of ‘pkexec /usr/bin/calamares -d’:

Calamares-error.txt (23.1 KB)


(rugyada) #26

Same here

cala-2242.txt (20,5 KB)


(Tomasz Paweł Gajc) #27

Try with new calamares-3.2.2-4


(rugyada) #28

calamares-3.2.2-4 looks fixing that issue

cala-2242a.txt (35,4 KB)


(rugyada) #29

Plasma ISO build ID 2242
Testing in VBox virtual machines.

- Falkon working
- PCManFM-QT ~working
- LO keep crashing the desktop, leafpad as well same as before
- Network not working in live mode, but works once installed system
- Long time before desktop show up, need the Alt+F2/Alt+F1 trick


(Tomasz Paweł Gajc) #30

So you were able to install it. Good. have you checked after installation , you system booted. Anything failed, especially in logs or systemd units ?


(rugyada) #31

@TPG system booted without any evident issue. Please tell me what log you want me to attach.


(Tomasz Paweł Gajc) #32

@rugyada please attach

journalctl -b

copy all the pages from
systemctl list-units


(rugyada) #33

@TPG
Here are the files

journalctl -b.txt (715,2 KB)

systemctl list-units.txt (15,1 KB)


(Ben Bullard) #34

We should make some kind of a list or cheat sheet for logs or other information to gather for ISO testers. Post-edit: Especially for VBox where it is problematic to gather logs and information when there are problems or failures.

And I admit up to this point I have done nothing to gather logs myself in this regard. I’ve been saying I wanted to wait until the mass rebuild and associated fixing is done before I get to serious about testing but it seems there are some things we can test now so maybe I’ll have to shape up and get with the program myself…
:crazy_face::monkey::dizzy_face:

Post-edit: So for a list of logs and info for ISO testers so far we have (what @TPG posted):

$ systemctl list-units

$ journalctl -b

(Ben Bullard) #35

Duh, might be helpful in testing to get in habit of running:

$ pkexec /usr/bin/calamares -d

and providing terminal output of that command. This should be a “must do” for failed installs.


(rugyada) #36

Plasma ISO build ID 2261
Testing in VBox virtual machines.

- Network now working also in live mode
- Installation fails with error in screenshot

cala-2261.txt (20,7 KB)


(Ben Bullard) #37

There is a trick for that or a workaround. So far I booted in MBR mode (not EFI) and I did succeed in getting the Plasma ISO #2261 to install. For the display manager issue you need to edit the file ‘/etc/calamares/modules/displaymanager.conf’. I cheated and used dolphin and kwrite. First this is what the default (and incorrect apparently) file looks like:

You want to edit it to remove all the display managers except sddm in the list. Then comment out the lines:

    defaultDesktopEnvironment:
    executable: startkde
    desktopFile: plasma

so your file looks like this:

and then I was able to install:

Next a word of caution. Don’t use Auto Login during install. Why? Because someone in his infinite wisdom has made Plasma (Wayland) the default desktop manager:

Everyone should try it in VBox and see how it works for you. You may want to change that to Plasma. Wayland does not work on my hardware. Does not work well for me in VBox.

Anyway result is:

Note: Did you really think I came up with this workaround? Nope I got it from crazy.


(Ben Bullard) #38

With the same Plasma ISO # 2261 I can boot EFI but install fails with same errors that have been reported already:

Just for whatever here’s the output of ‘pkexec /usr/bin/calamares -d’:

<I had posted the wrong output, will get that corrected shortly>
<OK, now this is the correct output>

Calamares-error.txt (33.6 KB)

Did not see anything in journalctl that looked like it would be helpful but I can do this again and post that if anyone wants to see it.


(rugyada) #39

Yeah. I saved his hints, commented all useless displaymanagers lines but missed the second part :stuck_out_tongue_winking_eye:

Now worked :+1:
Thanks for the remind.


(Ben Bullard) #40

Just checked something about desktop. When you boot ‘Live’ it is using Plasma not Plasma (Wayland). I’m baffled why Plasma (Wayland) is the default after install?

Another point: The issue about EFI installs not working is example of something that can be tested and fixed before Cooker mass rebuild is done. The trick for OpenMandriva is to keep it fixed and not let it revert to broken again.