OM Lx 4.0 does not work with TV Monitor

Tags: #<Tag:0x00007fc0bdfa6b00> #<Tag:0x00007fc0bdfa6948>

Hello,

  • OpenMandriva Lx version:
    OM Lx 4 final

  • Desktop environment (KDE, LXQT…):
    KDE

  • Description of the issue (screenshots if relevant):
    Installation not working

  • Relevant informations (hardware involved, software version, logs or output…):
    Lenovo T430, 32" Westinghouse TV as monitor

I downloaded the ISO, burned it to a fresh USB stick, and loaded the stick on my computer.

First time, I set the Displays. Apply. Everything worked, but froze open – the mouse still moved but nothing could be changed or clicked on or opened or closed. I had to do a hard reboot.

Second time, a day later: I set Displays, the Apply button was below the taskbar, it was difficult to move it to where I could click Apply (kept trying to move the whole window to a different workspace) but I did. I then clicked, and then double-clicked, Install Now, and nothing happened.

This might be something we did not see in testing because no one has the same hardware and I don’t know of any testers using a TV as monitor. If it is a bug then we’ll probably need to get devs involved. Developers will want more information about the hardware and the problem. All of the following needs to come from the computer having the issue while logged into OM Lx 4.0.

  1. journalctl output in a .txt file and attached here.

    $ journalctl > journalctl.txt

  2. Xorg.0.log in a text file and attached here.

    $ cp /var/log/Xorg.0.log > Xorg.0.log.txt

  3. xorg-session.log as .txt file attached here. (Where you replace uname with your user name)

    $ cp /home/uname/.local/share/sddm/xorg-session.log xorg-session.log.txt

  4. Hardware info with inxi command. (Again attach the .txt file here)

    $ inxi -F > inxi-F.txt

If you will do that I’ll give a shout out to our developers. Don’t be surprised if they ask for some things in addition to what I posted here. These types of problems can be difficult to get to the cause especially if noone has the hardware to reproduce your issue.

Moderator duties:

I split topics from an original post with multiple issues to make the technical issues easier to follow.

Note: To all users we also do this to make it possible for users and developers to find issues when they search the forum.

1 Like

Splitting the issue makes it doubly hard for me to update the issue.

Logging into OM4 and getting these results is quite difficult, as I’m freezing at the point where I hit the “Install OM4” button.

I apologize in advance for my aging vision, which requires much larger print than I can get on a 14" laptop.

And “not well working” is not good English.

Can we just recompile these into "I can’t get OM installed because the whole thing freezes (except my mouse) BEFORE I CAN INSTALL IT?

If I understand correctly you are tying to run the ISO ‘LIve’ while using a TV as monitor. This is definitely not the typical install or something we planned for or tested. And My best guess this is exactly what is causing the freezing. Running a ‘Live’ ISO is not even close to an installed system in terms of speed and ability to handle a lot of information.

So the first thing is for you to simply try using the ‘Live’ ISO without the TV monitor and see if that works so we can pin down exactly where the problem lies. Apologies for any inconvenience for you but we need to know this first.Then we are sure it is “OM Lx 4.0 ‘LIve’ ISO does not work with TV Monitor”

Basically this is done because of strong request from Developers. They hate multiplke issues in one thread. It is to hard for them or anyone trying to follow to keep straight what is what.

Also forum rules. It becomes impossible for user to find an issue with search if it is buried in shotgun threads with multiple issues. "Search’ searches the titles as far as I know.

1 Like

I’m not an English speaker I’m American. :astonished:

(Humor, but you all knew that right?)

Seriously, I just tried hooking up a Samsung TV to my compurter with hdmi cable and so far I can’t get it to work. This may just mean I don’t know how to do this. In SystemSettings it show up indicating that hardware is seen by system but it won’t enable. If I boot with only the TV I see black screen windows made famous.

Note: Compositor settings in SystemSettings do not seem to be respected. If I reboot they reset to a default regardless of my changes. This is disturbing.

Post-edit: In other words I’m trying to get to where I can attempt to reporduce the problem. Thought I should get this working in installed system first before trying with ‘Live’ ISO.

I don’t think using a TV with hdmi connection works. I tried:

$ xrandr -q
...
HDMI-2 connected (normal left inverted right x axis y axis)
   1920x1080     60.00 +  60.00    50.00    59.94    30.00    25.00    24.00    29.97    23.98
...

$ sudo xrandr --addmode HDMI-2 "1920x1080"

$ xrandr --addmode HDMI-2 "1920x1080"

Working with developer on this. So far we know something is not working correctly but not what or why. So will report when I know more.

I use a standard VGA cable connection for my TV.

I would poiint out that I did not have this problem with 3.03, 4 Alpha, or 4 Beta. So something may have changed since the Beta. I had other issues, and was looking forward to seeing them fixed in the Final (I rarely even check out the Alpha or Beta of a distro).

I’m glad to know it’s not just my hardware.

Ok let’s start at the beginning with this one.
The first difficulty is that this Lenovo has dual graphics cards.
Intel HD Graphics 4000
NVIDIA NVS™ 5400M
This is nasty because the system does not know which one to activate. This is made worse because you have the TV monitor plugged it which will be auto-detected by the X server. Since the HDMI port is almost certainly connected to the nVidia card the nVidia card will be activated. Unfortunately the default boot process will probably have activated the Intel graphics. This situation can cause issues with the X server we have seen this in the past.
The first thing to try is unplugging the TV monitor for the time being and trying to boot the iso to the laptop screen .
If this does not work then step two is to boot to a non-graphical mode so that we can diagnose the the issue. To do this choose the Troubleshooting option and pick the second option “Start Openmandriva Lx live in CLI mode”
This should boot you to a terminal screen where we can run some diagnostics
Run this command…
lsmod | grep nouveau
If this returns 7 or 8 lines with nouveau in them we can probably get you going.
Let us know what you find and we will advise further.

Actually, no it doesn’t. My T430 only has Intel 4000 graphics. And I have the TV plugged in as a VGA monitor, not HDMI.

This was taken from my Terminal on Linux Mint 19.1:

zaivala@zaivala-ThinkPad-T430:~$ lsmod | grep nouveau
zaivala@zaivala-ThinkPad-T430:~$

So, no news for me? That will seriously affect my review for Distrohoppers’ Digest.

Please consider also it’s holidays time, human beings need some rest, sometimes.

1 Like

Perhaps, and I hope everyone is enjoying what holidays they observe, but this has been going on for a while now. And I do a new podcast each month, with a distro being used for an entire monthand this was the month to be trying out OM 4.

NEW INFORMATION:

At the risk of severe eyestrain and with the help of a magnifying glass, I got the brilliant idea to try to install OpenMandriva Lx 4 FIRST, and THEN change the monitors. The Displays program worked great, and then refused to close, with the same issue I had before – the mouse pointer moved, and nothing else did.

STILL ANOTHER ISSUE, but one which is on Calamares’ doorstep: Calamares has developed a problem where, when you try to install onto an alread-in-use partition, it creates an imaginary partition and formats both the imaginary partition and the partition you wanted to install to, and the installation gets split between the two, resulting in a broken installation. I had this problem first with Feren OS and now with OM Lx 4. This is a new issue for Calamares, as it did not have this problem with Lx 3 (had another issue which was fixed easily) or the Alpha or Beta, so both you and Feren seem to have picked it up at about the same time. You need to ignore this for the most part, and I have just reported this to Calamares.

This needs a bug report. Post-edit: And a bug report is going to need some information. Like the already requested information. It is not reasonable to expect developers to try to problem solve when they have nothing to work with.

The best problem solver we have has been away recently and still is this week.

Well, now I can certainly try to get that information for you, since the install worked. If the system does not automatically set my monitor and freeze, that is. So I will try.

For an easier and quicker way to provide some information you could do this:

$ sudo sh /usr/bin/omv-bug-report.sh

That will create the file ‘omv-bug-report.log.xz’. Attach that to any bug report and also upload that to this thread. That file may have enough so we have something to work on.

Here’s what I did to try and reproduce this issue. I disconnected my regular monitor and plugged in my TV (hdmi cable in my case) and rebooted my fully updated Rock system. I am writing this while viewing my desktop on my TV. So I can not reproduce the problem myself.

I can report that when I boot this way with TV instead of regular monitor my wifi does not work and is not seen by nmcli which is odd as you would not think that would be affected by graphics. But with ethernet connected all appears to be working here.

Post-edit: Upon rebooting with TV as monitor it seems that things are sometimes hesitant, you have to wait for things to work until desktop settles in, and sometimes wifi does work, sometimes it doesn’t. But for my hardware this does seem to be working now.

Post-edit-2: Don’t know for sure about this but based on what I’m seeing when you see your system appear to “freeze” maybe that is temporary and if you wait long enough system will start working. That is what it seems like here.