New OMLx 4.0 ISO available for testers

New X86_64 ISO # 2476 available for testers here.

Please feel free to report on this ISO here.

However if you have an issue please open a separate thread with a descriptive title specific to your issue. We try to encourage the principle of one issue=one thread to make it possible for other users to find each and every issue reported when they do a forum search.

1 Like

The ISO did not include LibreOffice because it was still being built for Lx 4. It is ready now.

$ sudo dnf install libreoffice

and if one wishes:

$ sudo dnf install libreoffice-kde5

libreoffice-kde5 provides better integration with KDE/Qt but there have been reports of problems with it so it is an optional extra.

1 Like

can you please Add nvidia settings? and steam? Gog gog

sudo dnf install libreoffice

and if one wishes:

$ sudo dnf install libreoffice-kde5

I got a lot of issue:


OpenMandriva 4.0 - x86_64           1.3 kB/s | 169  B     00:00    
Failed to synchronize cache for repo 'openmandriva-x86_64'
OpenMandriva 4.0 - x86_64 - Updates 1.4 kB/s | 169  B     00:00    
Failed to synchronize cache for repo 'updates-x86_64'
Ignoring repositories: openmandriva-x86_64, updates-x86_64
Last metadata expiration check: 16:34:01 ago on Mon 06 May 2019 04:26:11 AM CEST.
Feil: 
 Problem: package libreoffice-kde5-1:6.2.1-1.x86_64 requires libuno_sal.so.3()(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libuno_sal.so.3(UDK_3_0_0)(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libuno_cppu.so.3()(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libuno_cppu.so.3(LIBO_UDK_4.4)(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libuno_cppu.so.3(UDK_3.1)(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libuno_cppu.so.3(UDK_3_0_0)(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libuno_cppuhelpergcc3.so.3()(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libuno_cppuhelpergcc3.so.3(UDK_3_0_0)(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libuno_sal.so.3(LIBO_UDK_3.6)(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libuno_sal.so.3(LIBO_UDK_4.0)(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libuno_sal.so.3(LIBO_UDK_4.1)(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libuno_sal.so.3(UDK_3.3)(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libcomphelper.so()(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libuno_cppuhelpergcc3.so.3(LIBO_UDK_3.9)(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libtllo.so()(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libuno_salhelpergcc3.so.3()(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libuno_salhelpergcc3.so.3(UDK_3_0_0)(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libvcllo.so()(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libsotlo.so()(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libuno_sal.so.3(UDK_3.1)(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libutllo.so()(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libi18nlangtag.so()(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libbasegfxlo.so()(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libucbhelper.so()(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libi18nutil.so()(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libjvmaccesslo.so()(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libvclplug_genlo.so()(64bit), but none of the providers can be installed
  - package libreoffice-kde5-1:6.2.1-1.x86_64 requires libreoffice-common = 1:6.2.1-1, but none of the providers can be installed
  - conflicting requests
  - nothing provides libhunspell-1.6.so.0()(64bit) needed by libreoffice-common-1:6.2.1-1.x86_64
  - nothing provides libboost_locale.so.1.69.0()(64bit) needed by libreoffice-common-1:6.2.1-1.x86_64
  - nothing provides libboost_date_time.so.1.69.0()(64bit) needed by libreoffice-common-1:6.2.1-1.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
[larsmartin@PC2 ~]$ sudo dnf install libreoffice
OpenMandriva 4.0 - x86_64           1.4 kB/s | 169  B     00:00    
Failed to synchronize cache for repo 'openmandriva-x86_64'
OpenMandriva 4.0 - x86_64 - Updates 1.4 kB/s | 169  B     00:00    
Failed to synchronize cache for repo 'updates-x86_64'
Ignoring repositories: openmandriva-x86_64, updates-x86_64
Last metadata expiration check: 16:34:12 ago on Mon 06 May 2019 04:26:11 AM CEST.
Feil: 
 Problem: package libreoffice-1:6.2.1-1.x86_64 requires libreoffice-draw = 1:6.2.1-1, but none of the providers can be installed
  - conflicting requests
  - nothing provides libpoppler.so.85()(64bit) needed by libreoffice-draw-1:6.2.1-1.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

How do you change user image on login screen on LX4?
Its a issue with hdd its tun off and on when i go to HDD devises and its slow boot 5 minutes after a clean install on my samsung SSD 840 evo.

  1. NVIDIA binary drivers should be available before or at the time of the official stable release.

  2. Steam? Steam is available. Just in non-free repo. You need first enable non-free repo and then install steam. How to enable repos:

sudo dnf config-manager --enable cooker-x86_64-unsupported cooker-x86_64-restricted cooker-x86_64-non-free

Above command enable unsupported, restricted and non-free repo. You can tweak this command to just non-free or use all.

3 Add GOG? How? How we can add proprietary WINDOWS/MAC only software to Linux distro? gog galaxy is not available for Linux still. They dont have money/manpower or just dont want release it for Linux. Ask gog.com folks, not us. Read more about this here: Looks like GOG Galaxy won't come to Linux any time soon, as it's "not a priority" | GamingOnLinux

BTW.
Lutris can run GOG games. Install it via

dnf install lutris

or even better

gamehub is similar to lutris app but support downloading native/non-native games from GOG and run it out-of-box as native or wrappled games.

dnf install gamehub

2 Likes

Technically there’s nothing that would prevent us from adding GOG Galaxy in non-free on x86 only – the package would just contain the Windoze version and a “Requires: wine” line in the spec…

Whether or not we want to do that is actually a valid question.

Obviously one reason to do it is that it would make stuff instantly available that isn’t available on other distros (and for some reason some people are scared of typing “wine something.exe” but not scared of running binary-only native applications – why? No difference at all…)

One reason not to do it is that we’d probably get endless requests for “package this Windows application the same way” (but if we can find volunteers to do it, actually, why not?)

2 Likes

Users please keep in mind that this is a development version using developer (Cooker) repositories.
Expecting everything to be trouble free is not realistic, there can be problems. Development release is for testing to discover and correct as many problems as we can. The ISO file says “OpenMandrivaLx.4.0-beta” for a reason.

There will be a repository split soon when we create repositories for OM Lx 4 and that will isolate users somewhat from the trauma of using something while developers are working on it. That will happen about the same time as we do our RC (Release Candidate) release. RC is last step before GA (General Availability) release. GA is the final or public release marking the release as “stable”.

1 Like

:+1:

Even if current cooker development release is way better than OMLx 3 has ever been imho, always keep in mind: cooker is cooker! :crazy_face:

1 Like

A post was split to a new topic: Few things found not working in Lx 4.0

6 posts were merged into an existing topic: Few things found not working in Lx 4.0

New X86_64 ISO # 2476 available for testers here .

Is it some reason that download from that server is very slow?
Its is more server that it can be uploaded to?

Hi since the announcement, I cannot access to the abf web server. Am I the only one?

I did not find the server slow, yesterday I downloaded ISO in few minutes.

All the development releases are only at ABF.
Once we’ll have RC out it will be available also at SourceForge, and maybe some alternative location too.

1 Like
 Problem: conflicting requests
  - nothing provides libgl1 needed by steam-1.0.0.61-1.x86_64
  - nothing provides libSDL1.2_0 needed by steam-1.0.0.61-1.x86_64
  - nothing provides libdbus-glib-1_2 needed by steam-1.0.0.61-1.x86_64
  - nothing provides libdbusmenu-gtk2_4 needed by steam-1.0.0.61-1.x86_64
  - nothing provides libdri-drivers needed by steam-1.0.0.61-1.x86_64
  - nothing provides libfreetype6 needed by steam-1.0.0.61-1.x86_64
  - nothing provides libgconf2_4 needed by steam-1.0.0.61-1.x86_64
  - nothing provides libgcrypt20 needed by steam-1.0.0.61-1.x86_64
  - nothing provides libgdk_pixbuf2.0_0 needed by steam-1.0.0.61-1.x86_64
  - nothing provides libglu1 needed by steam-1.0.0.61-1.x86_64
  - nothing provides libgtk-x11_2.0_0 needed by steam-1.0.0.61-1.x86_64
  - nothing provides libice6 needed by steam-1.0.0.61-1.x86_64
  - nothing provides liblcms2_2 needed by steam-1.0.0.61-1.x86_64
  - nothing provides libopenal1 needed by steam-1.0.0.61-1.x86_64
  - nothing provides libpango1.0_0 needed by steam-1.0.0.61-1.x86_64
  - nothing provides libpng16_16 needed by steam-1.0.0.61-1.x86_64
  - nothing provides libpulseaudio0 needed by steam-1.0.0.61-1.x86_64
  - nothing provides libsm6 needed by steam-1.0.0.61-1.x86_64
  - nothing provides libva1 needed by steam-1.0.0.61-1.x86_64
  - nothing provides libvdpau1 needed by steam-1.0.0.61-1.x86_64
  - nothing provides libvorbis0 needed by steam-1.0.0.61-1.x86_64
  - nothing provides libxcb-dri2_0 needed by steam-1.0.0.61-1.x86_64
  - nothing provides libxcb-glx0 needed by steam-1.0.0.61-1.x86_64
  - nothing provides libxtst6 needed by steam-1.0.0.61-1.x86_64
  - nothing provides libcurl4 >= 7.63.0 needed by steam-1.0.0.61-1.x

So not easy to install steam, did you have some fix? Its not a easy way to fix it?

Yes it is easy. Be patient. Wait until everything gets fixed. You are using cooker repositories which are always in development. I have every confidence that the @AngryPenguin will get this working soon enough.

Edit: Problems like this usually just mean a package needs to be rebuilt for updated dependencies. Again, just wait until developers have a chance to do this. This is why we keep tying to explain to you and other users the nature of using cooker. Expect problems. If you are using cooker and you expect no problems you will be disappointed. And after OM Lx 4.0 is released this part changes and users are seperated from development process. (Basically after repositories are split.)

You need to enable the 32-bit repositories – steam is mostly a 32-bit application, and therefore requires all sorts of 32-bit libraries (like all the ones you listed).

1 Like

But how to set up: https://pkgs.org/download/mandriva-control-center can i use this one? Or its other that i can use?

I think openmandriva LX 4 its not so bad to be in beta, but lot packes is missing or not setup.
I also have issue with LX3 but its works better, but did not have updated packages than LX4.
Its it some bug issue list? So i know what is wrong with LX4 beta?

Thanks @bero. Silly me I forgot all about 32 bit stuff. And that Steam is 32 bit dependent.

Apologies for my incorrect information above @lmh1. What @bero says should get you resolved as far as Steam.

However the points about cooker I stand by. But it’s like I’ve completely forgotten about 32 bit anything…

https://issues.openmandriva.org/

You need to enable the 32-bit repositories – steam is mostly a 32-bit application, and therefore requires all sorts of 32-bit libraries (like all the ones you listed).

I did not get answer about LX3, but i think i get error also with start steam.
So its more setup with openmandriva? Because its look like run steam runtime or diskspace error is a issue with openmandriva only, its works better with fedora\ubuntu or other distribution? Do you have idea why?

Did you ask a specific question?