Log In Screen does not appear on LX4.1 after upgrade

Tags: #<Tag:0x00007fe460321508>

Hello,
I am using Open Mandriva since 2005 and thank you for all your great job.
Unfortunately my newly installed LX4.1 went wrong and i cannot longer connect.
First i have installed LX4.1 on my SSD from OpenLive and it was working some weeks. Then i tried to upgrade and install some tools but not with discore and here started my trouble. From this time the connect screen had no longer appeared and i can’t connect to a KDE session.
I’ve tried all commands using this post:
failure-to-load-login-screen-please-help / 3605
But nothing works and i even can’t overwrite with an installation from LiveOpen usb disk.
Can somebody help me ?
I thinck it is just an installation trouble but i can’t find the issue.
With an console connection on root, I have tried:
$ rpm -qa sddm
wich gives
sddm-0.18.1-6.20200507.4.x86-64

$ sudo dnf clean all && sudo dnf upgrade
or
$ sudo dnf clean all && sudo dnf downgrade
No effects
the /etc/sddm.conf file seems as described in the post (session=plasma and current=breeze)
With journalctl -bx
I can see that sddm starts but shutdown just some seconds after.
I tried to install new rpm but the first one hasn’t finished after 2 hours ! So i turn off my computer.

I am using Lx on an ols msi x64 mob with athlon 64 x2.

Thanck you for all your helps.

Welcome @Logui

That is the wrong version of sddm for OM Lx 4.1. OM Lx 4.1 main repository has only one version of sddm and it is ‘sddm-0.18.1-5.20191216.1’.

Could you please post output of:

$ cat /etc/release

And also:

$ dnf repolist

Helpful hint for posting technical topics in this forum: Please post code as code with the </> icon in the reply window. If you forget this, as I sometimes do, you can go back and edit your post accordingly.

This makes if easier for people trying to help resolve issues to understand what is and is not code.

Thanck you Ben,
i guess that the OM Lx 4.2 is half installed. I’m using Live One to post so i need to reconnect so as to answer to you.

In your first post you were talking about OM Lx 4.1 now it is OM Lx 4.2?

Exactly what ISO are you using? From where?

To post what I asked for try from the grub2 menu: Advanced Options for OpenMandriva Lx>console mode or recovery mode.

You might be able to use these options to fix your installed system if it is fixable. But first we need to determine what we are working with.

Post-edit: For all users: If you have no internet connection in console mode or recovery mode you use the nmcli command to connect.

Not if :

To explain: The Calamares installer installs everything first and does not install the grub2 bootloader until the end of the installation process. Also if anything did not finish during the installation Calamares would issue a very noticeable error window.

Hello Ben,
To answer your first questions:
</> cat /etc/release:
Release 4.2 (Argon)
</> dnf repolist
rpmdb:(null) on 20 lines
rock-upgrade-x86_64
rock-x86_64
</> dnf clean all: 20 lines deleted

The ISO i did have used is Live OpenMandriva Lx 4.1
I still use it to post this:
Operating System: OpenMandriva Lx 4.1
KDE Plasma Version: 5.17.5
KDE Frameworks Version: 5.66.0
Qt Version: 5.14.1
Kernel Version: 5.5.0-desktop-1omv4001
OS Type: 64-bit
Processors: 2 × AMD Athlon™ 64 X2 Dual Core Processor 4000+
Memory: 3,7 Gio

:wink:

Add:
I have tried to make an another downgrade as the command rpm -qa sddm has returned this time :
sddm-0.18.1-5.20191216-1.x86_64

How are you using the downgrade command?

OK, you can not use this:

and end up with this:

So something is missing from your explanation of what you have done.

Also the way to post code is like this (in the reply window look for the icon </>):

cat /etc/release:
Release 4.2 (Argon)

What you are posting is so confusing I would suggest you start over with a fresh install of this.

After installation enable Rock repositories only. Do not under any circumstances enable Cooker or Rolling repositories.

Further explanation: If you have correctly installed an OM Lx 4.1 system from OM Lx 4.1 ISO and used the correct repositories you should be seeing this:

$ cat /etc/release
OpenMandriva Lx release 4.1 (Mercury) for x86_64

Unfortunately once a user has done something to upgrade their system to OM Lx 4.2 (aka: Cooker or Rolling) then the only solution to get back to OM Lx 4.1 is a fresh install.

Hello @Logui,

In addition to @ben79 's comments, here is a short explanation of repositories and how to manage them.
https://wiki.openmandriva.org/en/doc/repositories-tldr

1 Like

Ok, sorry if my post is so confused, I thinck it si because the system went confused.
So first i have made my installation of Lx 4.1 with the live disc.
Then it has worked well some weeks.
I needed to install some tools and i did upgrade Lx like I am used to (that is my mistake) instead of discover.
Since this last installation I no longer got the connexion screen sddm.
I have tried some commands found in the post failure-to-load-login-screen-please-help
wich gave no successfull results
I tried to downgrade with the command:
sudo dnf clean all && sudo dnf downgrade sddm
I can’t explain why it has used à cooked or rolling rpm instead of rock (may be i have made a wrong selection).
The result is what you had sayed: no upgrade or downgrade is possible.
Most of my trial were done on sunday but mirrors were unreachable.
I hope my post is less confused.
Finaly I already had tried to make a new install of Lx 4.1 from the live mandriva one usb but it is blocked when choosing the partition: from this point nothing is possible except cancel. Like it has detected a previous installation of Lx4.1 and didn’t want to overwrite it.
Do you think it will work with the link you have given me ?

Alt! :grin:

Forget Discover, for now (and maybe also forever).

To update system:
$ sudo dnf clean all ; dnf clean all ; dnf repolist

dnf repolist output should read only /main and main/updates repository

$ dnf repolist
id repo nome repo
rock-updates-x86_64 OpenMandriva Rock - x86_64 - Updates
rock-x86_64 OpenMandriva Rock - x86_64

if not, open Software Repository Selector (om-repo-picker) and disable everything except the above mentioned /main repository.
https://wiki.openmandriva.org/en/doc/repositories-tldr
Pay special attention to /testing section: it should never be enabled.

To update system:

$ sudo dnf clean all ; dnf clean all ; dnf repolist
$ sudo dnf --refresh upgrade

Now you are done with the very first step.

Then:

$ sudo dnf --refresh install <some_package>
$ sudo dnf --refresh install <another_package>

etc.

If you need some packages that belong to /unsupported or /restricted, start again Software Repository Selector select the relevant repository and refresh the repository lists:

$ sudo dnf clean all ; dnf clean all ; dnf repolist
$ sudo dnf --refresh install <some_package>

(Note: please read the note about /non-free repository)

You should have a “Replace a partition” (or so) in Calamares.
Note that if you are trying to change filesystem type, Calamares won’t do it.

Other option is to use KDE Partition Manager to delete the partition before to proceed with installation.

1 Like

Can you show us what you mean with screen-shots?

Yes, of course it will, you already installed OM Lx 4.1 once why would it not install again? Just start over from the beginning.

This Issue is resolved with great help from Ben and Rugyada.
by making a new install.

The trouble was an unwilling upgrade from rolling or cooker release with a sddm crashing on each start. No upgrade or downgrade was possible (explaination given by Ben).
When I have tried to install, i expected OM Live to did it as the first install.
In fact I needed to choose “Replace a partition” in Calamares (explaination given by Rugyada) AND to click on this partition to select it. Then the “continue” button is actived so as to perform the install.
Now i had to create all the users to access existing directories.

Thank you !

Please just two more questions:

  • will upgrade be done itself or should i do it with the dnf commands ?
  • User/Group ID now starts from 1000, is it safe to start from 500 as it used to be ?
1 Like

Glad that you solved.

Some hints in this topic.

I prefer to disable automatic stuff and to update from command line instead, so I can see in real time what’s going on (and just in case to abort the update).