KVM / virt-manager

Hi all,

I did a fresh install of OpenMandriva Lx version: 4.3 (Desktop environment KDE Plasma) and then I tried to install virt-manager via dnf! The install went fine, I added my user to the libvirt group, but I still cant create any virtual machines… What additional steps are required to get this working?


Welcome @uxman to OM Community and the forum.

Thanks for reporting the issue.

Hello Claus,
verify you installed at least an hypervisor, usually installing qemu is enough, then add the properly connection as suggested by the application itself.
If this doesn’t resolve please report a snapshot of of the error.

Hello mandian,

installing qemu pulled in some stuff:

qemu                           x86_64            3:6.2.0-1               rock-x86_64            7.2 k
Installing dependencies:
 ipxe                           noarch            3:6.2.0-1               rock-x86_64            278 k
 lib64capstone4                 x86_64            4.0.2-1                 rock-x86_64            634 k
 lib64spice-server1             x86_64            0.14.3-2                rock-x86_64            353 k
 lib64virglrenderer1            x86_64            0.8.1-1                 rock-x86_64            172 k
 qemu-common                    x86_64            3:6.2.0-1               rock-x86_64             16 M
 qemu-img                       x86_64            3:6.2.0-1               rock-x86_64            1.3 M
 qemu-user                      x86_64            3:6.2.0-1               rock-x86_64             18 M
 seabios                        noarch            3:6.2.0-1               rock-x86_64             76 k
 sgabios                        noarch            3:6.2.0-1               rock-x86_64            9.1 k

but still the same behavior of virt-manager…

You mean I should file a bugreport?

You may post here a screenshot of the error you receive or I can’t understand what is the error

After looking at the status of the libvirtd.service via systemctl I saw that also qemu-kvm was missing! I installed it via dnf and now the service starts fine:


ibvirtd.service - Virtualization daemon
     Loaded: loaded (/lib/systemd/system/libvirtd.service; enabled; vendor preset: enabled)
     Active: active (running) since Thu 2022-02-24 20:34:28 CET; 26s ago
TriggeredBy: ● libvirtd-ro.socket
             ● libvirtd.socket
             ● libvirtd-admin.socket
       Docs: man:libvirtd(8)
   Main PID: 797 (libvirtd)
      Tasks: 21 (limit: 32768)
     Memory: 22.9M
     CGroup: /system.slice/libvirtd.service
             ├─ 797 /usr/sbin/libvirtd --timeout 120
             ├─1026 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf --leasefile-ro>
             └─1027 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf --leasefile-r

All together I installed virt-manager, qemu and qemu-kvm with the added dependencies…

If I start VirtManager, I see the window, I can connect to kvm but I cannot create a virtual machine! No error is shown at the gui!

Please post code as code. Thanks.

Hello Ben,

Yes I will… sorry

Does anybody has a OM Lx 4.3 with VirtManager / KVM virtualization working?

In the contributor group people use either VirtualBox or Qemu. I am not sure how what you are asking about is different from Qemu. It is mostly people a developer level that use Qemu.

@uxman from your previous screenshot i can not understand what is going wrong. Can you reach this step?

Also you need qemu-img package installed.

@ben79 virt-manager is a gui by readhat for many virtualization or container software handled by libvirt. It’s a sort of virlualbox, imo is more versatile but it’s for linux only.

Hello mandian,

qemu-img was also missing and I did install it! But no change…
No, I cannot reach the step at your screenshot!
I can (right) click on QEMU/KVM, then I see NEW / DISCONNOCT / DETAILS, but thats it…

that’s right.

You mean when you clock on the first icon on the right no window NEW VM appears?

I have already said I do not know anything about this. However I installed virt-manager and qemu-kvm. Then ran:

$ sudo systemctl status libvirtd

When I open Virtual Machine Manager I am asked for root passwd, after entering that I is see this:

When I select New nothing happens, nothing opens. Running from Konsole there is no ouptput. Overall the application is unresponsive. Nothing open.

May you try to launch it from terminal with:

$ virt-manager --debug

Also may you report the output of

$ rpm -qa | grep -i gtksource

What it wants when opened is for the user to add a connection. I do not really want to get in to this at this time. But this is what “Add Connection” shows:

So to me that looks like it would work if user enters the requested information. I am unsure what it really wants for user and host names.

virt-manager.txt (13.8 KB)

$ rpm -qa | grep -i gtksource

Hope this helps.

If someone did a “How To” for setting up a VM using this software I would consider giving is a try. Maybe this is better than VirtualBox? Or is it?

Sorry for so many posts but figuring out as I go:

This is the output for virt-manager --debug if I select to use auto connection and then try to select “New”:

virt-manager-2.txt (14.5 KB)

Post-edit: Adding journal log.

journal.txt (188.7 KB)

user and host names are required only if you are trying to connect to a qemu instance on a remote machine over SSH, so shortly just click on Connect.

IMO yes. IT is a front-end for qemu and other hypervisor or container software running on linux like system. Because qemu has lots of options and setting them every time at launch time is not really easy, a simplified gui a virt-manager helps a lot.

Waha is different from other software like VBox is virt-manager is just a gui so it let you choose what hypervisoy/containes software you really want to use. So at first open it ask you to select which software you want to use and this is what it calls connection. If you installed qemu-kvm on your pc all you need is to connect virt-manager to QEMU with the window you’re already opened by clicking on Connect. Of course you may use more than one hypervisor/container software form the ones it supports (eg qemu, LXC, Xen) and the first time you have to Connect them.

Once you connected QEMU you can add VM under it so virt-manager may know you want to virtualize a box using qemu by opening the menu (right clink on QEMU row) and selecting New.

The VM creation is similar to other software. It usually put VM files and ISOs in /var/lib/libvirt/ path. This may be changed (eg. sometime I prefer to put them under my home) but you need to pay attention to perms of the folder.

Also your user should be member of a group named libvit (or libvirt-qemu, i don’t remember this now).

Another thing you need to know you can’t select file from the disk directly but you need to create pool before. This just mean you have to say to virt-manager what folders it may have access.

Then If it won’t open anything when I select “New Virtual Machine” it must be broken?