Verifica GPG fallita?

omlx-40
aggiornamento
Tags: #<Tag:0x00007fbb5039c4f8> #<Tag:0x00007fbb5039c3b8>
(Stefano) #1

Ciao. Sto aggiornando la mia Oma, trovo 1947 (!) aggiornamenti, scarico e, al momento di installare, mi dice; Verifica GPG fallita e non installa nulla. Tutti i pacchetti scaricati vengono indicati come non firmati… Fatto da consolle con dnf upgrade.

0 Likes

(rugyada) #2

Si, problema temporaneo in via di risoluzione ma ci può volere un pochino di tempo.
Per il momento disabilita la verifica gpg check come nel mio file qui

/etc/yum.repos.d/cooker-x86_64.repo

poi
sudo dnf clean all ; dnf clean all ; dnf repolist

poi
sudo dnf --refresh upgrade
(anche più volte)

Il comando per la pulizia della cache è essenziale.

1 Like

(Giorgio) #3

Risolto un problema eccone subito un altro

(305/2007): lib64KF5BalooEngine5-5.56.0-2-omv4000.x86_64.rpm                                                         123 kB/s |  51 kB     00:00    
[MIRROR] lib64KF5BluezQt-qml-5.56.0-2-omv4000.x86_64.rpm: Status code: 404 for http://abf-downloads.openmandriva.org/cooker/repository/x86_64/main/release/lib64KF5BluezQt-qml-5.56.0-2-omv4000.x86_64.rpm
[FAILED] lib64KF5BluezQt-qml-5.56.0-2-omv4000.x86_64.rpm: No more mirrors to try - All mirrors were already tried without success                   
(307-308/2007): kernel-firmware-extra-20190326-1-omv400 27% [==============-                                       ] 353 kB/s | 253 MB     32:35 ETA
I pacchetti scaricati sono stati salvati nella cache fino alla prossima transazione completata con successo.
È possibile rimuovere i pacchetti in cache eseguendo 'dnf clean packages'.
Errore: Errore nello scaricamento dei pacchetti:
  Cannot download lib64KF5BluezQt-qml-5.56.0-2-omv4000.x86_64.rpm: All mirrors were tried

A questo punto aspetto la versione corretta dei pacchetti.

0 Likes

(rugyada) #4
lib64KF5BluezQt-qml-5.56....

E difatti non c’è lì, c’è il 57 :slight_smile:

Se hai scritto in questo thread, do per scontato che hai disabilitato gpg check e dato i comandi come suggerito. Adesso io insisterei con i comandi. Probabilmente continuerà ad aggiornare quello che può in quel momento, poi forse si bloccherà di nuovo. Ma tu insistisci :stuck_out_tongue:

(Se proprio non se ne esce invece torna, e vediamo di scoprire il motivo)

1 Like

(Ben Bullard) #5

See this.

0 Likes

(Giorgio) #6

Insistito :slightly_smiling_face: e sono riuscito ad aggiornare.
Se dovesse capitare di nuovo userò il comando --nogpgcheck.

1 Like

(rugyada) #7

E’ un problema momentaneo, ma che potrebbe durare qualche tempo.

1 Like

(Giorgio) #8

Oggi ho aggiornato qualche decina di pacchetti con il comando
sudo dnf update --nogpgcheck
senza dover modificare il file /etc/yum.repos.d/cooker-x86_64.repo.

0 Likes

(rugyada) split this topic #9

3 posts were split to a new topic: OMLx 4.0 errore durante l’aggiornamento

0 Likes

(rugyada) closed #10
0 Likes

(rugyada) #11

Ho separato l’argomento perchè non attinente.
Per favore aprite un nuovo topic per ogni nuovo problema.

0 Likes

(rugyada) #12

PS>
Perchè iniziare una nuova discussione per ogni nuovo problema?

  1. Perchè si può chiudere la discussione corrente come risolta e indicare con il check la soluzione;
  2. Perchè chi fa una ricerca (voi usate la funzione ricerca, veeeero?) avendo un problema simile trova subito anche la relativa soluzione;
  3. Perchè vogliamo un forum ordinato e non un’accozzaglia inconsultabile;
  4. Perchè costa tanto uguale.
0 Likes