User can't install more than one kernel-release-desktop-devel version?

kernel
omlx-4
Tags: #<Tag:0x00007ff2b7d79b80> #<Tag:0x00007ff2b7d79860>

(Ben Bullard) #1

Currently I can’t (without using rpm --force) install more than one kernel-release-desktop-devel version. This does not seem correct and certainly has been possible before switch to dnf. Here’s what I mean:

# dnf --refresh upgrade
...
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/lib/.build-id/23/82b40083f52e878c6549ce3f11dd5438bafa09 from install of kernel-release-desktop-devel-4.19.4-1omv4000-1-1.x86_64 conflicts with file from package kernel-release-desktop-devel-4.19.2-2omv4000-1-1.x86_64
  file /usr/lib/.build-id/3f/ba7a21565d69ea20c527c3fab2ff0cb97387e3 from install of kernel-release-desktop-devel-4.19.4-1omv4000-1-1.x86_64 conflicts with file from package kernel-release-desktop-devel-4.19.2-2omv4000-1-1.x86_64
  file /usr/lib/.build-id/49/520a3ff3f1c2ef7f731ceae894822092272160 from install of kernel-release-desktop-devel-4.19.4-1omv4000-1-1.x86_64 conflicts with file from package kernel-release-desktop-devel-4.19.2-2omv4000-1-1.x86_64
  file /usr/lib/.build-id/4a/bbd919a8121734de8d6691ec7bf3f4d5fdfe18 from install of kernel-release-desktop-devel-4.19.4-1omv4000-1-1.x86_64 conflicts with file from package kernel-release-desktop-devel-4.19.2-2omv4000-1-1.x86_64
  file /usr/lib/.build-id/57/0b0fd5af05ba389f7ed47649c50489552c15b4 from install of kernel-release-desktop-devel-4.19.4-1omv4000-1-1.x86_64 conflicts with file from package kernel-release-desktop-devel-4.19.2-2omv4000-1-1.x86_64
  file /usr/lib/.build-id/68/42db6b68da24141fc60abd221b8013ddb9ca9d from install of kernel-release-desktop-devel-4.19.4-1omv4000-1-1.x86_64 conflicts with file from package kernel-release-desktop-devel-4.19.2-2omv4000-1-1.x86_64
  file /usr/lib/.build-id/68/491d7d1a76fdde1112c468ac97a24cfaf5012c from install of kernel-release-desktop-devel-4.19.4-1omv4000-1-1.x86_64 conflicts with file from package kernel-release-desktop-devel-4.19.2-2omv4000-1-1.x86_64
  file /usr/lib/.build-id/6e/f499af9951633942f325837505278ad57c4c24 from install of kernel-release-desktop-devel-4.19.4-1omv4000-1-1.x86_64 conflicts with file from package kernel-release-desktop-devel-4.19.2-2omv4000-1-1.x86_64
  file /usr/lib/.build-id/a1/0bfc031c6283e08c41871b2260e8bfec40aff0 from install of kernel-release-desktop-devel-4.19.4-1omv4000-1-1.x86_64 conflicts with file from package kernel-release-desktop-devel-4.19.2-2omv4000-1-1.x86_64
  file /usr/lib/.build-id/c6/c788b82e619f5d852746bb2b59368849353726 from install of kernel-release-desktop-devel-4.19.4-1omv4000-1-1.x86_64 conflicts with file from package kernel-release-desktop-devel-4.19.2-2omv4000-1-1.x86_64
  file /usr/lib/.build-id/ce/96fdc9af0a88d7beae915fc0ccc6e068a3bd65 from install of kernel-release-desktop-devel-4.19.4-1omv4000-1-1.x86_64 conflicts with file from package kernel-release-desktop-devel-4.19.2-2omv4000-1-1.x86_64
  file /usr/lib/.build-id/f4/1154a20b00bceb2f555b88e626d74ff0a5d0c4 from install of kernel-release-desktop-devel-4.19.4-1omv4000-1-1.x86_64 conflicts with file from package kernel-release-desktop-devel-4.19.2-2omv4000-1-1.x86_64
  file /usr/lib/.build-id/f5/c996abc4b96fe5a3252e055d57e06cf47f3127 from install of kernel-release-desktop-devel-4.19.4-1omv4000-1-1.x86_64 conflicts with file from package kernel-release-desktop-devel-4.19.2-2omv4000-1-1.x86_64
  file /usr/lib/.build-id/f9/0e18642873d18889b894996f3e3cf4ba80c6b0 from install of kernel-release-desktop-devel-4.19.4-1omv4000-1-1.x86_64 conflicts with file from package kernel-release-desktop-devel-4.19.2-2omv4000-1-1.x86_64
  file /usr/lib/.build-id/fd/2ec7f0cbe90155d68f57ae5e3eafb70fbd7753 from install of kernel-release-desktop-devel-4.19.4-1omv4000-1-1.x86_64 conflicts with file from package kernel-release-desktop-devel-4.19.2-2omv4000-1-1.x86_64

Error Summary

This seems like something that should be fixed before we get to far in to Lx 4 development.


Kernel-release-desktop-devel package conflicts with kernel-release-desktop-devel
(rugyada) #2

I confirm.
Also, it was not the case previously


(Ben Bullard) #3

Duh, how do I merge to threads in to one?

Post-edit: Like you just did… :astonished: Except it looks like you did it bassakwards.

:monkey_face:


(rugyada) #6
$ rpm -qa | grep kernel-release-desktop-devel
kernel-release-desktop-devel-4.18.9-4omv4000-1-1.x86_64
kernel-release-desktop-devel-4.19.2-2omv4000-1-1.x86_64

My command is:

# dnf --refresh install kernel-release-desktop-devel-4.19.2-2omv4000.x86_64

FWIW I updated from 4.18.9.
I have kernel 4.18.17 but I did not install its devel.

$ rpm -qa | grep kernel-release-desktop-4
kernel-release-desktop-4.18.17-1omv4000-1-1.x86_64
kernel-release-desktop-4.18.9-4omv4000-1-1.x86_64
kernel-release-desktop-4.19.2-2omv4000-1-1.x86_64

User can't install more than one kernel-release-desktop-devel version?
(Ben Bullard) #7

This issue persists with kernel-release-desktop-devel-4.19.6 conflicting with kernel-release-desktop-devel-4.19.4.

kernel-devel-conflict.txt (7.3 KB)

This probably ought to be fixed. :smiley:

:monkey:


(Ben Bullard) #8

Issue persists with kernel-release-desktop-devel-4.19.7 conflicting with kernel-release-desktop-devel-4.19.6.

kernel-devel-conflict.txt (10.6 KB)


#9

If I remember correctly, last night I updated the cooker to the new 4.19.7 kernel without problems by this command:

dnf clean all && dnf update -y


(Ben Bullard) #10

I run ‘dnf clean all’ frequently. Don’t know why ‘dnf update’ would do anything different from ‘dnf upgrade’? I will try -y and see what difference, if any, that make for this issue.


(rugyada) #11

@AngryPenguin Could you please post the list of the kernel-devel packages you currently have installed in your system?

$ rpm -qa | grep kernel-release-desktop-devel


#12

-y is only for automating the process, you do not need to give consent during the upgrade.

As soon as I return home.


(Ben Bullard) #13
$ rpm -qa | grep kernel-release-desktop-devel
kernel-release-desktop-devel-4.19.4-1omv4000-1-1.x86_64
kernel-release-desktop-devel-4.19.7-1omv4000-1-1.x86_64
kernel-release-desktop-devel-4.19.6-2omv4000-1-1.x86_64
kernel-release-desktop-devel-latest-4.19.7-1.x86_64

#14

Ok, my mistake, sorry.

I have just returned and I see that I do not have a devel package installed at all, only the kernel-release-desktop …
Installing devel for 4.19.6-2 goes fine but when trying install devel for 4.19.7 then I see same issues as you.


(rugyada) #15

No problem :wink:

The point was to know if by chance you had an older kernel-devel, like it happened to me last time I successfully updated it:

$ rpm -qa | grep kernel-release-desktop-devel
kernel-release-desktop-devel-4.18.9-4omv4000-1-1.x86_64
kernel-release-desktop-devel-4.19.2-2omv4000-1-1.x86_64

An expert bug-squasher might find useful to install such old kernel for testing and see what changed.

FWIW I add also that 4.19.2-2omv4000-1-1 kernel+devel has been the last good one for me in order to get the virtualbox shared folders properly working.
After that, no way… :imp: