USB install fails on startkde

Thank you for your reply, unfortunately the install process does not get far enough to enable any sort of interaction, the machine just hangs at the “startkde” box in the top left corner.
The mouse is the only thing that can move at all, but the system will not accept clicks or any keyboard input.
I have to do a hard switch-off.
I tried most variants of install process, various boot types, nomodeset, apci=off, etc etc. all with the same result.

Welcome @barfly.

Helpful hint for all users. Please post code with the </> icon in the window where you write your post.

@barfly your issue may be graphics related. Your hardware information shows nVidia graphic hardware but it does not show what driver kubuntu is using. You may have hardware that is not well supported by nouveau driver.

When you boot the ISO on the grub2 menu look for Troubleshooting:

Then Select “Start OpenMamdriv Lx in Basic Graphics Mode”:

and see if that works. FWIW: Basic Graphics=vesa driver (ancient but almost always works). OM does not exactly support nVdia proprietary drivers but there are drivers available in repositories.

Thanks Ben, that is the first thing I tried. The only way I can actually boot is into a cli, not what I want mandriva plasma for!

Please note Rufus only work in dd mode for the iso.

Booting to cli is fine, from there you do a dmesg and look for things may be broken,
as example DRM errors or a like. Wihtout to know what may cause that we cannot fix it.

Yet better do a dmesg -H so you can scroll down and look for broken things.

So far, 1) it may be a broken written usb image or 2) something is wrong with DRM/X/mesa stack and your HW.


1 Like

Hard to read like you’ve posted that…

1 Like

As far as I know we have not seen any graphic hardware yet that does not work in Basic Graphic Mode.

If OM Lx ISO ‘Live’ does not work in with vesa driver (Basic Graphics Mode) then we would suspect either a corrupted download or a corrupted USB flash drive image. Links are provided if you wish to try to problem solve this. I have had corrupted downloads myself when downloading with a browser. So I always download .iso files with aria2c command:

$ aria2c -c -m 0 <file_to_download.iso>

Post-edit: And then copy the .iso file to USB flash drive:

$ sudo dd if=<iso_name> of=<usb_drive> bs=4M

Post-edit: And by all means check checksums before wasting any time problem solving this.

Thank you all for your assistance here.
Ben-This whole issue is a bit of a mystery to me, this is a machine I use as a backup for my HTPC and also as a testbed for new distros. I have never had a problem with trying any distro before other than Sparkylinux. This has never presented any issue with any Debian based distro, Slackware, Centos, Fedora, Gentoo, Opensuse. I have been able to run all with very few unsolvable issues.
I have tried the live pendrive with my main machine too-different specs. but the same result.
I have downloaded the .iso a total of 6 times putting them on various pendrives and differing download methods, some as .iso some as torrents. I will try your cli download method and report back.

I did look for the checksums, and was unable to find them on the main download mirror at Sourceforge, surely they should be on the main download page?

I surely am not the only one who has experienced these difficulties, or perhaps I am a very experienced Linux user who pursues issues and wants to get to the bottom of these things. I suspect most would give up on the second or third attempt and give up, so you guys would never know. I have been using Linux since one of the very first Mandrake releases in 1998.

abucod… I agree, this was my first posting on here and the site only allowed very basic formatting for me, now I have more options available to make posts more readable.

Thanks again all Tony.

Ben- This is the result from aria2;

tony@linuxmint:~$ aria2c -c -m 0

02/28 07:58:58 [NOTICE] Downloading 1 item(s)
[#cc0597 0B/0B CN:1 DL:0B]                                                                                                                                             
02/28 07:58:59 [ERROR] CUID#7 - Download aborted. URI=
Exception: [] errorCode=3 URI=
  -> [] errorCode=3 Resource not found

02/28 07:58:59 [NOTICE] Download GID#cc05978b16e464ab not complete: 

Download Results:
gid   |stat|avg speed  |path/URI
cc0597|ERR |       0B/s|

Status Legend:

(ERR):error occurred.

aria2 will resume download if the transfer is restarted.

EDIT- Saw the error of my ways, for some reason the command had extra bits on the end, transferring now ok.

OK guys, I d/l the 4.1 image as suggested with aria2. I burned it using dd to the sandisk cruiser 16gb pendrive all on my main desktop machine, not the one I use for testing. I then rebooted this machine to the pendrive and the same result occurred. see the piccie of the failure. This is the same failure with every other d/l and burn I have done.
Getting nowhere fast Tony.

Now this site is telling me I can’t put images in a post… it lets me upload it then says no What the hell is it with this weird site??

specs of this machine:
lshw.txt (30.5 KB)

EDIT dropbox link to piccie: Dropbox - File Deleted - Simplify your life

@barfly please try again now.

1 Like

We do appreciate you reporting this as it gives us an opportunity to correct something we have not seen before.

Your picture includes the error “ISOFS: Unable to identify CD-ROM format” and below that in the red lines we see more similar errors for I/O error, SQUASHFS error. All of which adds up the the image on the USB Flash Drive being unreadable. In order for us to help you could you post exactly how you are burning image to flash drive. Be detailed and start with how you format flash drive. At least we can now be rather certain we know why this is not working.

You could also try another flash drive, these do get broken over time. Next I’ll post what we recommend to burn/copy image to flash drive.

This is from here. This is recommended for OpenMandriva Lx ISO images. Anything else is likely to fail.

== Booting from USB ==

It is also possible to boot this release from an USB storage device. To transfer the live/installation image you may:

You may alternatively dd the image to your USB stick:

$ sudo dd if=<iso_name> of=<usb_drive> bs=4M

Replace <iso_name> with the path to the ISO and<usb_drive> with the device node of the USB drive, i.e. /dev/sdb.

Thank you again for this assistance. I have already done all the things you suggest in your last reply.

The first post in this thread details how I have tried all different methods;

I have tried to install the latest .iso using different methods of putting it onto several different pendrives; the best result so far was with a 16gb Sandisk Cruiser stick…

Rosa and Rufus in Windows, Unetbootin, mkusb and finally dd on a cli in kubuntu 18.04 with differing levels of non-success.

The furthest I managed was with mkusb, where it booted but failed after a few seconds at “startkde”. The startkde error was actually the failure of “kdeinit5”

I have since tried the aria2 download, writing a pendrive with dd, that is when I get the “SQASHFS” (the one I photographed and posted to Dropbox) error after doing a nomodeset kernel parameter boot.

I’ll try another couple of pendrives with the 4.1 aria2 download and writing them with dd and report back on the results.
I think we are running out of ideas now…

Cheers, Tony

OK, I used the previously downloaded image from aria2 the 4.1 release and re-initialised a different usb stick; a Kingston Data Traveller with Gparted, setting it up with GPT and formatting to fat 32.
I then used dd to transfer the image to the pendrive using this command:

root@linuxmint:/home/tony# dd if=/home/tony/OpenMandrivaLx.4.1-plasma.x86_64.iso of=/dev/sdh1 bs=4M status=progress
2740301824 bytes (2.7 GB, 2.6 GiB) copied, 111 s, 24.7 MB/s
653+1 records in
653+1 records out
2740301824 bytes (2.7 GB, 2.6 GiB) copied, 808.205 s, 3.4 MB/s

I then booted with this and got exactly the same result!

initqueue[619]: losesetup: /run/initramfs/omdv/LiveOS/squashfs.img : failed to set up loop device: no such file or directory

Then the same squashfs errors as previously.

I did a quick Google search and this one seems promising, although it is way over my limited abilities:
[LiveOS image/overlay - Fedora Project Wiki](

Maybe you guys can make some sense out of it???

Cheers Tony.

EDIT; I managed to retrieve this from the boot sequence:rdsosreport.txt (44.4 KB)

I think this is the right command

dd if=/home/tony/OpenMandrivaLx.4.1-plasma.x86_64.iso of=/dev/sdh bs=4M status=progress

sdh not sdh1

Ahh, so the pendrive should not be formatted at all?

I’ll give it a shot and report back.

Cheers Tony

EDIT one hr later … Wheeee… it works. Boots straight to Mandriva.

Thanks to all, simple solution in the end. Looking forward to trying it out.

Cheers Tony.

Glad you got it sorted.

Ben- It may be a good idea to put this on the release notes for others.

Cheers Tony