Things are going wrong

Hello everyone,

From my point of view: things are going wrong here. It really shocked me to see multiple users on this forum, who have a system which is not able to boot after updates.

After installing Nvidia drivers on OM Lx 2014.2/3.0, users get a black screen. Why not fixing such a bug instead of developing the next version (3.0)?

From what I have seen, people just can´t rely on their systems, because after an update, there is possibility the system won´t boot anymore. After installing a driver, users get a black screen. Why do these updates get rolled out if they are not tested yet? And if the reason for not testing it is, because there aren´t enough resources, isn´t it better to stop development of OM, instead of releasing a distro with bugs, and updates which have not been tested? Mandriva used to be beginners friendly…

Don´t get my wrong, I love Mandriva, I appreciate the work all of you have done, and I would like to see development continuing with the OpenMandriva distro, but the current situation looks very bad to me.

In my case, what caused black screen after installing nvidia drivers ( and configuring the system to boot using it ) is that nvidia does not takes over if nouveau owns the video card. The workaround is to blacklist nouveau.

Don’t really know but it seems to me that it is not OMV fault although OMV could include a kind of a script to blacklist nouveau in the XFdrake configuration.

I had to remove /etc/X11/xorg.conf and run nvidia-xconfig in the terminal. Indeed a script could solve this problem, because I think it is important to solve it.

@adelson.oliveira : Can you give me a list of all the packages required for the Nvidia drivers (like the developer kernel packages) for i586 and x86_64? I will try to write a script to install the drivers correctly.

Thanks for reporting Did you install nvidia driver with XFdrake? It’s no secret we need more help and testing from users with nVidia and other proprietary hardware. Heck with any hardware…

I installed the driver with XFdrake indeed. After that, I did a reboot and I got a black screen.

How I solved it:

  1. Ctrl+Alt+F2
  2. mv /etc/X11/xorg.conf /etc/X11/xorg.conf.back
    3: nvidia-xconfig
    4: reboot

Isn´t it possible to edit the XFdrake script that installs the driver?

Thanks for the input.

I’m sure it is you just need to find it. I think it’s ‘/usr/libexec/drakx11’.

I’ve workaround the black screen after XFdrake installation/configuration simply blacklisting nouveau byaltering the file /etc/default/grub so as to include xorg.blacklist=nouveau. Did not use nvidia-config. As I said, I don’t know much about all of this, but as far as I could see,

  • XFdrake did the right thing and no additional package would be required.

The problem would be (as described elsewhere) that nouveau uses to take over nvidia video card and once it happened nvidia driver refuses to load. The black screen results from the lack of a loaded nvidia driver. It is important to verify how nvidia-config “told” nvidia driver to load, or take over nvidia video card, even with nouveau on in your case.

Thus, again, as far as I could understand, a script working with nvidia proprietary driver on nvidia video cards would either blacklist nouveau or do whatever nvidia-config did to have nvidia driver loaded upon rebooting.

I just would like to add that if the user got nvidia driver to work by blacklisting nouveau in the grub defaults file as above, he/she will probably have problems if a return to nouveau is desired. For any reason I don’t understand, blacklisting nouveau this way results in erasing the nouveau directory from,


Then, for returning to nouveau one would have to do

$ urpmi --replace-pkgs --replace-files kernel-package

to get nouveau files back.

Maybe blacklisting nouveau is an option too, but I thought the problem was that after the installation of the Nvidia driver, xorg.conf didn´t get updated to start the nvidia driver instead of nouveau. Blacklisting nouveau may be an option to start it, but I ran nvidia-xconfig. nvidia-xconfig generates a new xorg.conf.

This can be found in the xorg.conf generated by nvidia-xonfig:

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”

Driver has been changed from nouveau to nvidia. So I think editing the script, so it removes xorg.conf and generates a new one, may be the best solution, I have no experience with blacklisting nouveau.

PCSoftwarehulp what you are trying to do might be better accomplished in a bug report which gets the attention of developers. Forum posts don’t necessarily do that. Developers would be better able to help with this than users on forum. omv-bug-report.log should always be included with a bug report. More about that here.

I don’t have nvidia graphics. Last time I did XFdrake would create a xorg.conf file that among other things tells system to use nvida, or what ever specific driver name is (like nvidia-current, nvidia-304, ect) and it would automatically blacklist nouveau. If it isn’t doing both of those there is a bug which needs to be fixed. To do that someone with nvidia graphics needs to file a bug report including omv-bug-report.log. In other words XFdrake is supposed to completely configure graphics driver and install any needed packages or there is a bug. To be solved bugs need to be reported.

OpenMandriva systems don’t have xorg.conf by default, graphics are done dynamically during boot process. To my knowledge this is common throughout Linux. I think xorg.conf is only created if user runs XFdrake after install. Normally one would only use XFdrake only if one has proprietary driver or a problem of some sort.

I did the bug report. I don´t know if this is possible, and maybe I am thinking to simple about it, but isn´t it an option to deliver a /etc/X11/xorg.conf.nvidia file as default with an OpenMandriva 2014.3 installation (2014.3 doesn´t exist, but I will try my best to make this possible). If that file exists, users can run after installation, which will install Nvidia drivers succesfully. is a script I created, based on the scripts from om-welcome. If this works, maybe there is a possibility to get it working in XFdrake. I know I should message this to the developers, but I first want to know if it isn´t a horrible/impossible idea.


if rpm -qa |grep -e x11-driver-video-nvidia-current; then
kdialog --title $“OpenMandriva” --msgbox $" Nvidia drivers are already installed.";
if [ “$(uname -m)” = “i686” ]; then
gurpmi kernel-nrjQL-desktop-devel-latest x11-driver-video-nvidia-current && mv /etc/X11/xorg.conf.nvidia /etc/X11/xorg.conf;
if rpm -qa |grep “x11-driver-video-nvidia-current*”; then
kdialog --title $“OpenMandriva” --msgbox $" Nvidia drivers successfully installed. Please reboot your system.";
kdialog --title $“OpenMandriva” --msgbox $" Nvidia drivers not installed.";
gurpmi kernel-nrjQL-desktop-devel-latest x11-driver-video-nvidia-current x11-driver-video-nvidia-current-32bit && mv /etc/X11/xorg.conf.nvidia /etc/X11/xorg.conf;
if rpm -qa |grep “x11-driver-video-nvidia-current*”; then
kdialog --title $“OpenMandriva” --msgbox $" Nvidia drivers successfully installed. Please reboot your system.";
kdialog --title $“OpenMandriva” --msgbox $" Nvidia drivers not installed.";

The by default delivered xorg.conf.nvidia (generated by nvidia-xconfig) will be renamed to xorg.conf and so the system will be able to boot in GUI.

I first tried to do:
gurpmi kernel-nrjQL-desktop-devel-latest x11-driver-video-nvidia-current x11-driver-video-nvidia-current-32bit && nvidia-xconfig;

But it says command not found, I guess it only works after reboot.

I don’t know. XFdrake is supposed to detect graphics hardware, install any needed packages, and configure all automatically. If it isn’t it just means that the script for XFdrake needs to be fixed. Or some script it relies on.

It isn’t impossible that a new script would be better but you need to talk to people who understand such things.

Back to the nvidia driver X nouveau driver choices via XFdrake configuration, XFdrake seems to do just part of what is needed to have the graphical environment loaded at boot. In the case of moving from nouveau to nvidia without blacklisting nouveau or, as PCSoftwarehulp suggests, using nvidia-config, nvidia drivers won’t load and we’ll get a black screen. In the opposite case, from nvidia driver back to nouveau driver, XFdrake does not verify the existence of nouveau’s files at


which also yields a black screen at boot.

Unless this happen only in my two OMV installations, both problems should be reported and corrected for at XFdrake.

PCSoftwarehulp it would be helpful to post link to bug report here.

Edit: Can’t wait it’s here.

adelson.oliveira could you add that to the bug report here?

@ben79 Sorry, forgot to post the link, would be helpful indeed.
@adelson.oliveira Today I reinstalled OMV 2014.2 and removing xorg.conf and generating a new one didn´t work. But also blacklisting nouveau didnt work for me. What did you do from the beginning to get the Nvidia drivers to work?

I’ve used XFdrake to configure nvidia video card => I got dkms-nvidia, x11-video-nvidia, and so on, installed.

After attempts to blacklist nouveau in modprobe.conf and others, I’ve followed Crisb’s suggestion (bug 1935) to blacklist nouveau editing the file,


to include xorg.blacklist=nouveau at the line,

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash resume=UUID=325246ed-f161-4d8d-9c69-408c99d9fb84 rw logo.nologo acpi_osi=Linux acpi_osi=’!Windows 2012’ acpi_backlight=vendor audit=0 rd.timeout=120 locale.lang=pt_BR.UTF-8 xorg.blacklist=nouveau”

and then,

$ update-grub2


Sorry, I didn’t noticed you were talking about 2014.2. I don’t remember to have problems with nvidia drivers and OMV 2014.2!

The last message about blacklistin nouveau applies for OMV LX 3.0!

Thanks for filing bug report. Y’all now have TPG and crisb, 2 of our most accomplished developers, involved. Keep plugging away and this will get fixed. Please do post or attach any files, logs, or other info they request. It really helps them working on a problem. Try to imagine that they may be trying to fix an issue that exists on your computer but not theirs, logs especially help in this regard.
omv-bug-report.log will provide a lot of this. Also here’s a command that they used to (may still?) use in Fedora for nVidia graphics issues:

$ rpm -qa *\nvidia\*  *\kernel\*|sort;uname -r;lsmod |grep -e nvidia -e nouveau;cat 

adelson.oliveira thanks for posting and all your work on this and other issues. Also for participating in the bug report # 2013. Apparently there are issues with both 2014 and Lx 3. Don’t know if there is a bug report against Lx 3 but if not someone with nVidia hardware should do so.