The latest OMV 4.0 Alpha doesn't boot

omlx-4
Tags: #<Tag:0x00007fb720470f48>

(Zeffanyx) #1

Hello,
I understand that the recent OMV 4.0 Alpha may be unstable and generally untested. But it is still very frustrating to download the official ISO and not be able to boot it in my VirtualBox 5.1.26. The system will not boot in any way, neither the installtion, nor live mode, nor basic graphics mode. Looks like it fails to start the X11 mode.
Please let me know if this issue can be solved.
Thank you.


(rugyada) #2

Hi @Zeffanyx

The basic error is that it is not an official release.
A lot of work has been done under the hood and need deep testing. In fact it’s only a preview, not even at Alpha stage although we are almost there, and since then we’ll run faster :slight_smile:


(Zeffanyx) #3

Thanks for clarifying this issue. I’m really looking forward to playing with OpenMandriva 4 someday. What I appreciate most is the responsiveness of the Plasma desktop copmpiled with Clang.


(rugyada) #4

YW

We all do :wink:
Stay tuned, there will be an official announcement when it will be ready.


(Bero) #5

Hi,
this is not an official release (that’s why it’s in a directory clearly labeled “preview” and why there has been (and won’t be) any announcement).

We know that there’s a problem with the VirtualBox graphics driver in this iso, but it has been used successfully on some real hardware.


(Zeffanyx) #6

Actually, this news were rather misleading for me. Shame on you, Michael Larabel!


(rugyada) #7

Yep, we can understand, but I think it’s just a misunderstanding.
As a general rule, please wait for official announcements.

Thanks for your interest.

@bero @TPG and all developers will be happy to read it.


#8

Id like to know why this iso isn’t apparently listed here.


(rugyada) #9

I think it’s a local build from @bero.


#10

That makes sense… :slight_smile:


(Ben Bullard) #11

On a positive note you have identified the first problem to solve! I have the same problem in VBox.

Post-edit: FWIW: I burned (copied) the ISO to a USB stick and this was recognized by my BIOS and then booted and installed just as I would install Lx 3. Then it boots to a black screen with a mouse cursor. It should have booted to the sddm login screen. Internet is not working. There were some problems in the Live ISO environment also that I could document but my guess is that it makes more sense to wait for the next ISO after some know issues get fixed in Cooker.

I can work on the installed Cooker/Lx 4 system from cli to get things working if that would help problem solve things.

Post-edit: Moved this to Development Testing


(Ben Bullard) #12

Post-edit-Note: Let’s again mention that this ISO is a Preview meant for those of us working on development of Cooker/Lx 4 and is not for public review or testing.

OK here goes in VirtualBox 5.2.18 from VirtualBox website on OMLx 3 host machine. Internet is via ethernet connection.

This ISO does boot eventually but it takes some time. I timed it at 1 min 35 seconds once. If you try to enlarge the screen it crashes so you can’t touch that and you have to work in the 800x600 window. I install it as I would Lx 3 but installation fails with a Boost.Python error in job “bootloader”. Here are screen shots of the general process and the installation error:

Below we see that there was created a /boot/efi partition of 300MB Fat32 with flags ‘boot’ and ‘esp’.


(Ben Bullard) #13

Rest of screen shots:

And finally:

And now attached is the Konsole output of:

$ pkexec /usr/bin/calamares -d

Cooker-calamares-konsole.txt (33.2 KB)

Here’s hoping this helps our developers with problem solving.


(Ben Bullard) #14

So in the above posts one can see that I have booted this ISO in both hardware and VBox. In VBox install fails as noted. On hardware system installs but boots to black screen at this time. I have done nothing so far to trouble shoot the installed hardware system.


(Zeffanyx) #15

Thanks for your small review, ben79!
In the meantime it is clear, that the current build is not intended for public use, but still the link I posted above started spreading around. I noticed that https://distrowatch.com mentioned 4.0 Alpha in their ‘Latest distros’ feed.
I suppose the sooner we get a really working ISO, the better.


(Ben Bullard) #16

I knew this was going to happen as soon as I saw the @bero had put the ISO on SourceForge. But this may not have gone much different if it was posted on abf.openmandriva.org/platforms. You can put an ISO in a folder named “Preview” you can label it “Preview” but people will insist on wanting to test it. I’ll be surprised if we don’t see someone somewhere (YouTube likely) “Reviewing” this ISO as if it represents OpenMandriva for public use Product.

And in fairness we, those involved in development of Lx 4, need a place where we have access to the ISO so we can test before releasing to public. Full disclosure: (To say that I’m “involved” in development is a stretch, I’m a tester mainly and don’t know have any code writing skill.)

Post-edit: And let me add the I do appreciate @bero making this ISO available for us to see where we’re at and I appreciate very much the spirit in which he made this available.


(rugyada) #17

+1

I’d add also that I guess @bero was rather confident with the preview ISO mostly working (with all the due considerations that’s a pre-alpha) because before uploading to sf he gave it a test in real hardware.
More, as abf build (ISO) tool is/was still not working well, I think devs had not any other place where to download it for internal testing.

My best suggestion right now is to put into the Preview folder - to make it full clear - an extra README file.


(rugyada) #18

My screenshots (30/08/2018). Test in virtualbox.

After many attempts, a couple of them succesfully booted. After a looooong time waiting.
I learned soon “NEVER EVER touch the virtual screen size!!!” or everything will unavoidably crash :stuck_out_tongue_winking_eye:
htop actually did not show any that high CPU usage, afaics.
I went throught all the install steps, installation finished apparently fine, but reboot failed. Sorry I did not keep any log.


(Ben Bullard) #19

Dag nabbit! I wonder why installation keeps failing for me? But as shown in my screen shots I’m using ‘Enable EFI’ in VBox. Maybe it would install if I use legacy boot?

:monkey_face:


(Ben Bullard) #20

That does seem like a good idea.

This is hindsight now but what would be even better is a pop up window as user starts the boot process telling that this is an “Unofficial Preview” with limited testing and “Caveat emptor” or something similar. Some polite but emphatic way to tell user “Don’t complain if you have problems”. Or “Report but don’t complain about any issues”.

Post-edit: In fact we should maybe create and have as a standard such a pop-up for all Preview releases. And maybe extend it to Alpha and Beta as well?

:monkey: