Some bugs in OMLX 4 alpha 1

alpha
testing
plasma5
omlx-4
Tags: #<Tag:0x00007fb72d78fbe0> #<Tag:0x00007fb72d78fa78> #<Tag:0x00007fb72d78f938> #<Tag:0x00007fb72d78f7a8>

#43

Sorry, in the last post first picture was taken in a attempt to boot in recovery mode, and the second picture was taken trying to install OM LX 4.0 without getting the live mode (second option in live CD).


#44

I think I have problems because this is hybrid graphic computer (not Optimus technology). However, I tried blacklisting nouveau in /etc/default/grub and it did not worked as I described above.


#45

Do not do this (at least in the alpha1 release). As far as I know, Cooker does not yet have proprietary drivers for NVIDIA.
So if you are doing blacklist of nouveau drivers, you are inevitably depriving yourself of the ability to run the system. Just for alpha1 time try use nouveau drivers, in future proprietary drivers will be built, then you will be able to switch over.


(Ben Bullard) #46

For hybrid graphics users is there a way to tell system to boot to Intel graphics (or whatever they have) instead of nVidia (or what ever they have)? Is there a way to tell system “don’t use GPU 1” or whatever? It would seem like there has to be a way to do this as it would be borderline stupid to not be able to do this.


#47

In fact, this is not supposed to happen in this case. This is a hybrid graphics with an integrated iGPU provided by a intel video card, and a dedicated dGPU provided by the Nvidia video card. It means one can safely blacklist nouveau and Nvidia modules because the whole thing is going to be supported by the intel video card and its drivers.

I had problems with OM LX 3.03 CD live and those problems were bypassed editing grub line to blacklist nouveau (as in the Errata for OM LX 3.03 and OM LX 4.0). However, as I mention in another topic, the OM LX 4.0 live CD did not show any problem to boot in live mode, no matter if I blacklist nouveau or not, thus I thought this new live CD was somehow able to handle hybrid graphics notebooks. Now I think it still has weaknesses with such hybrid graphics notebooks …


(Ben Bullard) #48

I doubt it has any provision for hybrid graphics at all. I don’t recall ever seeing developers discussing “How are we going to handle hybrid graphics” but I may have missed it.

I don’t know if you will get this resolved unless you go on IRC and have a session with some of the developers.


(Ben Bullard) #49

@adelson.oliveira in your case one thing I don’t understand is there a way to get your computer working with only one GPU enabled. Can you do this in BIOS? It would seem kind of dumb to build a computer like that and then not provide a way to turn one GPU off for certain situations. That would be beyond stupid to the point of “I want my money back”.

Alternatively is there a way to do this in Linux with a boot parameter. Seems like there should be. I don’t mean a parameter for video driver I mean a parameter to turn one graphics hw or other completely off and/or force the use of a certain graphics hw.

Then once you get it working with one GPU or the other then you can work on getting the hybrid bits to work.


#50

I’ve seen no BIOS option for video cards. It seems that if I blacklist nouveau and no other driver is available, all graphics support will be provided by the integrated GPU. The computer does not miss the dedicated GPU.
So far, I’m not sure I did It right, I’ll try again…


#51

I’m wondering if setting the root partition / => /dev/sdb instead of /dev/sda has something to do with the error message
“Failed to switch root:…”
on the picture above, there one can read that the sysroot seems to not belong to a OS tree.


#52

About switch root problem found this
https://www.google.com/url?sa=t&source=web&rct=j&url=https://ask.fedoraproject.org/en/question/112797/specified-switch-root-path-sysroot-does-not-seem-to-be-an-os-tree/&ved=2ahUKEwjLjJuj6dbfAhWKqZAKHSSsAfkQFjAAegQIBRAB&usg=AOvVaw3ssz402fmQSiWhjL_hquRf


(Ben Bullard) #53

No.

You are going to have to get developers involved to get this solved.


(Ben Bullard) #54

@adelson.oliveira above you post a screenshot of journalctl. Can’t you put that in a file and attach the file here?
Also it would be helpful to post step by step what you did during install especially partitioning. Screen-shots of your partition set up would be good.

Also what does this mean? Tried Aldo in recovery mode:


#55

When writing from a mobile I have to be careful with the automatic corrector! Sorry for that. I meant tried also, not tried Aldo…


(rugyada) #56

:rofl:


(Ben Bullard) #57

Ah, ha! No worries. :laughing:


#58

Let me try to summarize it. I have three devices:
1-A SSD m.2 NVMe with 16GB > linuxswap >marked as swap
2-A 480GB SSD m.2 with 2 partitions: 300MB (FAT32) > /boot/efi > esp + a btrfs with / and LVM
3-A SSHD a ext4 partition set as /home and LVM


(Abucodonosor) #59

Well calamares does not really support LVM…


#60

Well, in the reference to fedora’s forum above, people relates this sysroot problem I’m having here to a symlink to /sysroot/etc/os-release which is said to not work. Here, in live mode I see no /sysroot at all. If the lack of /sysroot is the source of the problem, why it is happening only to me?
In fact, in the picture I’ve posted above one can see that the error appears after the command:
/bin/systemctl --no-block switch-root /sysroot
which points to the existence of a directory /sysroot which does not exist …


(Abucodonosor) #61

for your crash problem try booting with:

rd.driver.blacklist=nouveau  driver.blacklist=nouveau xorg.blacklist=nouveau

``

(Abucodonosor) #62

@ben79

100% sure wrong partitioning / flags … LVM partitioning need be done right from CLI anyway.