OpenMandriva Lx 3.02 development continues

Hi,

finally an OpenMandriva Lx 3.01 is released (almost of 8k downloads) it is time
to start to work on OpenMandriva Lx 3.02 !!!

Plan is to release 3.02 at the end of february 2017. At this time couple of
important piece of software will be released like:

Plasma 5.9.x
Kernel 4.10
calamares 2.4.6 (with kpmcore 3.0 support, that allow to install on LVM2/RAID
setups)

I have enabled weekly builds of 3.02 for i586 and x86_64.
Currently these ships software not available on 3.01 like Plasma 5.8.5 and
LXQt 0.11.x

i586 ISO builds:
https://abf.openmandriva.org/platforms/3.0/products/41

x86_64 ISO builds:
https://abf.openmandriva.org/platforms/3.0/products/38

Feel free to give it a solid testing. Bugs with output from omv-bug-report.sh
and other logs please fill to https://issues.openmandriva.org

Again i encourage to produce and publish by QA a detailed checklist(1) for ISO
with list of detected bugs. Based on such transparent report it will be easier
for all of us to make decisions GO/NOGO.

(1)
Checklist should contain typical use cases like:

  1. Does iso burns on usb stick
  2. Does the grub/boot screen appears
  3. Does the options in grub/boot screen works
  4. Does ISO boot to multi-user.target
  5. Does ISO boot to graphical.target
  6. Does autologin for live user works
  7. Does default graphical desktop shows after autologin
  8. Does default graphical desktop is useable (basics, like menu, file manager,
    web browser)
    etc. etc.
2 Likes

What I hope to do is better QA testing for next release (OM Lx 3.02 afaik) so we don’t get caught with a bunch of “this doesn’t work” stuff 5 days before release date. This testing is on hardware on 2 different computers a desktop (self assembled) and an ASUS X550C notebook. Used for this .iso # 946 (latest at the moment).

Some of the stuff I’m going to mention needs to have bug reports filed. I really could use help checking everything I’ve found. Obviously other people will find other issues I missed, can’t see, or am to dumb to realize, if so report them in this thread and if warranted file a bug report (and note bug URL here). If anyone can help solve any issues, well that would be just wonderful.

This report is meant to be in addition to existing open bug reports of which there are 102 open bugs against Lx 3 at the moment (April 22, 2017). See more here.

My procedure to follow this. Also go through Application Launcher (Kickoff in my case I think) and see that everything at least opens and in a lot of cases do more to see that basic things work. Then do spot checking in LXQT and check to see that it works overall. I haven’t checked every thing under “CLI Core Applications” thinking developers/power users will catch any of that.

Samba - no windows on this computer - so I don’t test this - there is a bug:
https://issues.openmandriva.org/show_bug.cgi?id=1630
samba 4.3.8 - this security update borks a lot of stuff In Progress

Skrooge - crashes, doesn’t even start - this is in application menu so should work right? This needs a bug report. - Fixed by crisb 4/26.

Grub2 - On system with 3 ext4 OS’s I install from iso # 946 with f2fs and other systems are not recognized by os-prober even after updating system - April 26: This started working correctly again on my computer so is no longer an issue here…

Drakconf - anything I use works - that’s rpmdrake, drakrpm-edit-media, and rarely drakdisk don’t use any of the rest - KDE Partition Manager is fine so I don’t need drakdisk actually

Auto update - does this mean updating from icon in menu panel with Discover - that works except for testing repos

Discover - Where are applications? - I don’t care for Discover and will be reluctant to file a bug report on this, perhaps someone else will do so

Plasma Desktop - some flashing screens and dialog windows - but no segfault error messages - It’s like some things maybe work to fast for graphic hardware or software?

Lxqt Desktop - OK - But sometimes hangs and won’t logout and if that happens an attempt to login to Plasma fails - this looks to be a pain in the tucus to document - need more testing, input from other users before bug report

KDE config apps - SystemSettings and anything I tried worked

OM-Welcome will not start from Application Menu - In Progress

k3b - Missing whatever provides ‘cdrskin’ which it now uses instead of ‘cdrecord’ ie. missing dependency - this needs bug report if there isn’t one - Fixed by crisb 4/26.

KMail - I’m having trouble with gmail account authentication -
https://issues.openmandriva.org/show_bug.cgi?id=2058
cyrus-sasl-2.1.27 breaks kmail smtp authentication

This is by no means meant to be an exhaustive list and some other users will have other issues to report. Again if needed file a bug report.

Edit: updated 4/26/2017

1 Like

These are just general questions to clean some things up.

Based on what is published in Release Notes should XFCE Desktop be tested?

Based on GNOME packages being in Main repos should it be tested?

Who (if anyone) are package managers for the various desktops in repos? Like XFCE, GNOME, Mate, Cinnamon mainly?

How much should we focus on any of these desktops not installing, or not working, or not working well? Is there an argument for removing desktops that aren’t maintained?

There is user (pujithadimuthu) reporting that a lot of apps in Education and Games will install but don’t work. Like Klavaro, well it’s true for Klavaro but that’s only one I’ve checked. Klavaro is in Contrib, I suspect a lot of these are. How much to be concerned about this? Does someone have time to check? Is there an argument for removing applications in Contrib that aren’t maintained?

Does Play on Linux work? I’m not a gamer so not right person for testing this. Whatever happened to our gaming effort? Still active? I hear nothing about this.

Got another one. Krfb - Desktop Sharing - is enabled by default. Is this wise?

Does ISO boot in basic graphics mode? Not on my desktop.

Maybe a boot parameter is needed?

Edit: Removing ‘nomodeset’ enable this to work both in Live and Install. So fixing for this computer would probably break it for a lot of others. But by all means check this.

I installed couple of windows apps using play on Linux (StarUml 5.0 and Universal Extractor) both worked fine. But some apps had some issues. Eg : MS Paint and Graphe 2D.

Latest updates MariaDB is not working.

[root@Pujitha-PC ~]# urpmi --update --auto-select
To satisfy dependencies, the following packages are going to be installed:
Package Version Release Dist DEpoch Arch
(medium “main updates”)
dkms-virtualbox 5.1.18 1 omv 2015.0 x86_64
drakxtools 16.72 1 omv 2015.0 x86_64
drakxtools-backend 16.72 1 omv 2015.0 x86_64
drakxtools-curses 16.72 1 omv 2015.0 x86_64
harddrake 16.72 1 omv 2015.0 x86_64
harddrake-ui 16.72 1 omv 2015.0 x86_64
lib64mysqlclient18 10.1.22 1 omv 2015.0 x86_64
lsof 4.89 1 omv 2015.0 x86_64
mariadb-client 10.1.22 1 omv 2015.0 x86_64
mariadb-common 10.1.22 1 omv 2015.0 noarch
mariadb-common-binaries 10.1.22 1 omv 2015.0 x86_64
mariadb-plugin 10.1.22 1 omv 2015.0 x86_64
mariadb-server 10.1.22 1 omv 2015.0 x86_64
virtualbox 5.1.18 1 omv 2015.0 x86_64
virtualbox-doc 5.1.18 1 omv 2015.0 noarch
x11-driver-video-vboxvideo 5.1.18 1 omv 2015.0 x86_64
732KB of additional disk space will be used.
40MB of packages will be retrieved.
Proceed with the installation of the 16 packages? (Y/n)

Yes, mariadb is not starting. Thanks for reporting pujithadimuthu. My first question is it supposed to be started or is it only started on demand by something that uses it? In other words is what I’m doing below a fair test?

# systemctl start mariadb.service
Job for mariadb.service failed because the control process exited with error code.
See "systemctl  status mariadb.service" and "journalctl  -xe" for details.

# systemctl status mariadb.service
● mariadb.service - 10.1 database server
   Loaded: loaded (/lib/systemd/system/mariadb.service; disabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sat 2017-04-22 20:52:17 CDT; 4s ago
  Process: 8098 ExecStopPost=/mysql-wait-stop (code=exited, status=203/EXEC)
  Process: 8097 ExecStartPre=/mysql-check-socket (code=exited, status=203/EXEC)

Apr 22 20:52:17 ben79-pc systemd[8097]: mariadb.service: Failed at step EXEC spawning /mysql-check-socket: No such file or
Apr 22 20:52:17 ben79-pc systemd[8098]: mariadb.service: Failed at step EXEC spawning /mysql-wait-stop: No such file or di
Apr 22 20:52:17 ben79-pc systemd[1]: Failed to start 10.1 database server.

‘journalctl -xe’ just repeats information above.

As I remember I did not install mariaDB. so “started on demand by something that uses it

StarUml 5.0:

My reason for asking about Play on Linux is because it is in our Release Notes. But Play on Linux isn’t OpenMandriva and I don’t know what relationship we have if any. Do know that OMV isn’t one of the distos in their download list whatever that may mean.

So as QA Team member when someone like you has a problem I currently don’t know how to handle it. But know that I will ask. And the fact that you (a loyal user/customer) brought up the issue makes a lot easier to, metaphorically speaking, stamp my feet and demand an answer. So, again, thanks pujithadimuthu.

The value of users reporting demonstrated. This was a bug. Should be fixed with:

To satisfy dependencies, the following packages are going to be installed:
 Package                        Version      Release       Dist  DEpoch Arch 
(medium "main updates")
 lib64mysqlclient18             10.1.22      2             omv   2015.0 x86_64 
 mariadb-client                 10.1.22      2             omv   2015.0 x86_64 
 mariadb-common                 10.1.22      2             omv   2015.0 noarch 
 mariadb-common-binaries        10.1.22      2             omv   2015.0 x86_64 
 mariadb-plugin                 10.1.22      2             omv   2015.0 x86_64 
 mariadb-server                 10.1.22      2             omv   2015.0 x86_64

Thanks pujithadimuthu for reporting and Crispin Boylan for fixing.

Edit: This is more a bugs desirable to get fixed. I don’t know that any of these are/aren’t blockers.
Perhaps 2058, and 2107 would be blockers? I think 1753 for sure needs to be fixed but isn’t considered a blocker.

Bugs needing fixing for 3.02 release:

General stuff:
1630 (In Progress), 1753, 2058, 2066, 2068, 2071, 2085, 2086, 2087, 2093, 2103, 2107

l10n/language/translation:
1861, 1893, 2044, 2072, 2078, 2079

This is just one person’s opinion so please do mention anything needing to be added or subtracted.

Updated: April 26, 2017

There are new ISO’s to test with latest from developers. See links in post # 1 above.

Edit: Latest 64 bit ISO # 993 works fine here. I don’t see any regressions so far.

1 Like

There is a new version of OM-Welcome (2.0.7-1) in Main-Testing repo. It needs testing. See this. Please post any comments and results of testing here.

1 Like

Ok. OM-Welcome works on my system. it crashed in 3.0.

Devede, BleachBit application crash…

1 Like

Thanks for reporting. On my ‘I hope to get done’ list is to go through the Applications listed on OM-Welcome and see which ones do/don’t work.

Better OM-Welcome has a fix size. now Full screen, … can be done.

1 Like

Yes they crash. Konsole output:

$ devede
  File "/usr/bin/devede", line 37
    print "DeVeDe 3.22.0"
                        ^
SyntaxError: Missing parentheses in call to 'print'

$ bleachbit
  File "/usr/bin/bleachbit", line 45
    print "Could not open X display"
                                   ^
SyntaxError: Missing parentheses in call to 'print'

does anyone have time to test these and file 2 bug reports?

It’s like them both use python2 script but they are launched using python3 instead.

Reported on bugzilla:

devede: 2119 – devede requires python2 but python3 is used
bleachbit: 2120 – bleachbit requires python2 but python3 is used

1 Like

Thanks to @crisb these bugs has just been fixed! So fast! :joy:

devede: fixed with 3.8.8-1
bleachbit: fixed with 1.17-1

1 Like

Here bleachbit is working now. devede still doesn’t open (reported in bug report) and it’s version 4.8.8-1 fwiw.

Thanks mandian for reporting and crisb for fixing. (And yes I’m anticipating devede being fixed soon).