OM Lx 4.0 does not work with TV Monitor

kdeinit5[1306]: kscreen.kded: Failed to find a matching mode - this means that our config is corruptedor a different device with the same serial number has been connected (very unlikely).Falling back to preferred modes.
This looks a likely candidate.
Please upload the file created by this command.
tar czvf kscreeninfo.tar.gz ~/.local/share/kscreen/
After you have uploaded the file you could try to clear the files in tar czvf kscreeninfo.tar.gz ~/.local/share/kscreen/ and reboot. There is a small chance that this may resolve the issue.

1 Like

Hello,
I installed OMLx-4. When I connect my TV by HDMI cable, it let me see through the TV monitor, but the PC is black. It seems not recognizeing more than one monitor. Nothing changed in tho hardware. Of course, in LX3 it was all OK.

Reported here.

At the end:

  • Have I to wait for future improvements? (I know well that OMA human resources are limited)
  • Which command may help to detect my problems ?( Maybe there are trivial patches I could do myself).

Consider my TV is in a room far away the computer, so I can’t use the keyboard and watch TV monitor at the same time.
Still, it is strange to me that Lx 3.01 had never shown such problems. Even with the Sound card, there is only analogical media, no Digital one in LX4.

How could I get information on my hardware ?

Yes, so far I haven’t been able to get any developer to look at this besides @Colin and he is to busy with other things to expect any resolution for a least a few weeks. FWIW several other developers are to busy with their day jobs and/or life events to do much with OM at this time.

Read this and this.

Someone needs to file a proper bug report on this issue. The bug report needs to include the omv-bug-report.log.xz file. Also if needed will be the information requested here and here.

I am disappointed that we did not catch this in testing. We need to add testing for dual monitors and TV’s as monitor to our testing for graphic package stack and for ISO testing. I will attempt to get this done.

Also I wish I could promise faster results on a solution for users but I’m being realistic. Right now a majority or our developers are buried by their day jobs or other life events and there just isn’t much person power available for problem solving. With OM I seem to observe that out problem solving goes in spurts where a lot gets done for a period of time and lulls where not much happens for a while. If users can be patient (not easy for me to do) we should be able to get this fixed it’s just a question of when.

omv-bug-report.log.txt (426.9 KB)
This is my report.

Can it be useful ?

Bug Report started.

1 Like

I am able to get this to work on my notebook and my desktop with this workaround. Whether this is something @zaivala can use we shall see.

For @alangea in your case we should wait and see what you get after you straighten out your Storage drive partition tables and reinstall you system with one set of repositories only.

@Colin is away for 4-5 days. We will get back to work on trying to find a cause for this at some point. At present no other developers have any time available to problem solve this.

I have purchased a MiniDisplayPort-to-HDMI adapter for my laptop, and will check to see if I still have the issue shortly. I hope not.

I’ve re-installed system and put all to the right terms. Now: What I can try to see (and listen) things from my PC on TV monitor, connected by an HDMI cable ?

What really happens is, when I reboot with TV connected by an HDMI cable, initially both Monitors (that are in different rooms) are visible, then TV monitor shows the desktops, the PC monitor sticks on the initial view. Soon a window pops up on the TV monitor, that apparently should allow switching to one monitor or another, or both (this I understood from the showed monitors sketch) but, since the keyboard and the mouse are in the other room, I cannot do nothing; as well mouse seems not to have any effect on what eventually happens on TV monitor.
Of course, I neither could look at the monitor settings, whether another display except the PC one was available. Even after having seen the TV monitor activated (with th PC one locked), once disconnected the TV no information was registered on the kscreen file about the TV.

As well , NO audio I heard on TV. This is another issue. I think that developers should cope these issues, on the basis of the bug report mentioned by Ben. On my side, I don’t know what to do, since the TV and PC monitors are in different rooms. Unless Ben could suggest anything to insert in the kscreen file, (but I don’t know information about TV), or something else.
Practically, I’m in stand by.

@alangea thanks for reporting. There has not been any work on this recently. The best person for this problem has been unavailable due to personal issues.

I followed suggestion by Ben:

  • Connected HDMI (as HDMI-1)

  • Typed xandr -q and HDMI-1 was connected

  • Typed xrandr --addmode HDMI-1 “1920x1080”

  • In the file present in ./local/share/kscreen there were information about TV monitor, but TV monitor was disabled

  • Enabled TV monitor (enabled:true) then shuttted down system.

  • When system booted up, TV monitor was visible, PC monitor not, but command and mouse were active. So I executed the command for the system settings, and in monitor and video section I unified exits (both monitor were present).

  • Now BOTH monitor were visible BUT: NO AUDIO on TV.

  • I went in the multimedia section of system settings; in the audio devices were active both audio analogical internal stereo and GF108 HD Audio Controller Digital stereo (HDMI-2 ) ! Why ? Should be HDM1 !

Suggestions ?
I hope my report will be useful to developers to fix this annoying bug. After all, we are on the right way on…

P.S.: I cannot show you a snapshot of the audio settings interface, because screengrab crashed, because of lack of a library (screengrab: error while loading shared libraries: libuploader.so.1.0.0: cannot open shared object file: No such file or directory)
Is there a way to get around this inconvenient, or another graphical capture tool I could use instead ?

Spectacle is KDE screen shot utility. Installed by default with OM Lx 4.0

1 Like

OK Spectacle works. I’ll open a specific thread for the audio problem, waiting for news about the definitive resolution of the dual monitor issue.

OK, right now we may not have anyone available to work on this. The reasons are different for each individual but right now about half our devs aren’t available.

This one reason why progress in OM comes in spurts sometimes and slows to a crawl sometimes. Just nature of an all volunteer and very small group. I doubt anyone likes this.