Nothing provides libxslt needed by nordvpn-3.7.3-1.x86_64

Tags: #<Tag:0x00007ff291b0b1f8>

Hello,

  • _**OpenMandriva Lx version:**4.1

  • _**Desktop environment (KDE, LXQT…):**kde

  • _Description of the issue (screenshots if relevant): missing libxslt i believe its downloaded already

  • Relevant informations (hardware involved, software version, logs or output…): nvdia gtx 1060 intel i7 nord-vpn 3.7.3-1.x86_64

Welcome @vaspam

Moderator: I just upgraded your “Trust Level” on the forum so you can post screen shots and .txt files ect.

The information you provide is rather skimpy. To help us help you could you be more specific and tell us or post a screen shot of what you are trying to do? Please remember to post code as code with the </> icon.

Just facts: There are packages lib64xslt-devel and lib64xslt1 in main/release repository. But with the lack of detailed information it is impossible to know for sure what is needed for your situation.

Hi.
Package libxslt should be installed in OpenMandriva. If not try:

sudo dnf install lib64xslt1

Worth to add, you see missing dependency error because package nordvp is build for Fedora and Fedora use another package naming system.
So to install packages from Fedora, first install missing package (step above) and then try install nordvpn with this command:

sudo rpm -i --nodeps nord-vpn 3.7.3-1.x86_64.rpm

BTW. I can’t find 3.7.3 version to download, I see only 1.0? Do you have link to test it?

nordvpn-release is like a shell package for norvpn. First you install nordvpn-release then you install nordvpn. So far I can’t figure out an rpm command that will find the nordvpn packages. In other words where does nordvpn-release put the .rpm’s for nordvpn?

Ah, Ha!

Download this.

Open Konsole and navigate to the directory where you downloaded the .rpm file. Run this command:

$ sudo rpm -i --nodeps nordvpn-3.7.3-1.x86_64.rpm

For me result is:

$ sudo rpm -i --nodeps nordvpn-3.7.3-1.x86_64.rpm
warning: nordvpn-3.7.3-1.x86_64.rpm: Header V4 RSA/SHA256 Signature, key ID 5c964ca1: NOKEY
NordVPN for Linux successfully installed!
To get started, type 'nordvpn login' and enter your NordVPN account details. Then type 'nordvpn connect' and you’re all set! If you need help using the app, use the command 'nordvpn --help'

Now we need @vaspam to test the installed software and let us know if it works with OM Lx. If there is a problem it would likely be because the software can’t find library packages in OM Lx because it uses Fedora/Centos syntax.

Post-edit: @AngryPenguin and anyone else this is where the real nordvpn .rpm’s are located. To be specific x86_64 packages are here.

Post-edit-2: Would this be software we might want to add to OM Lx repositories?

Hello!

Thanks all,

It seems as though I got stuck at the part where you download the release directly from their website and I guess afterwards I had to directly download the version?(nordvpn-3.7.3-1.x86_64.rpm) from Here Which was provided by ben79,

So I guess a little confusing, for future reference how were you able to find the list of nord repositories?

Also, sorry for the lack of information I myself didn’t really understand the problem. I gave all the information that the console gave though I’ll be sure to take a look at the better results guide.

Also! Yes lib64xslt1 came installed.