New User, Sorta

omlx-3.0
Tags: #<Tag:0x00007fb728cfd0c8>

(Moss Bliss) #1

Hello,

  • OpenMandriva Lx 3 & upgrading

  • ** environmeDesktopnt (KDE):**

  • Description of the issue (screenshots if relevant):
    New install. Lots of issues. Great start, want to help with implementation

  • Relevant informations (hardware involved, software version, logs or output…):
    Lenovo ThinkPad T430
    Main problems with Calamares (mostly great), KDE Discover (way messed up, but might be fixed in updates), and timeout process (messed with my upgrades).

OK, Calamares was wonderful during setup… I had a partition ready for it (although in use). Except Calamares did not ask whether I wished to format it, and then refused to install on the basis of “partition already mounted” (it wasn’t). I had to go to Manual partitioning to get the right stuff selected.

After installation, KDE Discover choked on having over 1300 updates. The machine froze, then refused to work. So I rebooted and tried it in Terminal; after some time, the software decided it needed to lock the screen for timeout, and gave me a command to enter to continue. As I did not remember it correctly (yes, I should have written it down), it refused to run. Ever again. I had to go reinstall, which I am doing now.

I am a member of the mintCast team, and I am constantly trying new distros or versions. The first distro I ever successfully ran was Mandrake 8. The upgrade to 9 was OK, but the next version locked my (old 386) machine up and sent me back to Windoze.

Calamares COULD BE the best installer anywhere, if all the options are activated. It SEEMED like the easiest installer to use ever, until it refused to install due to a lack of options to select. I had used it also when evaluating OpenSuSE and Gecko. Love it, in principle.

I hope this installation gets completed … so I can evaluate it. But there are still too many places where a new user would get lost. Maybe if I had waited for 4 it would have been easier.

I will also state that I LOVE the fact that it doesn’t simple overwrite my GRUB, but instead keeps all my other installations (4 partitions on this machine) in place, In Debian-based distros, I have to go get a copy of Grub-Customizer to fix this.

I also LOVE the fact that, even though it can’t find an exact driver for my printer, it can STILL print to it, even in the live version. That’s impressive. For Debian-based distros I have to go get the Brother Installer for my model (which, while Linux-compatible, seems to be left off most driver lists – MFC-J470DW).


(Ben Bullard) #2

Post-edit: Woops I did it again! Dagnabit! :disappointed: I forgot to start with:

Welcome to the OpenMandriva Forum @zaivala. We all hope you enjoy your time here and using OpenMandriva. And thanks for reporting any issues.

First it is helpful to know if a user with issues is installing on hardware or in VBox. What you say about partitioning indicates hardware install but we can’t be absolutely sure. Next we need to know the exact ISO that was used to install from. The ISO’s have a first line on the grub2 menu page that will include something like “Plasma x86_64 Build ID 1588”. That “Build ID XXXX” is especially important to get to bottom of issues with the Calamares Installer.

Discover is a #$%^ and I don’t use it at all except to test it because I am a tester. Especially for that many updates I would not use it. Don’t know if this is a result of bad design or if OM’s implementation of Discover is :poop:. (Guess I should qualify that statement with IMO.)

For a lot of updates especially 1300 or more I would use Konsole and do with:

$ sudo urpmi --auto-update --test

This will download all packages to be updated first, and if all is OK it will tell user “Installation is possible”. Then you just delete the --test and:

$ sudo urpmi --auto-update

Machine freezing during an update is not normal. I do a lot of testing in VBox and on hardware and have updated many installed Lx 3 systems and not seen this so don’t know what is going on without any information, Konsole output, or logs.

That sounds like “Screen Locker”. Easy to disable. Go to SystemSettings>Workspace>Desktop Behavior>Screen Locking and unselect the 2 boxes and select “Apply”. In Lx 3 “SystemSettings” may also be called “Configure your Desktop”.

This is AFAIK set by upstream, ergo KDE devs. IMO Screen Locker should be disabled by default and user should have the opportunity to chose to enable it. But see, KDE devs enable it by default just for me and you and other users! They decide it is for you own good! How kind they are. :roll_eyes: (Guess I should qualify that statement with IMO.) (Again.) :laughing:

On the other hand all it takes to unlock screen locker is user password and one should remember or have written down their own password. It does not seem fair to blame devs for forgetting that.

Don’t know exactly what you did so can’t comment. But I can say that on hardware I use Manual Partitioning automatically unless I’m testing something or trying to reproduce a problem. I do that because I need to set mount points for Data partitions. I don’t store data on my operating systems I keep it separate. In VBox I try to use a variety of choices but don’t recall the problem you mentioned. But there well may be an issue with something auto-mounting partitions incorrectly.

If you would be so kind tell exactly what you did I can try and reproduce and see what’s up. And I would like to reproduce this and take a look at what is going on. There may be something here we need to note in our Release Notes.

Note: For you and all users see more about updating Lx 3 see here.

:hear_no_evil::speak_no_evil::see_no_evil:


(Ben Bullard) #3

You and others my find this more recent ISO to be interesting if not downright useful.

By comparison the most recent “Official” ISO the Lx 3.03 ISO is “Build ID 1588” so there are some months between the two.

:monkey:


(rugyada) #4

Some times I’ve seen it happen (in virtualbox), while updating dracut (and/or systemd). It looks like freezed with black screen but it isn’t, workaround is to switch to VT, and back without doing anything. You’ll see the console still running and updating.


(Moss Bliss) #5

Good questions. I’ll try to address them all.

First, I have, to date, never used a VM in my life that I am aware of. My Lenovo ThinkPad T430 has a 500 Gb hard drive, and I keep all my documents and other files on an external drive, so I have it partitioned into 4 pieces. My main driver, LinuxMint 19, is in sda2. My first backup is KDE Neon 18.04, installed on sda5. My learning machine is Ubuntu Studio (MATE) on sda6. And I now have OpenMandriva 3.03 on sda4. (sda5 and sda6 are on the extended partition, sda 2 and sda4 are on the primary)

I downloaded the iso in the past few days, marked “current”, so I assume it’s the latest 3.03. Which is what surprised me that there were still over 1300 updates; I guessed (wrongly) that the iso was actually 3.00 and the updates took it to 3.03.

I did keep a log of my update output if anyone wants to see it. There were a number of steps which did not work for a variety of reasons, but that happens with most updates on most distros so I didn’t think much of it (except to save the file).

Most of my experience in the recent past (say, last 8 years) has been with Debian-based systems, but I knew that there was a similar set of stuff for rpm, and looked it up. I did not know the --test flag, should do that next time.

I will dispute your statement on the screen locker. If it happens while in terminal, the terminal states to sype a certain command to continue. I did not write it down, so I both cannot tell you what it was nor did I get it correct. But I avoided the problem last night when doing the second try.

All I did was use the Calamares installer, I did not select manual install but just continued on selecting the partition. I selected the partition I wanted, it showed that the completed project would look like “this” (showing OpenMandriva on the correct selected partition), and said to continue. There was no selection available to format that partition. And the result of going on from that point was to be told that the partition was already mounted (it wasn’t – the only thing mounted was the USB drive) so it could not continue.

Thank you for the welcome and your comments. I will keep OM on my system for a while and try to get all my packages installed. There were a number of things which were flat-out simple, easier than any distro I’ve tried, so the glitches were that much more upsetting.


(Ben Bullard) #6

Then I don’t have a clue what might have happened.

Nothing more frustrating than trying to solve a problem when you don’t know what actually happened. So if it happens again by all means please take a screen shot or copy and paste the terminal output if you can.

For future reference to get information and documentation for problems in addition to screen shots and posting terminal output actual logs are very, very helpful. If the screen actually locked that would be a graphic issue and would likely be in Xorg.0.log (/var/log/Xorg.0.log) or maybe in xorg.session.log (/home//.local/share/sddm/xorg.session.log). So you would look and those and see if you can find the issue or copy the logs to a file and post the file/files here. (General rule of etiquette is to not post much over 20 lines of code here, otherwise put it in a file and post the file.)

Otherwise anything significant that happens in terminal would most likely show up in journalctl logs (which are system logs). I’m not expert at journalctl logs (or much of anything) but you can create a file for developers to look at like this:

$ journalctl -b -x > journalctl-bx.txt

and post that here. The -b means it will post log for current boot the -x means it will add message explanations where available.


(Ben Bullard) #7

Would that include:

If so then by all means post it.


(Ben Bullard) #8

An attempt to reproduce the partitioning issue:

Here I select “Replace a partition” and select partition 16:

Here Calamares tells us details of the installation attempt:

And installation fails:

So this does not work and you have to use “Manual Partitioning” to get this type of install to work. Thanks for reporting. I have added this to Lx 3.03 Release Notes and Errata. I believe this has been fixed in Lx 4 but I need to double check this. Maybe will get to that tomorrow.

Post-edit: I have confirmed that “Replace a package” is working on Cooker/Lx4 ISO Build ID 2280. So this is fixed for Lx 4.


(Moss Bliss) #9

Nope. The file generated was of my COMPLETE update. But there were some disturbing things in it, at least for us n00bs.


(Moss Bliss) #10

Thank you. It is always good to know that a problem was not caused by (a) my own stupidity, or (b) something wrong with my machine.


(Ben Bullard) #11

Then please post it. It is likely what you are seeing are error messages created by urpmi. urpmi issues some error messages that aren’t errors and also post some things users find scary or confusing that really aren’t so I can attempt to explain. OR if there is something that is a real issue we would like to know that as well to see if we can eliminate the problem. But, most likely, these won’t be something you did or something wrong with your machine either. FWIW I did not see anything wrong with how you went about installing or updating OM Lx 3.03, if it has sounded that way, sorry, was not intentional.

FWIW: urpmi will be gone for our Lx 4 release and we will be using dnf for package management. The above is part of why. The main reason has to do with the language urpmi is written in (Perl) and the fact that it is getting increasingly difficult for our devs to maintain. I can say that dnf seems to be faster, noticeably faster.


(Moss Bliss) #12

OK, I’m not allowed to upload a txt file here, and the length of it might choke the system. What would you recommend?


(rugyada) #13

Is it a plain .txt extension file?


(Moss Bliss) #14

Yes. 53.4K, 895 lines.


(rugyada) #15

I cannot say the reason right now. Maybe related to user permission (not sure), will need to investigate further.
For the time being, I’d suggest to use a service like https://pastebin.com/


(Moss Bliss) #16

I’ll try to do my own pasting and see what happens.

[…]

Removed too long console output (and not useful anymore)
~rugyada


(Moss Bliss) #18

Apparently the character limit in here is 32000 characters.


(rugyada) #19

So this

is not a good move.

Some other services (if you don’t like pastebin for any reason):
https://paste.opensuse.org/
https://paste.ee/
http://pasted.co/

Please edit your post. Thank you.


(Ben Bullard) #20

Um, users posting text file is a common occurrence here and don’t recall an incident where someone could not do that. Could you please post a screen shot? If there is an issue I seriously want to get that corrected straight away. For screen shot use Spectacle from Application Launcher>Applications>Tools and post with the UP Arrow icon (the same one you use for posting a text file).


(Moss Bliss) #22

I tried pastebin. I put the link to the new file in here. I got told, “Sorry, you cannot include links in your posts.”

So I’m screwed any way I go.