Installation LX3


#41

Build 707 :unamused:


#42

J’essaye toutes les nouvelles versions dont la dernière 707, pour moi le résultat est toujours le même que ce soit en ext4, f2fs, partitionnement personnalisé ou install automatique. ça se termine toujours sur un écran noir au redémarrage, en mode recovery je ne peux rien tirer de l’install, j’ai un “home” vide. Soit je suis maudit, soit mon ordi est allergique à LX3, soit c’est LX3 qui est allergique à Virtualbox installé sur mon ordinateur soit enfin je vais être obligé de me tourner vers une autre distri ! Mais il ne reste que Mageia qui a bien du mal à sortir sa dernière version.

De toute façon il m’est impossible de choisir une distri qui s’installe dans 1 seule partition, qui m’obligera à formater mon home avec un passage de etx4 à f2fs. Ca devient compliqué, ça fonctionnait si bien avant !


#43

Je ne comprends pas ce que vous dites. J’utilise des partitions séparées et / / home et depuis depuis toujours dans Lx 3. Utilisez-vous le ‘partitionnement manuel’? C’est ce que j’utilise. Si je veux, je peux utiliser f2fs ou btrfs pour / et xfs pour / home. Cela me semble assez facile.

Edit: Je parle d’installer sur le matériel, mais je utiliser le partitionnement manuel dans VirtualBox ainsi. F2fs fonctionne-t-il dans VBox? Le type de fichier dans VBox doit-il être identique à celui de la partition hôte?

I don’t understand what you are saying. I use separate / and /home partitions and have since forever including in Lx 3. Do you use ‘Manual Partitioning’? That’s what I use. If I want to I can use f2fs or btrfs for / and xfs for /home. It seems quite easy to me.

Edit: I’m talking about installed on hardware but I use manual partitioning in VirtualBox as well. Does f2fs work in VBox? Does file system type in VBox need to be the same as the host partition?

Edit: Wow, je dois le perdre. J’ai répondu en anglais au forum français. Désolé à ce sujet, généralement utiliser Google Translate.

Edit: Wow I must be losing it. I replied in English to the French forum. Sorry about that, usually use Google Translate.


#44

Oui, c’est pas du tout vrai.
En partitionnement personnalisé vous pouvez mantenir votre /home sans la formater.
En théorie, vous pouvez également choisir ext4 au lieu de f2fs (pour la root) proposé par défaut. Si le truc marche, cela est encore à vérifier…

OMG, il y en a un bon nombre de distributions, avant de tomber là… :stuck_out_tongue_winking_eye:


#45

Je n’arrive pas à faire fonctionner LX sur mon ordi, j’ai essayé 2 fois et le seul résultat a été l’obligation de réinstaller la 2014-2. Depuis je ne fais des essais que sur virtualbox et là ça ne fonctionne pas

  • en install automatique,
  • en install avec partitionnement personnalisé,
  • en f2fs,
  • en ext4,

Je me retrouve systématiquement sur un écran noir, peut être suis-je le seul, tant mieux pour les autres.
Je n’ai ce problème qu’avec Openmandriva. Toutes les autres (dignes d’intérêt) s’installent et fonctionnent sans sur le même virtualbox, sur le même ordinateur !
A patr voir un sorcier je ne vois pas quoi faire :slight_smile: .


#46

Je viens d’essayer avec une iso téléchargée le 14 décembre (je n’ai pas noté son n°) et je confirme.
En fait Xorg est lancé mais sddm semble bloqué.
Tout ce que j’ai réussi à faire est de passer dans une console texte, installer icewm et obtenir une interface graphique utilisable. Mais ce n’est pas kde qui lui aussi bloque en le lançant directement.

Info:
pour lancer icewm, il faut :

  • d’abord arrêter Xorg depuis une console texte en tant que root

systemctl stop graphical.target
systemctl stop sddm

  • lancer X depuis une console texte, puis starticewm depuis une autre console texte (la première fois il sera demander d’installer le paquetage) après avoir exporté la variable DISPLAY.

export DISPLAY=:0
starticewm

Enfin retourner à la console 1 pour la session graphique.

Les logs de Xorg montrent une erreur sur un module vboxvideo :

(EE) vboxvideo: module ABI major version (20) doesn’t match the server version (23)

Mais cette erreur n’empêche pas Xorg de fonctionner.

EDIT: kde démarre aussi en suivant la même procédure que pour icewm


#47

Au moment où vous avez le écran noir, juste passer en console virtuelle (ctrl+F2), login votre user, et ensuite
startx /usr/bin/startkde

Le problème le plus grave est la /home vide !!! :grin:

Build 713:

Postedit:
Pour ce que ça vaut, même la création d’un nouvel utilisateur ne résout pas…


#48

Tu as raison! J’avais installé en utilisant le partitionnement manuel sans formatage / home donc au début ne voyait pas cela pour 4 utilisateurs existants, y compris xguest. Mais j’ai créé un nouvel utilisateur et il devient vide à la maison:

# useradd -c "Billy Weiser" -u 1003 billyw

# passwd billyw

C’est un problème grave.

FWIW: Je ne suis pas francophone ainsi écrit en anglais et traduit avec Google translate (S3). J’espère donc que cela a du sens en français.

FWIW: I’m not French speaker so written in English and translated with Google translate (S3). So I hope this makes sense in French.


#49

Par défaut, c’est /etc/skel/ qui sert de modèle pour les nouveaux utilisateurs (défini dans /etc/default/useradd) . Effectivement, il manque les dossiers usuels.
Il suffit de les ajouter avant de créer les nouveaux utilisateurs.

[quote=“ben79, post:48, topic:653”]
FWIW: Je ne suis pas francophone ainsi écrit en anglais et traduit avec Google translate (S3). J’espère donc que cela a du sens en français.[/quote]
C’est bon :wink:

[quote=“ben79, post:48, topic:653”]
FWIW: I’m not French speaker so written in English and translated with Google translate (S3). So I hope this makes sense in French.[/quote]
It does :wink:


#50

Pas sûre de comprendre du tout :confused:

De toute façon malheureusement je n’arrive pas à voir la différence.
Voici deux captures à comparer, la 713 et une précédente (qui marche).


#51

Et quel est le contenu de /etc/skel/ ?

Précision : par défaut, useradd copie le contenu de /etc/skel/ dans le home de l’utilisateur. On peut donc personnaliser celui-ci, en ajoutant, par exemple, un dossier /etc/skel/Images/ contenant des images de test, un dossier /etc/skel/Audio/ contenant des sons exemples, etc. Cela pourrait être d’ailleurs un “plus” pour la distro.
Dans la dernière iso que j’ai testée, le contenu de /etc/skel/ était le suivant :

├── .bash_completion
├── .bash_logout
├── .bash_profile
├── .bashrc
├── .cache
├── .compose-cache
├── .config
│   └── Trolltech.conf
├── .face.icon
├── .fonts.conf
└──  .local
    └── share
        └── user-places.xbel

#52

@jclvanier Quelle est la commande que vous avez utilisée ici svp ?


#53

Pour afficher le contenu de /etc/skel/ ?

tree -aR /etc/skel

The first time, you are asked if you want it installed.


#54

Oui, merci :slight_smile:


#55

Oups, j’ai demandé le contenu de /etc/skel alors qu’il était affiché dans les images.
Cela dit, lorsqu’on crée un utilisateur dans la 713 et dans la précédente “qui marche”, est-ce que le contenu du home de ces utilisateurs est différents ?

PS: j’ai la même configuration dans la 2014.2


#56

Dans la précédente (la 534 pour être précis, mais aussi pour les autres il n’y a jamais eu des problèmes) je n’ai pas eu la nécessité de le créer, donc de vérifier. Toutefois je peux faire un test.


#57

Ok, j’ai créé un utilisateur dans la 534 et tout fonctionne parfaitement:


#58

717 pas mieux …


Call for testing OM Lx 3.01 .iso's
#59

Ok.
In bref:

  • Au moment où vous avez le écran noir, passer en console virtuelle (ctrl+F2), login votre user

  • startx /usr/bin/startkde

  • Systemsettings

  • Arriver à SDDM, choisir Maldives
    Postedit: voir aussi

  • Logout

  • Reboot

Bonne chance :smile:


#60

Bonjour zuzu21, oh comment je voudrais encore 21 ans …: rire:

La ligne:
(EE) vboxvideo: module ABI major version (20) doesn’t match the server’s version (23)

Nous dit pourquoi. Vous devez donc installer VirtualBox? Le (EE) signifie Erreur. Je ne suis pas expert, mais je devine que votre version de VirtualBox ne correspond pas à la version de ‘x11-driver-video-vboxvideo’ dans le système installé. Ils doivent correspondre. Vous auriez besoin de VirtualBox 5.1.10.

# rpm -qa x11-driver-video-vboxvideo
x11-driver-video-vboxvideo-5.1.10-1-omv2015.0.x86_64

A moins que je me trompe… :head_bandage: