Installare MATE su OMLx 3.02

mate
desktop
Tags: #<Tag:0x00007ff2b7a0c7b8> #<Tag:0x00007ff2b7a0c678>

#41

:grin:

Per ora è tutto fermo a causa del bug 2197 :frowning:. Magari ti faccio sapere quando avrò ricompilato tutti i pacchetti necessari.


(rugyada) #42

C.V.D.

Vabbè, a sto giro mi tengo questa come base per il futuro MATE.
Per il resto aspetterò una comunicazione ufficiale con un link ad una ISO che non sparisca dopo qualche ora.


#43

Stavo quasi pensando di usare la minimal … magari prima vedo se funziona (abbastanza) bene con la LXQt.


(rugyada) #44

Casomai poi fai sapere :wink:


#45

Aggioramento: ho ricompilato tutti i pacchetti di mate

  1. le icone svg non sono più visibili né sul desktop nè nel menù :worried:
  2. a volte il termine della sessione è lento (probabilmente a causa di at-spi-registryd, come avviene sulla 2014.x)
  3. il gestore degli archivi engrampa non gestisce i file tar, come segnalato qui.
  4. le icone breeze che non hanno dimensione 32 non sono scalate correttamente da caja.

(rugyada) #46

E’ collegato al problema nell’altro topic ?
Ti ho risposto ma non ho capito bene come verificare.


#47

Penso (o meglio spero) di sì ;), altrimenti ho sbagliato qualcosa nei pacchetti perché prima le vedevo.

Se ha i tempo e voglia (magari anche nei prossimi giorni) puoi disinstallare tutti i paccketti di MATE e reinstallare solo task-mate

urpme `urpmq --requires mate-task | cut -d\  -f2 | cut -d\[ -f1`
urpme --auto-orphans
urpmi.update mandian_personal
urpmi task-mate

La soluzione ottimale (è equivalente) è:
urpmi.addmedia --no-verify-rpm …


(rugyada) #48

Ho installato task-mate nel sistema live.

Adesso? :slight_smile:

PS>

PS2>
Impostando le icone breeze si aggiusta:

In questa macchina non ho aggiornato nulla, solo installato task-mate e lightdm (che non so cosa dovrebbe fare :stuck_out_tongue: )
E breeze-gtk ovviamente.


#49

Ecco invece come appare MATE con la ISO #1300 :frowning:

Come puoi vedere le icone breeze non sono visualizzate e sono sostituite con quelle di Adwaita. Le icone sulla scrivania non sono visualizzate (ma su LXQt si vedono e nel sistema sono installate) ed anche alcune icone del menu (qui non si vede) mancano. :angry:

È un display manager leggero in alternativa a sddm. Se le icone non sono visualizzate lì (e l’ho installato su una macchina pulita e senza i,l mio repo) il problema potrebbe essere causato da un pacchetto di sistema ;).


(rugyada) #50

Ok, questo è evidente, dallo screenshot.

Ecco qui per capirci ti riferisci ancora alle icone sostituite da Adwaita o a Donate e Join ?


#51

A quelle Donate e Join che, però, sono presenti nel sistema e ben visualizzate sulla stessa macchina con LXQt. Anche l’icona del menù non è visualizzata, come le nei menu. :angry:


(rugyada) #52

Mah, non so se è cambiato qualcosa ultimamente però in LXQt è una vita che non vedo quelle icone.
Qui c’è uno screenshot della 1090 ma di sicuro ne ho fatto anche altri.
Non si vedono perchè il percorso è sbagliato, cioè va a cercarle dove non sono - o non sono più.

Postedit:
Guarda, qui ce n’è un altro

Ho fatto questi screenshot per tenere traccia delle cose da correggere, quando ancora pensavo che avrebbe potuto essere utile…


Missing icons
#53

Di solito nei file .desktop il campo Icon deve contenere il nome delle icone senza il percorso. Avevo notato che nei vecchi file c’era il percorso completo ma adesso, come mostrato nello screenshot precedente, il percorso è stato rimosso (lo avevo fatto a mano nelle installazioni precedenti, poi ho reinstallato una macchia pulita per vedere come funziona con le configurazioni standard). Se fai lo stesso nei tuoi file le icone appaiono.

Postedit:
Una screenshot della stessa macchina con LXQt


(rugyada) #54

Vero, questo problema sembra sia stato corretto adesso.
Ho avviato il desktop LXQt nell’ultima ISO disponibile, fresca di installazione, e le icone appaiono.
Meglio così.


#55

Il seguente comando ha risolto il problema delle icone svg scomparse:

sudo gdk-pixbuf-query-loaders --update-cache

Ho anche provato a sistemare l’aspetto del pannello inferiore:


(rugyada) #56

Vorrei un chiarimento se possibile, prima di fare pasticci

I solved by adding splash at line GRUB_CMDLINE_LINUX_DEFAULT of /etc/default/grub and then update grub

significa che devo semplicemente aggiungere " splash " - preceduto da uno spazio vuoto ?


#57

Sì, ma all’intero delle virgolette. Questa è la riga modificata nel mio /etc/grub/default:

GRUB_CMDLINE_LINUX_DEFAULT="quiet rw logo.nologo acpi_osi=Linux acpi_osi='!Windows 2012' acpi_backlight=vendor audit=0 rd.timeout=120 splash"

#58

Ho modificato la dimensione delle icone breeze e questo è il risultato

caja:

desktop:

Cosa ne pensi?


(rugyada) #59

Che è senza dubbio molto meglio di prima :thumbsup:

Riguardo al plymouth (gioia e dolori… ma più dolori che gioie) ti confermo. Benchè si veda poco, dato che appare solo per mezzo secondo o giù di lì, adesso si intuisce che c’è :thumbsup: :clap:

Pensi di fare una pull request?
:smiling_imp: rotfl


#60

:rofl:
Per ora no. Per GRUB magari chiedo prima su IRC o al prossimo TC meeting aa cui riesco a partecipare perché nel repo github l’impostazione è corretta.