How to use ABF to build rpm's

in github do you have a 2014.0 branch?

have you this configuration here

@luca No, I haven’t. It is mandatory?

@jojodu34 yes I have the same configuration.

Here is an example of the error. I also tried with a customized live of openmandriva 2014.0 and I got the same error so I think it isn’t an abf issue but a rpmbuild.

I’m not sure, but take a look at another project present in 2014.0/3.0/cooker

I see

Building target platforms: x86_64
error: Fetching Source0 failed: Unknown or unexpected error
error: Missing Source0: v2.0.tar.gz: No such file or directory

seems bad address or bad name something like that

The same woks in 3.0

So I’ll try.

maybe v2.0.tar.gz and tc-play-2.0.tar.gz names differs? and that is a problem?

I’ve seen that in 3.0 works:

–2016-08-15 16:54:52--
Resolving (…
Connecting to (||:443… connected.
HTTP request sent, awaiting response… 302 Found
Location: [following]
–2016-08-15 16:54:53--
Resolving (…
Connecting to (||:443… connected.

try with

In any way putting that link in the browser works. The link with the full name doesn’t work.

Usually github uses a link containing only the version number but when you click on it using a browser it saves an archive with the name and the version. This doesn’t happened with wget, of course. But the archive in the OpenMandriva file-store contains the full name so I use the full name in the file .abf.yml and the real link in the spec. I don’t know if it is the right way.

I already tried this but is doesn’t solve. I also tried with another package using a direct link to the file (i.e. without redirections) but I got a similar error.

It fails even with branches :cry:

seem solved refering to file store

+Source0: tc-play-2.0.tar.gz

at least in 2014.0, maybe stop to work in 3.0 :wink:

So I must pay more attention to the name of the archive before to load in file-store, at least for 2014.x.

Thank you!

I was following the tutorial but I had this problem where the site does not show the option to search for the file

as you can see in this screenshot

Add files does not work?
Nor drag&drop?

in the tutorial he asks to look for the sha1 file (dos2unix) on the site but doesn’t have the option to search the site

Look at this post:

I have also similar question, like how can I get the sha 1 file. with out the file will it be possible to move forward, that I want to build in Looking for the answer, and thanks in advance.