How to use ABF to build rpm's

I guess it is because meld has never been rebuild in OpenMandriva ABF. How should I proceed in this case?

the best way to proceed in this case is to go to the github of opendriva Association

and then you look for the project. (Find a repository …)

with a search with “meld” you have two responses

you can fork meld in your github

I pushed meld 3.16.1 in file store (fe003ba49433a735713bf93f06994e480b45384d )

see here GitHub - joeltess/meld

with no change except version I tried a build with no success. the reason is at least the spec file use make ! (very old version in fact)
so you have to change spec file

ex:

for build something like
%build
CFLAGS="%{optflags}" python setup.py build

for install something like

%install
%{__python} setup.py install --root %{buildroot} --install-purelib=%{python_sitelib}

I have no time to go further. it is best to take inspiration from a spec file of a python 2 module

good luck :wink:

1 Like

log in into abf, then project like this

you see your project, choose settings of the project you want change

push red erase button

about your bug https://issues.openmandriva.org/show_bug.cgi?id=1772

I use qupzilla always and I have not this problem
maybe a cache problem

try this adress ABF

1 Like

Thank you. I did so.

In this case my ABF repo has not been synchronized with my github account. (Is is not a problem, I’ll wait for the fist build)

I erased null project from my ABF account but the packages I built are still in my personal repo.

log in > platforms choose the platform ( mandian_personal), in right corner choose main (or other)

click on the cross you want

1 Like

It is all OK now.

Thank you for all your patience. :slight_smile:

Command failed:
# [’/usr/sbin/urpmi.addmedia’, ‘–xml-info=never’, ‘–urpmi-root’, ‘/var/lib/mock-urpm/openmandriva-x86_64/root/’, ‘luca_personal_main_release’, ‘http://abf-downloads.openmandriva.org/luca_personal/repository/3.0/x86_64/main/release’]
adding medium “luca_personal_main_release”
…retrieving failed: curl failed: exited with 22

Hi,
I’ve got an error building a project in my personal repo.
http://abf-downloads.openmandriva.org/luca_personal/repository/3.0 is missing.
Who can create it?

Thanks in advance.

question waiting on IRC. I hope an answer :innocent:

@jojodu34 thanks :wink:
It’s easier they respond to you than to me :smile:

I had no problem to build in http://abf-downloads.openmandriva.org/luca_personal/repository/cooker

[16:55] <\HisShadow_> joel_tess_: yeah, I’ll fix it, gotta create it manually

:wink:

thank you very much!

Hi,
I’ve still some problems with ABF. The first is an error at publishing stage. I succeeded to publish some packages on y personal repo but all them cause a ‘Publishing error’ on ABF I can’t understand what it refers to. I dont’n know if it is because all my packages are not signed but I can’t find the way to make it.

Also I would like to compile a package which depends on one or more packages in my personal repo. Is there a way to do this (maybe i should add an extra repositories before to start the build)?

Finally I wonder if the option ‘Use cached chroot’ in the Build panel may speed up the build of a package. Or it may be unsafe?

seems the same problem:
http://ml.openmandriva.org/pipermail/om-cooker_ml.openmandriva.org/2016-July/001557.html

I’ve solved deleting the existing synthesis.hdlist.cz

So I.
Thank you.

btw I some problem to compile a package for the 2014.0. Has that version already been deprecated?

I don’t think, updates are still arriving in repos.

I don’t see openmandriva2014.0 branch on my personal repo. You have it.

yes, I have it as target platform

It is like rpmbuild can’t fetch sources from remote in 2014.0.