How to install nvidia driver by .Run installer

driver
nvidia
Tags: #<Tag:0x00007fb72491bd78> #<Tag:0x00007fb72491bb70>

(ho3in) #1

hi guys.
i’va switched to Openmandriva from fedora just for few days for running Autodesk Maya… but after installing nvidia vga driver package provided via repos i cant use view-port 2.0 inside Maya. it says the video device is not recognised.
i had the same problem on fedora so i fix it when fallowed the tutorial here:
https://www.if-not-true-then-false.com/2015/fedora-nvidia-guide/

so does anyone know how i can do the steps in openmandriva like disabling nouveau, etc and finaly have driver installed usin nvidia provided .Run installer?
this problem tempt me switch back to fedora. :smirk::thinking:
Tnx for any help :pray::pray::pray:


(Ben Bullard) #2

Welcome to OpenMandriva and our Forum. Hope you do enjoy your time here.

I don’t have nVidia hardware so I’m not much help on this.

Go to #openmandriva-cooker on Freenode IRC and ask for itchka aka: @Colin. Or you could send @Colin a PM.


(ho3in) #3

tnx for your greeting.
i hope so. and other tnx for your comment but i’m not familiar with IRC :sunglasses: would you give an other hand?


(Colin Close) #4

How did you install the video driver? If you used the OpenMandriva tools then the graphics driver will be set up correctly. If you installed directly from the rpm then it probably won’t.
Are you sure that the nvidia driver is running? Check this by doing ‘lsmod | grep nouveau’ it it returns ‘nouveau’ then the nVidia driver has been incorrectly installed. The best thing to do in these circustances is to uninstall it reboot and then installl using the OpenMandriva tools this will give you a correct setup.
If there is a problem after this then we will look further.


(Ben Bullard) #5

Don’t we have a wiki page about this??? It would seem to be bizarre if we don’t.

Edit: Anyway there is this from the Release Notes:

“To access XFDrake, the DrakX video configuration tool, go to Configure your Computer>Hardware>Set up the graphical server.
NVIDIA Graphics Cards”


(rugyada) #6

Or command line in root console:

# XFdrake

PS>
Some users reported that they needed to run it twice.


(ho3in) #7

i used Setup Graphic Driver (Computer>Hardware>Set up the graphical server) … the same result was on Mageia for Maya viewport before with this kind of NV driver installing …
when i’m able to run nvidia control panel and kwin effects correctly , monitor the GPU temp and adjust AA and Etc it means that it’s installed correctly… but this way of installing isnt work good for for Maya Viewport.


(ho3in) #8

unfortunately i breaked my OM , i’m going to do that as soon as i install OM again.


(ho3in) #9

i didn’t find anything… i don’t thing so


(Colin Close) #10

I took a quick look at the tutorial you pointed to I can’t see anything hugely different from what we do but since I have nVidia on my box I will investigate the problem further. This is probably an xorg.conf issue.


(Colin Close) #11

I’ve had a quick look around there is some useful information here https://us.download.nvidia.com/XFree86/Linux-x86/302.07/README/configtwinview.html which will probably have the setting you need. I do not have Maya so I can’t check these but I’ll try and set up spome “Viewports” and see what happens.
I will detail for you the differences in the fedora install. It looks like it should work on OpenMandriva.


(ho3in) #12

tnx Colin , i’m waiting for you impatiently.


(Colin Close) #13

Here are the revised instructions let me know whether they work for you. I was able create a viewport using the advanced setting in the nVidia cofig tool.

Make sure your original nVidia driver install is removed.
To do this select configure your computer -> Hardware -> Set up the graphical server.
Select the top drop down men titled and select the graphics card closest to the one you have installed once done select ok.
The next screen will ask you whether to install the proprietry drive select “No” and continue with the install. This action will restore the open source video drivers. You will need to reboot following this procedure.

You can ten start with the procedure detailed here:-
https://www.if-not-true-then-false.com/2015/fedora-nvidia-guide/

You can ignore all of step 1
At step 2.4 run "urpmi --auto-update"
To updat eyour system.

At 2.5 if you have already installed the nVidia driver from OpenMandriva you should already have all the necesessary dependencies are installed.

The command in 2.6.1 should be echo “blacklist nouveau” >> /etc/modprobe.d/blacklist-mdv.conf

For 2.6.2 you need to modify the the file /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT=" scsi_mod.use_blk_mq=1 quiet resume=UUID=09a2dab2-a9b5-4592-805d-bb527d1169dd rw logo.nologo acpi_osi=Linux acpi_osi=’!Windows 2012’ acpi_backlight=vendor acpi_backlight=vendor audit=0 rd.timeout=120 rd.driver.blacklist=nouveau nokmsboot

For 2.6.2 the grub2 update line is like this grub2-mkconfig -o /boot/grub2/grub.cfg
Use the same line for either bios or EFI installs.hy this is

You can ignore step 2.6.4 as we use the modeset driver.

Step 2.6.5 is not necessary as loading of the nouveau kernel driver is already disabled by the changes to the grub2 command line. I’m not sure why this step is here.

Do step 2.7

Do step 2.8.1
New step 2.8.1A

Run the following command:-
echo nvidia >> /etc/modprobe.preload

Note that for the following steps you will only get text prompts as we do not install the library with gives the menu prompts by default.

Contine through steps until 2.8.4 at this step select "No"
The reason for the “No” is that the dkms modules have already been built by the previous installation by control centre but the installer will not continues
unless it builds the modules.

Continue to step 2.9

If you want to install the additional packages detailed in step 2.10
Then use urpmi instead of dnf to install the packages named on the first line.


(ho3in) #14

tnx for your respond
’m going to do, i hope it works


(ho3in) #15

i did the steps you have provided above , now the nouveau is disabled, but installer return this error :
Unable to find development tool ‘cc’ in your path; please make sure that you have package ‘gcc’ installed. If gcc is installed on your system, then please check that ‘cc’ is in your PATH.
and i know that ‘gcc’ is installed.


(Colin Close) #16

Ah you don’t have gcc installed I thought that would be installed when you tried to install the nvidia driver with the OpenMandriva tools.
No matter do this "urpmi gcc kernel-desktop-devel kernel-headers dkms acpid and pkgconfig"
Let me know if there is still a problem


(Ben Bullard) #17

hsafaei I suspect you will find there aren’t packages named kernel-desktop-devel or kernel-headers. It will work better if you do this:

# urpmi kernel-release-headers kernel-release-desktop-devel kernel-release-desktop-devel-latest dkms pkgconfig

and then be sure that the kernel-release-desktop, kernel-release-headers and kernel-release-desktop-devel packages are exactly the same version. You can check that easily from Konsole with:

# rpm -qa | grep kernel-release

for instance mine looks like this:

# rpm -qa | grep kernel-release
kernel-release-desktop-devel-4.13.12-2omv-1-1-omv2015.0.x86_64
kernel-release-desktop-4.13.12-2omv-1-1-omv2015.0.x86_64
kernel-release-desktop-latest-4.13.12-2-omv2015.0.x86_64
kernel-release-headers-4.13.12-2-omv2015.0.x86_64
kernel-release-desktop-devel-latest-4.13.12-2-omv2015.0.x86_64

Note: gcc and it’s dependencies will install automatically with kernel-release-desktop-devel.

Second note: I don’t have nVidia hardware so otherwise I’m not much help on this.

Edit: Third note: If this all seems a bit convoluted it’s partly that we are using this thread to create a “How To” for this so bear with us until we get this sorted. And thanks for your help on creating a “How to Install nVidia proprietary driver in OpenMandriva Lx3”. (Or some title similar).


(ho3in) #18

tnx Colin and ben79
i’had installed that pkgs before so i created this link : cd /usr/bin && ln -s gcc cc
then i could install Driver.
this time i have another issue. probably OS cant start KDE and this message is showed in a small box:
“could not start kdeinit5. check your installation” and i can move cursore around.
i tried to start kde manually by pressing alt+ctrl+F3 and typing: sudo startkde but it sayed something like this:
can not connect to x server or xorg maybe.
any idea?


(ho3in) #19

tnx Colin and ben79
i’had installed that pkgs before so i created this link : cd /usr/bin && ln -s gcc cc
then i could install Driver.
this time i have another issue. probably OS cant start KDE and this message is showed in a small box:
“could not start kdeinit5. check your installation” and i can move cursore around.
i tried to start kde manually by pressing alt+ctrl+F3 and typing: sudo startkde but it sayed something like this:
can not connect to x server or xorg maybe.
any idea?


(ho3in) #20

i’had installed that pkgs before so i created this link : cd /usr/bin && ln -s gcc cc
then i could install Driver.
this time i have another issue. probably OS cant start KDE and this message is showed in a small box:
“could not start kdeinit5. check your installation” and i can move cursore around.
i tried to start kde manually by pressing alt+ctrl+F3 and typing: sudo startkde but it sayed something like this:
can not connect to x server or xorg maybe.
any idea?