How to install nvidia driver by .Run installer

driver
nvidia
Tags: #<Tag:0x00007fb7212aad20> #<Tag:0x00007fb7212aabb8>

(ho3in) #21

"Third note: If this all seems a bit convoluted it’s partly that we are using this thread to create a “How To” for this so bear with us until we get this sorted. And thanks for your help on creating a “How to Install nVidia proprietary driver in OpenMandriva Lx3”. (Or some title similar)."
i never wont give up until getting success to install it. this How To might be useful for other mandrake-based distros so i’m determined.
Sorry of my poor English.


#22

Please could you attach your /var/log/Xorg.1.log file here?


(ho3in) #23

here is the log file.
Xorg.0.log.txt (47.1 KB)


#24

It seems nvidia module is load with no errors …


(ho3in) #25

so i dont know why i’ve never had installed nvidia driver on any manrvia based linux. i waste 2months on magei and now on Openmandriva. i need a RPM based linux with nvidia driver provided by Nvidia itself to run Maya…
now i can use only Maya lagacy Viewport because it can connect to nvidia driver that installed from repository.
and here is another issue, Maya 2018 only has Viewport 2.0 and lagacy Viewport is dropped so if i want to Use maya 2018 wihout install driver from .run installer i will Closeitself and never open up the software.
i dont want to comeback to Fedora because it has many bugs after fedora 22. so i have just 1 choise : backing to an old version of Fedora whoithout update it.


#26

Have you already tried to contact Maya customer support?


(ho3in) #27

no because i can run it on without any problem on any ubuntu based distrows , debian based distrows and arch-based distrows but have not run on madriva based. i need RPM based distro because of RenderMan is only RPM and i cant install it by converting to other type of packages.
i just have some finite choises:
Magei , Rosa and OpenMandriva or
Fedora , CentOS
Fedora is now full of bugs for example KDE panel freezes when i run gnome based apps. CentOs is stable but when i install desktop softwares from unofficial Repos. it breaks-up.
i forget OpenSuse , this distrow breaks up after about 1 week spontaneously so i afraid of it :smiley:


#28

Have you already tried to generate a new /etx/X11/xorg.cfg file with X -configure?


(ho3in) #29

i’ve already done it but still the same result.


(Colin Close) #30

You don’t have the latest driver installed. The version you have requires patches to make it work.
The version you need installed is 387.34 you have installed (384.98) needs patches to make it work. Please run the installer again with the correct version then kde might start.
The version number is show in the xorg log.


(ho3in) #31

thank you Colin, Ben79 and Mandian.
Now it works smooth with latest driver.


(Colin Close) #32

I would be grateful if you could post you Xorg.conf here so that we can check whether it is the same as the one installed by our own rpm.
Thanks,
Colin


(ho3in) #33

why not. its my pleasure.
xorg.conf.txt (7.6 KB)


(Bruno) #34

Happy New Year to all, but not happy nvidia.
Really i never had success with nvidia proprietary driver & openmandriva-os, against the nvidia proprietary driver & rosa10-os that run quite well on the same hardware.
But I would try again so i followed the @Colin/fedora instructions; all was going well untill the nvidia program stopped with a message like:

«The kernel was built with gcc version 7.2.1 20171011 (OpenMandriva) (Linaro GCC Snapshot 7.2-2017.10), but the current compiler version is clang version 5.0.0 (tags/RELEASE_500/final).»

For the people who like squeeze your own brain hunting bugs, below:

inxi -F
System:    Kernel: 4.13.12-desktop-2omv x86_64 (64 bit) Desktop: KDE Plasma 5.10.5
           Distro: OpenMandrivaLinux 3.0 Einsteinium
Machine:   System: TOSHIBA product: SATELLITE C55-A-1P6 v: PSCGNE-00V00FIT
           Mobo: TOSHIBA model: PT10S Bios: TOSHIBA v: 1.20 date: 01/13/2014
CPU:       Dual core Intel Core i5-4200M (-HT-MCP-) cache: 3072 KB 
           clock speeds: max: 3100 MHz 1: 2741 MHz 2: 1851 MHz 3: 2921 MHz 4: 3021 MHz
Graphics:  Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller
           Card-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M]
           Display Server: OpenMandriva X.org 119.6 driver: N/A
           Resolution: 1368x768@60.00hz, 1920x1080@60.00hz

and the nvidia.log.txt
nvidia-installer.log.txt (152.2 KB)


(Colin Close) #35

Bruno,
First do this:- urpmi kernel-release-headers kernel-release-desktop-devel kernel-release-desktop-devel-latest dkms pkgconfig gcc

Then you can do this:- export CC=/usr/bin/gcc

Then finally run the nVidia installer.

You may get a black screen because you have dual graphics adapters but we can cover that issue one you have installed the driver. Bumblebee does work on some laptops. Other laptops have a switch.

I still don’t know why our install (using OpenMandriva tools) is different from installing via the .run file.


(Bruno) #36

I do not know why, but I did not see the above Colin’s suggest until yesterday july 14 (only 7 months later).
I apologize for that.
Anyway yesterday I tried this suggest but without success.
After several trial, and messes, the only result has been: nothing screen in openmandrivaLx3.
Today, after 600 or more packets of upgrade the screen was born again.
So I state: stop nvidia trials on openmandrivaLx3… maybe on Lx4? and yet it runs so good in rosa os…


(Ben Bullard) #38