Epson XP-352 doesn't print in wifi

I installed Epson XP-352 printer with both interfaces: usb and wi-fi.
Using usb it works normally, using wi-fi doesn’t print.
Note that printer is correctly recognized during installation and I use same driver for both printers.

  • _OpenMandriva Lx version:_4.3

What driver you use?

Epson Inkjet Printer Driver (ESC/P-R) for Linux version 1.7.18 downloaded from Epson internet page in rpm version.

Try setting up the printer via the ‘cups’ interface which you can access by entering this address http://localhost:631 in your browser.

Tried already and nothing change.

On some printers you need to set up wifi via the usb connection before the printer is detectable. Have you tried that approach?

The same printer works in other Linux distribution and worked in OpenMandriva Lx 4.2.
More: it’s detected and installed using wifi, then wifi connection works,
May be a Firewall problem?

You could try stopping the firewall using systemctl with
systemctl stop firewalld
systemctl disable firewalld

You will need to enter your password to perform these operations.

Unfortunately stopping firewall doesn’t solve the problem.

In that case I suggest you delete ALL printers shown in cups and start from the beginning if your printer is set up correctly for wifi through usb you should have no problem detecting your priinter using the cups method of detection. Before you start though read this help page it will help you to choose the correct method http://localhost:631/help/network.html Others have installed wireless printers through cups so there is no reason why you should have a problem if you choose the correct method to detect it.
Please note that you need to provide the root password to access the cups interface.

1 Like

Thanks for suggestion.
I already installed printer using “631” and it doesn’t works. Printer is correctly recognized and is installed but don’t print (printer seems unavailable).
I tried to follow help page but, as often happens in Linux, I get stuck.
As an example " Run the lpinfo(8) command to find your printer’s URI:" give me:

$ lpinfo --include-schemes dnssd -v
bash: lpinfo: command not found...
Install package 'cups-common' to provide command 'lpinfo'? [N/y] y

 * Waiting in queue... 
 * Loading list of packages.... Failed to install packages: cups-common-2.4.1-1.x86_64 is already installed

Do this “sudo dnf --refresh install cups-common”

reinstall maybe better

$ sudo lpinfo --include-schemes dnssd -v

1 Like

I have a HP printer set up using wifi with CUPS in OM Lx 4.3. It worked when I set it up. And if I remember to turn it on it is still working wifi.

Follow the document @Colin posted. The trick is in getting the correct selection under either “Discovered Network Printers” or “Other Network Printers”. For me “Discovered Network Printers” shows my printer but using that did not work I had to use an entry under “Other Network Printers” and manually enter my wifi printer url. The url of your wifi printer is on the screen of your printer.

As far as the firewall, firewalld, it is set to incoming Allow and outgoing Allow. That is unlikely to be stopping much of anything.

try xp 344 drivers… it works on mageia distri !

It seems doesn’t change (in bracket my translation):

$ sudo dnf --refresh install cups-common
[sudo] password di giorgio: 
OpenMandriva Rock - x86_64                                                    6.2 kB/s | 4.3 kB     00:00    
OpenMandriva Rock - x86_64 - Updates                                           13 kB/s | 3.3 kB     00:00    
OpenMandriva Rock - x86_64 - Updates                                           61 kB/s |  58 kB     00:00    
OpenMandriva Rock - x86_64 - Testing                                           12 kB/s | 3.3 kB     00:00    
OpenMandriva Rock - x86_64 - Testing                                          1.0 kB/s |  18 kB     00:17    
OpenMandriva Rock - Unsupported - x86_64                                       12 kB/s | 4.3 kB     00:00    
OpenMandriva Rock - Unsupported - x86_64 - Updates                            2.6 kB/s | 3.3 kB     00:01    
OpenMandriva Rock - Unsupported - x86_64 - Updates                             42 kB/s |  43 kB     00:01    
OpenMandriva Rock - Unsupported - x86_64 - Testing                             12 kB/s | 3.3 kB     00:00    
OpenMandriva Rock - Unsupported - x86_64 - Testing                             26 kB/s |  27 kB     00:01    
Il pacchetto cups-common-2.4.1-1.x86_64 è già installato.
Dipendenze risolte.(*package cups-common-2.4.1-1.x86_64 already installed.
Dependecies ok.*)
Nessuna operazione da compiere.(*Nothing to do*)
Fatto! (*Done!*)

Not sure.
Removed cups-common with several dependencies.
Reinstalled only cups-common (without any dependency ! Why?).
Hope system doesn’t need any of the dependencies removed …
We’ll see.

post edit: all printers previously installed disappeared.

$ sudo lpinfo --include-schemes dnssd -v
[sudo] password for giorgio: 
lpinfo: Bad file descriptor

post edit: it seems that remove and reinstall cups-common deleted all printers and perhaps other functions.

No removing the printers wouldn’t do this; this is a disk error by the look of it…unless there’s a dependency missing. I’ve just run the command it works fine here. Do this ‘systemctl status cups’
If it says the service is running then run ‘systemctl restart cups’
If the service is not running then start it with ‘systemctl start cups’ and hopefully all will be well.
If all else fails then reboot.