Driverless printing for OMLx


  • OpenMandriva Lx version:

Cooker & ROME

  • Desktop environment (KDE, LXQT…):

Plasma (instructions are for KDE Plasma desktop. One may use CUPS (localhost:631) or perhaps some other utility on other desktops.

  • Description of the issue (screenshots if relevant):

Printing on HP Photosmart 6520 driverless. The smart folks are saying this is the future in Linux. This is known to work on a lot of other printer models. Obviously there will be some printers that are to old for this to work.

  • Relevant informations (hardware involved, software version, logs or output…):

List of supported printers for driverless.

Driverless printing introduction and documentation.

You may need wifi connection to do this. (As far as I know at this time.)

Telling other folks how to set up their printer is difficult to impossible because of the wide variety of hardware and the different manufacturers doing things differently combined with the wide variety of hardware they are connected to and different connection types. But for purposes of discussion and getting some other folks started on this I can tell what I did that works for me. Some of you may already know more about this than I do.

You will need to be patient and let things work. Sometimes there may be what seems like hesitation until something happens, system is either thinking or connecting via net/wifi.

I am doing this in a ROME znver1 system fully dsynced 2023-02-28. First I removed hplip. I found for my HP printer I had to remove this software. If you don’t have a HP device this does not apply to you. For other hardware users will have to discover for themselves if any software needs to be removed.

$ sudo dnf rm hplip

Then to add printer I open SystemSettings>Hardware>Printers and select add printer. Be patient it can take some time while system finds all your options. For my device I want the one under “Discovered network printers” that says “IPP network printer via DNS-SD”. You may find some other option works best for your hardware.

Ignore that error. Select “Next” and wait while it looks for drivers. Be patient this can take some time. In my case these came up:

It so happens that the first one in the list is what my printer wants to print driverless. In any case if you get this far with your hardware you are looking for an entry that says driverless.

Print Test Page. Works for me. This worked on my hardware. Users will need to be flexible and perhaps try different options to see what works in your setup. The OpenPrinting website is a great souce of information for this or setting up printers in general, including older “Legacy” printers. There are other places on the internet with useful information so don’t hesitate to search if you have questions.

Note: SystemSettings>Hardware>Printing is a KDE module you can also launch from terminal with command:

$ kcmshell5 kcm_printer_manager

Note-2: I used SystemSettings module you can also do this with CUPS by entering ‘localhost:631’ in a web browser. This may work better for some hardware.

Note-3: I will be posting another thread about scanning on the same device driverless.

Note-4: Would like to know how to do this without using wireless if that is possible.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.