Disk space problem during update from 4.1 to 4.2

I tried to update my system from 4.1 to 4.2 using this guide: Attention Rock users: Rock repositories switched to OM Lx 4.2. At the terminal the size of the packets who was needing to update was about 2.9gb , at the end of the process i got a message on the terminal about the size of my disk is not enough, it said me i needed about 1.1 gb more. My total root partition size is 25.38gb and in use is 20.52 so there is 4,86 gb free space

My question is why the update failed since there is almost 2 gb more of the packets size who need to updated?
Also, is there any safe way to clean my system for enlarge my free space?

  • _OpenMandriva Lx version:_4.1

  • Desktop environment (KDE, LXQT…): kde

  • _Description of the issue (screenshots if relevant):_Disk space problem during update from 4.1 to 4.2

  • _Relevant informations (hardware involved, software version, logs or output…):_Operating System: OpenMandriva Lx 4.1
    KDE Plasma Version: 5.17.5
    KDE Frameworks Version: 5.66.0
    Qt Version: 5.14.1
    Kernel Version: 5.5.12-desktop-1omv4001
    OS Type: 64-bit
    Processors: 8 × Intel® Core™ i7-8550U CPU @ 1.80GHz
    Memory: 7,7 GiB

1 Like

Welcome back to the forum @thanasis_65.

Your best bet is to go here and try talking to OM developers. You will need to be patient as we are a small group and developers are busy folks.

As far as removing data from / partition it depends on what is in there. Anything that is just stored there you should be able to move to another partition. An operating system does not need 20.52 GB. If there is a lot of additional software installed you might have to remove some of that and reinstall it after the distro-sync operation.

Hope this helps. But developers can give much better advice on this type of issue.

Ben79, thanks for the quick reply i will try there…
The truth is there is installed some software via flatpack like qgis who is necessary for me and viber for linux and some few others, i have notice flatpack occupies to much space on my disk, about 18.5 gb but i don’t want to remove the qgis, it’s absolutely necessary for me. this is the reason who i tried to update my system and not do a new clean installation.

1 Like


the size of the packets who was needing to update was about 2.9gb

2.9gb looks like a lot of packages.

If you have any additional repos enabled disable them (keep only main and main/updates) and try again.

Do it from Software Repository Selector (om-repo-picker)
$ sudo dnf clean all ; dnf clean all ; dnf repolist

If main packages update works fine (should be smaller size than before) you can enable the additional repos later and update the rest.
Clean dnf cache before each transaction.

1 Like

rugyada hello and thanks for the quick reply , i will try it later the afternoon when i am at my home, and i will post here the results.


Hello, i finally upgrade my system, following rugyada’s advise, and the ben’s guide and with ben’s invaluable help during the process for the rights choices, everything went well and i upgrade my system, thanks to all guys who helped me!!!


Update, four days after i upgrade my system following the process who is described above i have tested all the software who i have installed and everything work great. I also installed some apps like the BleachBit who were not working on my previous system and now work great too, i am very happy!