Can't update Plymouth Alternatives

  • OpenMandriva Lx version: 4:0

  • Desktop environment (KDE, LXQT…): KDE Default Plasma from clean install into physical PC

  • Description of the issue (screenshots if relevant): I can’t change/update the Plymouth theme from the System Preferences, picture below

I already searched and usually I get these commands to work on wich seems to be only for Debian based OS wich are these:

sudo update-alternatives --config default.plymouth
(here I should be asked to select desired plymouth theme but NOTHING happens)
sudo update-initramfs -u

Can someone tell me what am I missing? I see Plymouth while booting but can’t change it and that error means something is wrong.

Tell me if you need any other info, thanks!

1 Like

In OpenMandriva:

# plymouth-set-default-theme your_theme_name_here
# dracut -f
# update-grub2

If those are the correct commands to set Plymouth theme then our SystemSettings is not doing it right for OpenMandriva Lx. It that is the case then this is what we call a bug.

Personal opinion: I would rather our developers work on getting rid of Plymouth than spending time on fixing this is SystemSettings5. It is not the thing developers complain the most about as far as upstream software but it’s in the top 3. :poop:

Mmhh didn’t work, I will put here the results:

As you can see with the first command it returned not order found, then asked for instal “plymouth-scripts” wich tried but gave me an error because the are already installed (I installed before hand all the related Plymouth stuff from the software manager trying to solve this)

After I tried directly going over “dracut -f” wich tells me depend on 3 modles that can’t be installed (I missed the sudo in the first try tho)

Well, that is the update, I think thatis the only problem I have right now to feel like I customized everything I wanted, also I want to later upload the Plymouth I created it is based on Mandriva 2001 wallpapes and looks nice IMO hahaha, but can’t even use it myself, I mean, I see it when turning the PC Off since I replaced the old “OpeMandriva” files but sinec I can’ save it for boot it doesn’ work whe starting.

Those ‘network’ module errors are irrelevant, OpenMandriva does not use them.

$ sudo dracut -f

something is missing from that command. It needs a kernel to work on. What dracut does is it builds or rebuilds the kernel initrd so you can boot that kernel. I’m operating form my imperfect memory but I think to run it on the currently booted kernel it is:

$ sudo dracut -f $(uname -r).img $(uname -r)

For training and education for all users: In OM Lx:

$ sudo dracut -f -v /boot/initrd-$version.img $version

where $version is taken exactly from one of:

$ ls -1 /lib/modules

Edit: The -v option just means verbose as usual. It is optional. The -f option simply forces dracut to automatically overwrite the existing initrd file.

1 Like

Sorry, I didn’t get it, should I try using the first command with the “$version” or replace the version with one of this wich are the ones I get from your seccond command:

[sogetsu@Mandriva-PC ~]$ ls -1 /lib/modules

I already tried something with that but didn’t work, maybe I missunderstood something so I wait for further clarification to test ASAP

That’s just a command to list your kernel modules to use with the dracut command. What dracut command did you run?

Tried replacing both and both gave me error anyway, I will try again but which one should I chose to replace in the first command for dracut?

If you are booted in to OpenMandriva to get an idea of what you a doing just run this and see what it says:

$ uname -r

Then run this:

$ sudo dracut -f $(uname -r).img $(uname -r)

that will rebuild the initrd for the kernel you a using right now. ‘uname -r’ simply tells you what kernel you are booted in to at the moment. ‘$(uname -r)’ is a bash script way of telling it to use the current kernel version.

1 Like

Ok, tried both to check just in case, these are the results:

[sogetsu@Mandriva-PC ~]$ uname -r
[sogetsu@Mandriva-PC ~]$ sudo dracut -f $(uname -r).img $(uname -r)
[sudo] password for sogetsu:
dracut: dracut module 'ifcfg' depends on 'network', which can't be i
dracut: dracut module 'cifs' depends on 'network', which can't be in
dracut: dracut module 'nfs' depends on 'network', which can't be ins
[sogetsu@Mandriva-PC ~]$
[sogetsu@Mandriva-PC ~]$ sudo dracut -f $5.1.21-desktop-1omv4000.img
dracut: Cannot find module directory /lib/modules/.1.21-desktop-1omv
dracut: and --no-kernel was not specified

The first one worked as I knew it would because I use rather often myself. The second one is done incorrectly. Should not have the $ in it. Should be:

$ sudo dracut -f 5.1.21-desktop-1omv4000.img 5.1.21-desktop-1omv4000

You should try that one to see for yourself.

1 Like

Ok, I’ve got the same 3 “nework errors” again, exactly like running the first command.
No idea what could it be as you can realize, I did this in Ubuntu for the Ubuntu Plymouth so I can’t think of something wrong, simply editing the pictures in the same resolution of the standard theme and the it was the rebuild of the “image” for the boot screen, there in Ubuntu was the command of rebuld initramfs or someting like that and worked like a charm, here I thought I didn’t need to do anything since in the System Cofig Panel I have the option to select other Plymouth themes but like in the first picture I only get an error and now none of your commands seems to be working.
Is anything else I can check to bring you some useful information?

I’ve already told you those network error don’t mean anything. Those are things that are not used anymore. At least not in OM Lx. They have nothing to do with whether the command worked or not. If you got those it means the commands did work in fact.

1 Like

lol Sorry! I undestand about not caring the network errors but since I didn’t have any other message showing up I didn’t get it worked.

Rebooted and already showing the Plymouth update, thanks!! Thanks a lot man! For the help and the patience. Cheers! I will check how to upload the theme I made later .

This is exactly what I get and this is an example of successful ‘dracut -f’ operation.

That’s it that’s all you get.

1 Like

No worries. I mean that seriously. You’d laugh your rear end off if you saw what an idiot I was when I was learning this particular thing. I mean specifically building initrds with dracut or mkinitrd. I did it wrong a lot more times than you did today… :astonished:

Edit: FWIW: For me trying to remember stuff like this does not work. I have a cheat sheet. I believe in cheat sheets.

Post-edit: And I understand how to a user not used to doing this how the output looks like failure when it is the opposite in reality. Also glad you get the original issue sorted.

1 Like

So, to list all plymouth themes installed the command is (or better afaics was…)
plymouth-set-default-theme --list


[ruru@ruru-omlx4 ~]$ LC_ALL=C plymouth-set-default-theme --list
bash: plymouth-set-default-theme: command not found...
Install package 'plymouth-scripts' to provide command 'plymouth-set-default-theme'? [N/y] n

The commands I suggested are those I always used to test new distro themes, hence either something changed upstream (?) or we got a bug.

OMG I fell now myself into OP’s same error :crazy_face:
The commands must be run as root, as I wrote here


# plymouth-set-default-theme --list


# plymouth-set-default-theme OpenMandriva
# dracut -f
# update-grub2

@Shinusagi bear in mind that if you just replaced files while keeping OpenMandriva as plymouth theme name it will get soon overwritten by the next update.
For the change to be permanent -till you wish to change it again- you need to save it as a new theme with new name, properly set (see my first reply).

1 Like