Can't boot OM LX 4.0 alpha1 in recovery mode

omlx-4
Tags: #<Tag:0x00007f0e44a5f4c0>

#1

To boot OM LX 4.0 alpha1 I have to blacklist nouveau. With the proper instructions (rd.driver.blacklist=nouveau, etc …) I boot without problems in regular mode. Why can’t I (or what should I do) to boot in recovery mode?
I’ll try to get more of logs to attach here …


#2

Then I realize I don’t know enough to get logs. The following messages are issued when I try to boot OM LX 4.0 in recovery mode:

Tried to mount a USB stick as suggested but no USB stick was detected (dmesg did not show anything) Then tried to copy systemctl, journalctl to /root but upon rebooting no files was there …

:/# systemctl >root/systemctl.txt

So, what should I do to get these logs?


#3

Sorry for the mistyping, I tried

:/# systemctl status initrd-switch-root.service >root/systemctl.txt

and anything was in /root/ upon rebooting in regular mode.


(Tomasz Paweł Gajc) #4

You have all the information on your screen.

Just open /run/initramfs/rdsosreport.txt and check logs for errors.


#5

Well, as I know almost nothing in this subject, this is what I would suspect has an error message:

It is pointing to a problem with the “sysroot not being a OS tree”

The whole file /run/initframs/rdsos… is big and cannot fit a screen.

Without tips on how to copy systemctl, journalctl and this file, all that I can do is to show this image above.


(Tomasz Paweł Gajc) #6

Your /etc/os-release is missing. This means your installation may be broken.

You may want to boot your system without initrd in grub.


#7

Well, I’m surprised that it boots properly in regular mode then.

The problem only appears when I boot in recovery mode.

Anyway, I’ll try …


#8

And, the content of

$ cat /etc/os-release
NAME=“OpenMandriva Lx”
VERSION=“4.0 (Nitrogen)”
ID=“openmandriva”
VERSION_ID=“4.0”
BUILD_ID=“20181103.17”
PRETTY_NAME=“OpenMandriva Lx 4.0 (Nitrogen)”
VERSION_CODENAME="(Nitrogen)"
ANSI_COLOR=“1;43”
CPE_NAME=“cpe:/o:openmandriva:openmandriva_lx:4.0”
HOME_URL=“http://openmandriva.org/
BUG_REPORT_URL=“http://issues.openmandriva.org/
SUPPORT_URL=“https://forum.openmandriva.org
PRIVACY_POLICY_URL=“https://www.openmandriva.org/tos


(Abucodonosor) #9

@adelson.oliveira

I am not sure how you get in this situation…

For me all Alpha* installs I have, VMs or real HW booting fine
in recovery mode.

Also you can actually copy /run/initramfs/rdsosreport.txt to an USB stick
or try mount a HDD and copy to there.

For me it looks like your initrds are broken some sort … or a mix of broken
initrds and wrong grub entry.


(Ben Bullard) #10

This is just a guess but if you can boot in regular mode and not in recovery mode maybe try running:

$ sudo grub2-mkconfig -o /boot/grub2/grub.cfg

Here recovery mode also works normally.


#11

Well, this is my point, I don’t know how to do it…

Should I do it in regular mode?


#12

If I do,

$ cat /boot/grub2/grub.cfg

I see a lot of instructions besides a comment on it is being automatically generated by grub2-mkconfig


#13

Ben,

I did
$ grub2-mkconfig -o test

and then

$ diff test /boot/grub2/grub.cfg

and get no difference at all


(Ben Bullard) #14

Does not matter. That command is simply rewriting the file /boot/grub2/grub.cfg which is the grub2 menu.


(Ben Bullard) #15

Then it won’t help.


(Ben Bullard) #16

Is there a reason you need to boot in recovery mode?

For instance there are multiple ways to boot to command line from the regular boot entry if that is all that is needed.


#17

There has been in the past problems that i could solve only in recovery mode, NVidia drivers related problems for instance. By now, in alpha1 I’m just reporting what I think could be important to get a free of bugs release.


(Ben Bullard) #18

If you can boot to a command line you should still be able to do anything you can do in recovery mode right. And you can boot to a command line from regular boot entry simply be adding 3 to the end of the “Linux” line. That’s for run level 3 or you can to the same thing by adding to that line:

systemd.unit=multi-user.target

Yes that would be useful if it is an OM bug and not something that results from customizing system after install. So the first question that needs answering is does recovery mode work in a freshly installed system before you make any changes to the system?

If recovery mode works in a fresh install before any customization then as you customize one step at the time you keep checking until you find what is breaking recovery mode.


#19

This works Ok.

Well, the only customization I can recall was to include in the linux line,

rd.driver.blacklist=nouveau driver.blacklist=nouveau xorg.blacklist=nouveau=nouveau

and,

$ grub2-mkconfig

I did,

/:# makedir home
/:# mount /dev/sda1 /home

and finally was able to copy these files:

rdsosreport.txt (31,2 KB)
systemctl.txt (9,0 KB)
journalctl.txt (24,0 KB)

and I’m filing a bug about this …


#20

Although I’ve made a kind of a mess in reporting the bug, bug 2743 is there …