Can't boot OM LX 4.0 alpha1 in recovery mode

omlx-4
Tags: #<Tag:0x00007f0e46f45a28>

(Abucodonosor) #21

@adelson.oliveira

now I can reproduce after seeing your log and guesing your installation
which is from my guess this:

/dev/sda1 = /home = etx4
/dev/sda2 = EFI = vfat
nvme ( optane I assume ) = swap
/dev/sdb1 = roofs = btrfs

And now the bug is clear … RECOVERY has an bug with btrfs

For your setup and quick workaround will be this:

Open /etc/default/grub
On GRUB_CMDLINE_LINUX_RECOVERY= line add this:
rootflags=subvol=@

Now grub2-mkconfig -o /boot/grub2/grub.cfg and on next reboot you can go RECOVERY

BTW @adelson.oliveira like I’ve told you before it helps when you tell us about your setup,
we cannot guess that.


#22

Now I can boot in recovery mode!
Since it worked, I’ve tried doing the same in GRUB_CMDLINE_LINUX_DEFAULT. Regular mode booted finely as well. Is there any reason why I should not use rootflags=subvol=@ for the regular boot as well?

Thanks a lot


(Abucodonosor) #23

@adelson.oliveira

for normal boot is done magically … No need to add anything.
The bug exists in RECOVERY , fix for that will be pushed later on today.


#24

I’m going to close bug 2743 …


(Abucodonosor) #25

please don’t … we do that once we push the fix out


#26

Sorry, I was faster than you. Anyway, there I just suggested closing the bug. And, in fact, the bug is not 2743! It is 2423! I need new, more accurate, glasses…