Blender produces core-dump when started in omlx-303

Tags: #<Tag:0x00007fe31859cd80>

Hello,

I installed blender from the omlx-303 repository. When I try to start it, a core-dump is produced. Can this behaviour be verified?

Regards,
Albert

$ blender
Segmentation fault (core dumped)

A bug report would be advised.

Can confirm this. Worth to add “static version” 1.76b downloaded from http://download.blender.org/release/Blender2.76/blender-2.76b-linux-glibc211-x86_64.tar.bz2 just work without this issue. So if you need urgently blender, try download it from here: Download — blender.org unpack and launch from ./blender file.

Thanks for the advise, but I don’t need it that urgent. I was just testing my new installation.

I created bug 2341

Regards,
Albert

Hello AngryPenguin,

At first I wasn’t interested in the “static version” because you mentioned version 1.76b in your reply, but looking into it a little closer I noticed that its about version 2.76b which is identical to the blender version in the OpenMandriva repository.

Thanks for the tip I will use your work-around.

Regards,
Albert

It is most helpful if you file a bug report about an ongoing issue in a forum thread to post the link to that bug report. This one is here.

In that bug report is a link to a new package in main-testing repo for testing to see if it resolves this issue. :smiley:

Edit: Please report results of testing the new package here and in the bug report.

The new package in Main-testing segfaults here. I ran a backtrace on it and with help of crazy (@ #openmandriva-cooker IRC) we determined that there is a dependency circle.

Edit: Removed some stuff made irrelevant. See below. @Colin has made another attempt to build a working package.

In about an hour a working blender package should be available in testing. You will need to fully update your installation from the testing directory as other libraries are needed from there.
Colin

2 Likes

All right, thanks.

OK, here is the latest. Packages (2) in main-testing repo. Either enable the repo and update or if you don’t want a bunch of testing repo packages download and install ‘lib64OpenColorIO1’ and ‘blender 2.76b-5’. And now blender works here. Or at least it opens without segfaulting.

So now we can all live happily ever after. :joy:

And @vhelmont can mark this thread as solved if blender also works for him.

Edit: For building this credit goes to @Colin, @bero, and crazy. Thanks to all of you.

1 Like

Hello Ben,

Sorry for the late reply, but I was busy with other stuff. I installed the work around mentioned above which worked for me and lost track of this open issue.

Two remarks:

  • I couldn’t find the packages you mentioned in your previous post, the links return as invalid. Are the packages moved to another repository?

  • Firefox is doing difficult when you try to enter this forum. It complains about invalid certificates. Is this a known issue?

Regards,
Albert

Well the packages were in testing repo. Packages don’t stay there for long usually. They are probably in updates repo now. To check use ‘rpm -a <package_name>’ or ‘rpm -qa | grep <partial_package_name>’.

Yes.

Edit: Surely users of this forum know how to find packages in our repositories by now? Right?

I installed blender and it performs as expected, thanks.

The repositories are fine, its entering the forum and posting questions which is difficult especially for new inexperienced users.

Why is that, not sure I understand.

If it is fear of making mistakes or being incorrect about something not many new users will beat me at either. Been there done that many times. What I focus on is trying to not repeat the same mistakes over and over. (Not always successfully).
:monkey:

1 Like

Hello Ben,

It’s not a question of making mistakes. I simply want to inform you that the first time you try to load the main page of the forum, firefox warns you about trying to enter an unsafe site.

I can imagine that this scares people off.

Regards,
Albert

OK, that is Firefox doing that not the forum. And I don’t know all the details about why Firefox does that with some sites. Or if the forum has a certificate that is out of date.

But yes it almost certainly does scare some people off. @jclvanier, @raphael any ideas or illumination on this issue?

Strange,

Is your time and date correct in your system?

Edit: can you try with https://forum3.openmandriva.org (no “s” after forum)?

what version of firefox do you use?

I think it is the URL if use https://forums.openmandriva.org

But if I use https://forum3.openmandriva.org

Edit: Correction > I don’t know that forums vs. forum is or isn’t correct but just how they each work here.

Edit-2: Thanks for the tip @raphael.

1 Like

I need to squash this bug, anyway! :cowboy_hat_face::cricket::spider::bug: