After updates NTFS partition isn't mounted

After recent updates (around 300 packages) NTFS partition is no more mounted at login. I have to mount it manually at every login.
Tried systemsetting -> removable storage -> removable devices -> automount on login but it don’t works.

  • OpenMandriva Lx version: Lx 3 64 bit

  • Desktop environment KDE: 5

I have the same problem after update to KDE Plasma 5.10.5.

I had the same problem as well , so this issue needs further investigation , in the mean time to fix the issue,
On reboot , when the Plymouth screen appears,and a list of options are presented , on the line where it says Advanced options for OpenMandriva Lx
I used the arrow keys to scroll down to it , press the enter key , a new window appears and offers a list of options
I noticed that different kernel versions where among the items on the list so ,
I selected an earlier kernel version which solved the problem of seeing the NTFS

That sounds like the Grub2 Menu not Plymouth.

That indicates this may be a kernel issue.

Now we get to why I keep complaining about people reporting updates broke something. No, that is very unlikely. What is much more likely is that a package within the updated packages broke something which is why I keep saying to post the list of updated packages when it seems that “updates” breaks something. Otherwise no one has enough information to do any more than guess. Try also to remember that every system update is unique. No one trying to help has a clue as to exactly what packages were involved in your update.

Now, based on @jimmyc’s report it appears to be a kernel issue. Maybe.

  1. So could all of you with broken NTFS support investigate and report if there were/weren’t kernel packages in the update in question? Even better post the list of updated packages in case there were packages that affect file system support.

  2. Also all of you could you try booting into an earlier kernel and see if that is a workaround?

Perhaps it is worth mentioning that with only 3 people checking packages and one of those is on holiday it is easy for something like this to slip through the process. There may not have been anyone with a NTFS partition testing at the time.

Any suggestions on how this type of thing could be fixed?

There has been work by @Colin and @TPG on automatic testing and some considerable improvement there. But ultimately there is no substitute for human testing on a wide variety of hardware. I hope someday we can automate some of that as well.

I specified that updates are almost 300 (296 if I remember well). Is it useful this list? If you need I can make it. But in my opinion it’s much better that a developer restrict the number of packages involved in automount and asks about them.

Tried to boot 4.11.3-desktop-2omv that I’m forced to use when I need wireless (because an old bug still unsolved) and problem isn’t solved. Then in my opinion this problem isn’t related to kernel version.

I’ve no problem at all in seeing partition. What don’t works anymore is automount, as I wrote in first message.

Yes. You can with large groups like KDE Frameworks or KDE Plasma eliminate a lot of those (unless the issue is relevant to KDE packages). But otherwise the answer is yes.

I am skeptical that this would be a kernel issue but I don’t know anything really about how automount works. I just know that on Linux computers with ext4 fs OM Lx 3 tends to mount every partition. And every partition tends to be available in Dolphin or other File Manager.

This issue needs a bug report.

Edit: Or for someone with the issue to go on IRC and talk to @Colin, @TPG, or @bero.

Talked to @Colin on IRC and he thinks he knows what this is. Will look at it soon.

@Colin and I just tried to reproduce this issue and can’t. NTFS partition is mounted here. So more evidence is needed from people with the issue in order for anyone to do anything.

First when you say the partition isn’t mounted what exactly do you mean? What is expected behavior. Here I create an NTFS partition and reboot and open Dolphin and the partition is just there and available and I was able to create a file in that partition.

Also we’re going to need to get some lists of updated packages to see if anything was installed that would likely change this.

And finally could you post complete out put of:

$ lsmod | grep fuse

Edit: Also need to be sure package ‘ntfs-3g’ is installed. The output of this will show that if it is installed:

$ rpm -qa ntfs-3g

@Giorgio… question …is your set up a dual boot system ?
and did you check /etc/mtab to see if the NTFS is listed there , you might have to edit /etc/mtab

Please be careful these days NTFS is mounted by systemd useing the kernel fuse modules which is a user land mounts system. The filesystem does not show up as NTFS.
Here is my mount entry for an BTFS partition.
/dev/sdd1 on /home/colin/Videos type fuseblk (rw,nosuid,nodev,noatime,user_id=0,group_id=0,allow_other,blksize=4096)
You’ll notice that there is no mention of NTFS
Try doing as root.
journalctl -b | grep fuseblk
and check what it returns

Thanks to all that answer but I would ask to read carefully my messages. In first one (and in one more) I’m asking about AUTOMATIC MOUNT of ntfs partiton. Nothing more than this.
To be more clear: in Dolphin I see NTFS partitions and I can mount them. But I want one of these partition automatically mounted at login. This was the behaviour before updates.
I opened this thread to know if this happens to me only or affect other users before opening bug 2314.

1 Like

No return.

[root@HP_16ac ~]# journalctl -b | grep fuseblk
[root@HP_16ac ~]#
I add a list of updates that probably caused bug updates_18_feb_2018.txt (22.2 KB)

Please do “lsmod | grep fuse”

$ lsmod | grep fuse
fuse 102400 7

Just checked out FUSE on wiki …thanks for the update… it’s been a while …thumbs up !:+1:

What is the result of the following command?

ls -l /etc/fstab*

$ ls -l /etc/fstab*
-rw-r–r-- 1 root root 619 mar 9 2017 /etc/fstab

going off a tip of what Colin said earlier

I found a wiki on filesystem in user space (fuse ) it might be helpful in determining why systemd does not automount the nt filesystem , the wiki is located here .

@Giorgio also check out systemd man pages systemd.automount(5).
also see if you have kernel version 4.14.14-desktop-22omv this is the one I switch back to .
have fun bro …on my way to Mexico for sun & surf …adios amigo