After updates NTFS partition isn't mounted

Done. No changes. I think this bug isn’t kernel related. Enjoy surf.

Sorry the kernel change did not work , I will help research more for a resolution , if not kernel related , then maybe config file or run control (rc) on start up . It’s time to do some reading on the subject and backtrace the steps…

on my way to the airport …:sunglasses:

So it has not been changed. Could you please post its content and the output of the following commands?

journalctl -ka | grep mount
journalctl -ka | grep -i ntfs

Here’s fstab (I added underscores to avoid big characters)

_# /etc/fstab: static file system information.
_#
_# Use ‘blkid’ to print the universally unique identifier for a device; this may
_# be used with UUID= as a more robust way to name devices that works even if
_# disks are added and removed. See fstab(5).

UUID=40BD-0983 /boot/efi vfat defaults,noatime 0 2
UUID=e043016e-1769-491d-b40e-49a766d427b1 swap swap defaults,noatime 0 0
UUID=fa3a0e7f-abe4-4801-b106-3faa8c0d320e / ext4 defaults,noatime 0 1

$ journalctl -ka | grep mount
feb 26 21:55:21 omv kernel: EXT4-fs (sda9): mounted filesystem with ordered data mode. Opts: (null)
feb 26 20:55:26 HP_16ac kernel: EXT4-fs (sda9): re-mounted. Opts: (null)

[root@HP_16ac ~]# journalctl -ka | grep -i ntfs
[root@HP_16ac ~]#

Simply post code as code.

# /etc/fstab: static file system information.
#
# Use ‘blkid’ to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).

I tried to include text between “code” and “/code” in square bracket but with fstab it don’t works. Now I see I have to add an end of line

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>                           <mount point>  <type>  <options>  <dump>  <pass>
UUID=40BD-0983                            /boot/efi      vfat    defaults,noatime 0       2
UUID=e043016e-1769-491d-b40e-49a766d427b1 swap           swap    defaults,noatime 0       0
UUID=fa3a0e7f-abe4-4801-b106-3faa8c0d320e /              ext4    defaults,noatime 0       1

Could it be that the filesystemd is dirty and thus systemd will not mount it? Try cleaning the ntfs and try again.
systemd has automated fsck but maybe the driver for ntfs isn’t installed.

[quote=“Colin, post:27, topic:1695”]
Try cleaning the ntfs and try again.
[/quote] How? Using Linux or in Windows?

urpmi ntfs-3g
Then use ntfsfix. You’ll need to read the man page but as I understand it there is a command to clear the dirty flag. It can do a lot of other things too.

I think this is what you asked for:

[root@HP_16ac ~]# ntfsfix /dev/sda6
Mounting volume… OK
Processing of $MFT and $MFTMirr completed successfully.
Checking the alternate boot sector… OK
NTFS volume version is 3.1.
NTFS partition /dev/sda6 was processed successfully.

and it seems partition is ok.

Still valid this nasty bug.
Any idea on how to mount an NTFS partition at boot?

1 Like

Normally you add the partition to /etc/fstab/. You can do this with KDE Partition Manager (preferred) or with Drakdisk (deprecated but still works here). Or you can manually add the partition to /etc/fstab.

If you need to learn more about any of the above use an Internet search. AKA: Google-ing.

And all users need to know that you can add partitons to an installation simply by using ‘Manual Partitioning’ and adding the partition. You’ll need to name the partition I un-creatively use for instance /Data1 and /Data2.

Screen-shot of KDE Partition Editor showing a /Data1 partition on a Hard Disk.

Typically I add this when I install an operating system. If I’m installing OpenMandriva I use “Manual Partitioning” to do this. But you can do this after installing with the KDE Partition Editor or other utility such as GParted or DrakDisk.

Screen-shot of /Data2 partition on same Solid State disk as operating systems on a multi-boot computer:

Thanx, but how to set an NTFS partition with automout option in KDE Partition Manager?

In post #11 Colin seems having a different opinion.
And I don’t edit /etc/fstab/ since long time. Remember that automount worked till few months ago.

This is my question too. I don’t see anything in KDE Partition Manager that allow automount. Nor found anything in the net.

Edit: In my first reply I got the answer completely wrong. What happened was at some point possibly from the beginning of Lx 3 it was set to mount everything, ie. all partitions on a computer that it could detect. This is considered to be a very bad practice by Linux developers so It was changed in the recent past probably at the time of the update where @Giorgio computer witnessed the change. So this is not a bug and will not be changed back to previous behavior under any circumstances. Again this was changed as a bad design practice that can lead to security issues as well as problems with booting and other problems.

Well. I think @ben79 explained it well and clearly.

If you still can not find this option read this:

use tool from openmandriva control center or kde partition. I prefer an old school method (I have a fondness for old times) but you can use kde partition in the same way.

  1. Open “Openmandriva Control Center” and go to “local drives” and launch “management of disk partitions” - . should be called similar (I have no english version so I’m guessing the name).

  2. Find your unmounted partition. Click on it and from the menu on the right, chose “mount point”.

  3. enter in the new window the name of the directory where your partition should be mounted. Ex. Disc1, data, games, fedora system etc. or any other name. I chose the directory: /media/disc1/

  4. Click on ok and after on done. Reboot computer and see… partition should be mounted.

1 Like

I have the screen-shots for how to do this in KDE Partition Manager and will post a tutorial soon in ‘Resources’ category. Does not matter if partition is NTFS or other FS.

Dudgum EDIT: I know from experience that what @AngryPenguin posted above about DrakDisk also will work. It is very easy to do. Does not matter if partition is NTFS or other FS.

Thanks for hints. Using OMCC partition is mounted at boot then problem is solved. I’ve not tried before this way because is deprecated.
But I have two comments

OMCC and KDE partiton manager is completely different, absolutely not equivalent. We will see how to get same result using KDE tool.

May be is bad practice in general but I need this partition mounted. The real bad practice is changing settings without user permission! And this is not the first time it happens. In my school lab suddenly boot order changed and my colleagues complained about it! Then I had to change settings in 18 pc with OpenMandriva!