3.02 iso build 1046


finally i’ve managed to build 3.02 iso with latest updates.

You can download it from here:


Dear QA and other fellows, feel free to give it testing
Bugs, requests for software please file on https://issues.openmandriva.org



Any response? Did anyone test it?

I’m on holiday at the moment so I have limited bandwidth and time. It will take most of the night to download I’ll do some basic testing in the morning and report if I’m given time to do so.

Colin Close

1 Like

I’ll test asap but can’t today…

Installed build 1046 in virtualbox but not had much time for testing.

No repo /testing enabled.
Just installed kernel-devel and guest additions. kernel-devel version is the same as kernel, so that’s ok now.
Guest additions compiled properly.

Currently not mentioning an issue I found because not 100% sure that it isn’t my fault, so need of further investigation.
Postedit: All right. Invalid :slight_smile:

1 Like

Same here. Very quick test. Both live mode and installed system work. No trouble in vbox.
There is no “real” graphical screen during the boot and I discovered something I wasn’t aware till now: if you strike an arrow key early after having started the machine, a text screen gives some unusual choices:

A new grub feature or an ancient I didn’t see before?

Installed on desktop and starting install on notebook. No regressions noted yet. Thorough testing will take longer. Maybe time to link Calamares > Release Notes and Known Issues to 3.02 pages? Just something noticed. Also noticed this bug is still in play. Don’t know if it’s upstream bug or not.

Hmmm strange, I doubt that is openmandriva feature. Looks like your laptop bios, efi or raid

Did a quick test this morning just booting live on real hardware with Intel graphics; Very impressed with boot speed never saw a live image boot this quick.
Couple of minor things on network.

The old network manager is still in draktools

The new network manager has default names of eth0 and wlan0 not sure that this is correct
I did not check whether the names had changed after establishing a connection (see below), I will do this later.
Device not detected on boot.
This is a pretty unusual hardware setup but wireless netwroking worked in 3.01 from boot but does not seem to work in 3.02.
The situation is this. I have a Broardcom wireless device in this laptop which requires the non-free repo for it’s firmware files so I don’t use it. What I use is a USB connected Edimax Ralink based device
to provide wireless. In 3.01 this device is picked up at boot and it’s firmware loaded and the new network manager sets it up and it works straight away.
In 3.02 this does not happen; to get it to work I must first unplug and then replug it after which it’s firmware is loaded and the new network manager picks it up and it work without issue.

1 Like

I will test this ISO today. I was out of town yesterday.

Do you see plymouth loading?

My enthusiasm for testing has waned there are two issues that lead to this being a NO GO for me.

  1. Our system of checking individual packages is broken. I don’t see how it is responsible to release ISO’s to the public until this gets fixed. I’ve said more than enough elsewhere about this.

  2. The ISO is still built with testing repo enabled. This also needs to be fixed before we release ISO’s to the public IMO. As above 'nuff said elsewhere.

Both of these need to change for me to not vote NO GO.

1 Like

At start, we see console lines. With the ESC key, Plymouth shows the famous ugly squares …

[quote=“ben79, post:12, topic:1128”]
Our system of checking individual packages is broken.[/quote]
I’m sorry, I had no time to read all the posts and I don’t understand what this means. Could you specify a little?

It’s in my mail to council and e-mails I sent to Cooker ML, I guess after ML stopped functioning. I’m kind of rushing to leave for weekend. If/when I find those e-mails I’ll post to Cooker Forum category.

I do not understand point 1, please explain.

Issue 2 is invalid, as all the packages a will be pushed to main/updates so nothing will be pulled on Iso from testing repository.

I installed this ISO on vbox without problems. When I tried to install it on my old PC, the background screen appeared, then the calamares one appeared then quickly disappeared. When I started up the Live system then ran calamares by hand, the install worked properly.



1 Like

Today I have to add
in skip.list for getting the --auto-update process finished because of:

Preparing...                     #######################################################
Installation failed:    file /etc/opensc.conf from install of lib64opensc4-0.16.0-1.x86_64 conflicts with file from package lib64opensc3-0.15.0-2.x86_64
        file /usr/lib64/onepin-opensc-pkcs11.so from install of lib64opensc4-0.16.0-1.x86_64 conflicts with file from package lib64opensc3-0.15.0-2.x86_64
        file /usr/lib64/opensc-pkcs11.so from install of lib64opensc4-0.16.0-1.x86_64 conflicts with file from package lib64opensc3-0.15.0-2.x86_64
[root@omlx-1046 ruru]#

You have to remove opensc and lib64opensc3 then reinstall opensc. The update changes the name of the library from lib64opensc3 to lib64opensc4 which causes the confusion.

1 Like

Thanks. Done.
I think worth mentioning, because it blocks the update process :slight_smile: