X11 doesn't work in Parallels Desktop 13

The problem is when you boot OMA 3 in PD13 (Parallels Desktop 13), it boots but gets stuck at X11 prompt. X11 says that there are no errors but there is no video output. Nothing except the console log of the boot process is visible. KDE doesn’t start. What should I do?

Please could you attach the /var/log/Xorg.0.log file?

1 Like

Welcome @supergeography2018.

Before anything else try booting in “Basic graphics mode”.

Just for your information the name of the release is OM Lx 3 or commonly Lx 3. Not OMA 3.

How to start an OpenMandriva ISO in “Basic Graphics Mode”:
Example is in VirtualBox using a OM Lx 4 pre-Alpha test ISO but is same with Lx 3 ISO’s.

1 Like

@ben79 We tried it, but it didn’t work.

1 Like

For some reason, I cannot boot to the basic graphics mode and I also cannot switch to virtual consoles when it’s stuck on that X11 text.

1 Like

Welcome @chengize.

1 Like

OK, thanks. First what are you trying to boot, which ISO? You can see from the screen-shots the line at the top of grub2 menu includes a Build ID: < number>. Next, and this is ultra important, are you booting on hardware or in a virtual machine such as VirtualBox?

Is there a bug report filed on this issue? Filing a bug report makes it easier and faster to get developers involved which looks like we need for this issue. If not could you do so here. I or a dev will probably ask you to post some logs or other information in the bug report. If there is anything you don’t understand how to do just ask and someone will walk you through it. To start with in the bug report could both of you please attach this. Also for hardware information if you would be so kind as to post output of this command string:

$ LC_ALL=C inxi -F -c 0

If both of you could put that output in a .txt file and attach it to the bug report and also attach it to a post here too. In the bug report also tell us what ISO you are using.

That log would be great if they can get it. Getting logs from OM ISO’s that won’t boot isn’t all that easy though.

The build number is 1588, which is OpenMandriva 3.03 64-bit.

Since Parallels is a virtualization software, it is emulating the hardware which is different from the host computer (which is a Mac). And while OpenMandriva 3.03 doesn’t boot in graphical mode from the ISO, it does boot from the ISO in the single user mode without GUI, so I was able to (sort of) get some details:

It appears it cannot automatically find a suitable driver for the custom emulated video card Parallels Accelerated Video Adapter automatically. That’s why it gets stuck on the X11 splash text.

BUT I found a way to make X11 work.

  1. Reboot the virtual machine and boot from the OpenMandriva ISO.
  2. When you see the GRUB2 menu, press the E key on the keyboard.
  3. Now at the end of the line which starts with linux /boot/vmlinuz0 you will see these kernel arguments:
quiet rhgb splash=silent

Replace them with:


Then just press Control-X on the keyboard to boot into single-user mode.
4. Now you’ll see a bunch of systemd related text and then this text:

Press Enter for maintenance
(or press Control-D to continue):

Press Enter on the keyboard.
5. Now type in XFdrake and press Enter. You’ll see OpenMandriva’s X11 configuration tool in text mode.
6. The tool will ask you to choose the X11 video card driver. Select Xorg|vesa and select OK.
7. Then a dialog named Xorg configuration with various options (such as disabling Control-Alt-Backspace) will appear. Just select OK.
8. The tool will ask you then to choose a monitor. Choose Generic|800x600 @ 60Hz and then select OK.
9. Set the resolution to 800x600 24bpp and select OK.
9. Then XFdrake will say that you need to reboot BUT DO NOT DO THAT!!! Instead, just select OK to exit the tool.
10. Now run this command:

# startx $(which startkde)

Now everything works! :slight_smile:
To install the system, open Konsole and run this command:

# calamares && reboot

Then follow the installer instructions and (if the installation completes successfully) after Calamares quits your system will reboot automatically.

There are additional steps that you need to do so that the installed system could boot in graphical mode. When you reboot your virtual machine after the installation and see GRUB2 menu select Advanced options and choose the option which has the (recovery mode) text at the end. Then enter the password for the root user that you’ve set during the installation. Run the XFdrake tool and repeat steps 6-9. After that, run the command reboot and then everything should work.


  1. Thank you, @ben79, for help! :slight_smile:
  2. Here is the bug report on Bugzilla: https://issues.openmandriva.org/show_bug.cgi?id=2355

OK, thanks for that.

Just a thought: Maybe it would boot in “Basic Graphics Mode” if you removed ‘nomodeset’ from the line which starts with linux /boot/vmlinuz0?

FWIW: This would be virtualization software that may not be familiar to OM Developers. It has not been tested. The only VM testing we do is with VirtualBox at this time.

No problem! :slight_smile:

I’ve tried that and, unfortunately, removing nomodeset still doesn’t help. It seems that the graphics adapter emulated by Parallels is not just automatically recognized at all.