Wine64 not working

Tags: #<Tag:0x00007f250db39230> #<Tag:0x00007f250db39168>

Hello,

OpenMandriva Lx version: 4.1

Desktop environment (KDE, LXQT…): KDE

I successfully installed Wine64 by Rock repository with Dnfdragora, but it crashes when I try to launch configuration or a test program.
The command “wine --check-libs” reports the following libraries are missing:
libcapi20.so.3
libGL.so.1
libnetapi.so
libodbc.so.2
libpcap.so.1
libsane.so.1
libXi.so.6
libxslt.so.1
libXxf86vm.so.1

After typing the command “winecfg” the following errors are returned:

000b:err:module:LdrInitializeThunk “ntdll.dll” failed to initialize, aborting
000b:err:module:LdrInitializeThunk Initializing dlls for L"C:\windows\system32\wineboot.exe" failed, status c0000005
0009:fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
000d:err:module:LdrInitializeThunk “ntdll.dll” failed to initialize, aborting
000d:err:module:LdrInitializeThunk Initializing dlls for L"C:\windows\system32\explorer.exe" failed, status c0000005
0009:fixme:winediag:start_process Wine Staging 5.0 is a testing version containing experimental patches.
0009:fixme:winediag:start_process Please mention your exact version when filing bug reports on winehq .org.
000f:fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
000f:err:module:LdrInitializeThunk “ntdll.dll” failed to initialize, aborting
000f:err:module:LdrInitializeThunk Initializing dlls for L"C:\windows\system32\winecfg.exe" failed, status c0000005

Is it possible the package I have installed a corrupt package? I asked for support to the WineHQ fellows and they told me to ask for help to my distro managers because maybe the Wine package was incomplete.
Please help me troubleshooting this issue.
Thank you!

People should really get into the habit of using the command line to install packages :roll_eyes:
It’s easy, quick, you can see what’s going on in real time, have the control over what happens and in case of any doubt abort the process, and last but not least you can keep the logs of all transactions.

1 Like

Helpful hint: Did you file a bug report on this same issue? If so a link here would be nice.

I’ve asked on IRC for developers to look into this we’ll see what happens. I do not use wine myself and do not know how to test it.

Post-edit: The regular IRC channel for users is #openmandriva @ Freenode IRC. You are welcome to go there yourself and weigh in on this issue. I wish users would do this more often with things like this that don’t work. Developers get tired of the same person (me for instance) always telling them something is broken. It is wise if they hear from a wider variety of users. I believe if developers heard about problems from more users then the issue would seem more urgent. The squeaky wheel gets the grease.

OK @Marco I got some information from @bero on IRC. We aren’t doing it right. @bero says wine is working in Lx 4.1. And it is a bit confusing to me but I’ve already admitted I don’t know anything about using wine. Here are the most important points form IRC conversation:

< bero> you just need to know what to do
< bero> and you have to pick between wine32 and wine64 because they can’t coexist
< bero> but since 64bit stuff is still relatively rare in the M$ world, most people who installed wine32 never noticed wine64 is missing
< ben79> So user should enable i686 and install wine32 and not wine64 is what I think I’m hearing.
< bero> remove wine64, enable i686 repos, install wine32
< bero> to get a version that works for both 32bit and 64bit Windoze stuff, we need what we’ve done in cooker

Hope this makes sense. Please try it and let us know.

Obviously what he is talking about “what we’ve done in cooker” should be available for OM Lx 4.2. I do know that he has spent a lot of time on this in Cooker over last few weeks. So wine is definitely not being ignored.

In fact I installed Wine64 both from shell and from graphic facility with no difference at all.

@Marco the following is worth noting.

< ben79> bero: Another question about wine, if user runs “wine --check-libs” is does report some missing. But does that mean it does not work? Or are there so many dadgum libs that it just does that?
< bero> Probably hamless and fixable by just installing the libs
< bero> we don’t have hard dependencies there because some of them are needed only for extremely obscure functionality
< bero> e.g. you need a few extra libraries if you want to use an ISDN card from a Windoze application

I’m quoting this stuff from IRC exactly. I hope to get the information as correct as possible. From listening to developers talk about it wine is a very, very, complex thing to work with.

Thank you so much, Ben.
As you may have noticed, I had already posted a Wine64 issue on the OM bug tracker (id 2626).
I’ll remove 64bit package and install wine32. I’ll let you know.

1 Like

Look forward to hearing from you. I will edit the bug report if and when I can confirm what we are doing actually works.

I don’t have any Windows applications to test at the moment and am looking in to see if I can get a few simple ones for free somewhere. I would like to come up with a simple way to add testing wine to OM QA testers tool box.

Post-edit: I also installed wine64 at first. Did not know any better.

It would be awesome if any wine users could let us know for a fact that it works in Lx 4.1. That is what I’m trying to get to is to confirm for sure that it is working. I believe it is but need to confirm with users.

Ben, I did as you suggested.
I confirm on my system Wine32 is working fine, instead the 64 bit version does not.

1 Like

What exactly about wine64 does not work? If the applications you use work with wine32 that means you were using the wrong version of wine not that it does not work. I’m just trying to find out if there is an actual bug with wine64?

Also I don’t know yet how all this stuff works myself. I just noticed that if I install wine32 with i686 repos enabled that dnf also will install wine64 maybe that is how it is supposed to work?

Post-edit: wine32-install-list.txt (39.9 KB) If you look at the bottom of the dependency list you will see wine64 installed as well as the requested wine32.

When I installed Wine64 only, the whole package crashed as I tried to configurate it with “Winecfg” command.
After I removed it and installed Wine32, configuration was fine and test programs like Notepad worked.
I needed Wine to avoid installing a virtual machine. I need to establish a particular RDC connection, but no Linux client was suitable.

From what I’ve seen VirtualBox would be a lot easier to deal with than wine.

In QA testing we use VirtualBox a lot for packages and ISO’s and especially for problem solving for bug reports and forum issues.

Ben, thank you for your suggestions.
I hoped I could manage rdp connections in an easier way, but I realize that some operating system facilities are more complex than they appear. I think I’ll try virtualbox; let’s cross fingers…

As far as I know both wine32 and wine64 work in Lx 4.1. You can not install both you must chose one or the other. For both versions you must enable i686 /main and /main/updates repositories before installing or they will not work.