Wifi not working

I have an Asus X550CA laptop that I have Openmandriva installed on and it has a mediatek 7650e wifi chipset in it. When I run lcpsi in the Konsole it shows up. But when I go into the network configuration it doesn’t show and no wifi networks. So how do I get openmandriva to recognize this wifi chip? Could anyone please write out step by step what I need to put into the Konsole? I really need to get the wifi working?

I have a ASUS X550CA myself and wifi works here.

What version of OMLx are you using? Rock/4.3? I have ROME and Cooker partitions installed on mine. I did previously have Rock/4.3 installed on it and wifi worked then also.

Maybe you can post some screen shots of what you are seeing with the wifi config?

Edit: Hmmm… I may have different hardware than yours in spite of the similar model name.

$ lspci
00:1f.3 SMBus: Intel Corporation 7 Series/C216 Chipset Family SMBus Controller (rev 04)
02:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)

We should still be able to sort out this problem though.

Edit: List of wifi devices drivers existing in Linux kernel:

kernel.org wireless drivers

Open-source wireless drivers

I just asked our devs on OpenMandriva Chat if the one you posted is supported. We do add a few based on user requests. FWIW the added wifi drivers would be in kernel-firmware-extra package which is installed by default.

Apologies for the extra edits. Brain malfunction…


Moderator: I just increased your trust level so you can post screen shots or anything else that may help troubleshoot this issue.

With help from our devs:

We show that the driver is present in Rock/4.3, and ROME (rolling) releases.

In 4.3:

$ rpm -qf /lib/firmware/mediatek/mt7650e.bin


$ rpm -qf /lib/firmware/mediatek/mt7650e.bin.xz 

Reason for the difference in where it is located is that old kernels don’t support compressed firmware.

The driver is mt76 so maybe all that is needed is:

$ sudo modprobe mt76

and see if it is working.

Note: The command inxi -n will tell you about your network devices and drivers in use. For overall hardware info use inxi -F.

Hi Ben you’re not gonna believe this. After reading your replies I went upstairs and booted up my laptop to take pics for you here and you’re not gonna believe what popped up after the bootup? The wifi icon. So I clicked on it and there was the wifi list and of course mine showed up as well so I click on mine and put in my wifi password and voila it says I’m connected to the Internet. Don’t ask me what happened. I was working on it earlier and then it was just a square in the taskbar and saying no connections. I shut the machine down all frustrated and I post on this thread. And I go back and boot the machine and here’s wifi. Not sure if it was divine intervention but now it’s working. What can I say? Weird

Glad you got it working. Sometimes just rebooting clears up something like this. I guess every once in a while something fails during boot process. I learned some things in chasing down the issue so all good.