What good are volume controls? Solved

This just started happening so probably related to something updated today. No matter what I set volume to if I logout/login it is changed to 33%. I’ve even run:

# alsactl store

This is one of the things about LInux that drives me crazy.:rage: Not being able to set and keep a constant volume setting. This is hugely important to older people, those who live in close proximity to others (most of us), and those with pets, children, angry teenagers, and angry spouses. If ‘alsactl store’ doesn’t do it what the heck does? In this instance I’m thankful that OMLx3/2015/Cooker/how-frickin-many-names-do-we-need is setting it at lower setting, I have seen instances where system keeps setting volume to 100% which can cause one to have one’s lease revoked, pets and teenagers running away from home, neighbors calling the police, and spouse giving that “just one more #$%^up and I’m calling divorce lawyer” look.

FWIW: I’ve had computers since ms-dos and I don’t recall ever even thinking about this on a Windows computer. None the less I prefer Linux to Windows and just wish one Linux distro could come up with a way to have a setting that results in the same volume setting every time I start my system. This is more aggravating than than any other problem in the entire cosmos.:smiling_imp:

OK, OK, I know this turned in to a, I hope humorous, rant but I AM serious about the core issue.

FWIW2: how-frickin-many-names-do-we-need would be a good name for our upcoming release. Can’t believe we’re going to release something probably in October 2016 that most people, including developers, are calling 2015. This is the second most aggravating thing in the entire cosmos.:grin:


Did you try different kind of distro? I remember having almost :heart: attack with Mandriva start music or kcrash notification during the night :smiley: But not all distro seems to suffer from this.

Currently only openSUSE Leap 42.1 and OpenMandriva 2014 both of which seem pretty well behaved in this regard. And this only started yesterday in OMLx3/2015/Cooker so hopefully it won’t be a permanent ‘feature’.

I do remember a time or two when Mandriva would reset volume to 100% and my desktop has pretty powerful Klipsh speakers so it did cause some fairly big problems!

So far nothing works. In cooker no matter what I do if I logout or reboot system volume gets set to 33%. Is there any way to get my volume control unstuck? I’ve tried playing with so called ‘fall back’ button which does nothing. I’ve tried ‘alsactl store’ also does nothing. How to get system volume unstuck?

Don’t have this problem in 2014 or openSUSE Leap 42.1.

I have not this behaviour Ben. I have 2 users with different volume and these settings are saved.

May you have to try a new user or a clean home.

iso 130 updated

Yeah, that did it. Thanks.

I’ve done a fresh install and that is working correctly so far as well as one or two other issues. It had to be something I did. Don’t know what, yet.