--wget appears broken with urpmi --auto-update

Hello,

OMV LX 3.03, updated!

Why there are differences if I launch,

$ urpmi --wget --auto-update
Packages are up to date

and

$ urpmi --auto-udate
Package Version Release Dist DEpoch Arch
(medium "main updates (Einsteinium3.0-2)")
ffmpeg 4.0.2 1 omv 2015.0 x86_64
lib64avcodec58 4.0.2 1 omv 2015.0 x86_64
lib64avdevice58 4.0.2 1 omv 2015.0 x86_64
lib64avfilter7 4.0.2 1 omv 2015.0 x86_64
lib64avformat58 4.0.2 1 omv 2015.0 x86_64
lib64avresample4 4.0.2 1 omv 2015.0 x86_64
lib64avutil56 4.0.2 1 omv 2015.0 x86_64
lib64postproc55 4.0.2 1 omv 2015.0 x86_64
lib64swresample3 4.0.2 1 omv 2015.0 x86_64
lib64swscaler5 4.0.2 1 omv 2015.0 x86_64
(medium "restricted (Einsteinium3.0-13)")
lib64fdk-aac1 0.1.4 2 omv 2015.0 x86_64 (suggested)
lib64opencore-amr0 0.1.3 2 omv 2015.0 x86_64 (suggested)
lib64xvid4 1.3.4 1 omv 2015.0 x86_64 (suggested)
20MB of additional disk space will be used.
8.3MB of packages will be retrieved.
Proceed with the installation of the 13 packages? (Y/n)

Why would anyone use --wget for --auto-update in the first place. Don’t understand.

If you want to use wget you set it in Global Options in drakrpm-edit-media. Or use aria2 which as everyone knows is the best. :face_with_hand_over_mouth:

General information for all users.

There are instructions for urpmi one is 'urpmi --help and there is ‘man urpmi’. This is from ‘man urpmi’:

Download Options
–parallel alias
Activate distributed execution of urpmi to other machines (it is mandatory that urpmi is installed, but it is not necessary to have media defined on any
machines). alias defines which extension module is to be used by urpmi (currently, “urpmi-parallel-ka-run” or “urpmi-parallel-ssh” are available) and which
machines should be updated. This alias is defined in the file /etc/urpmi/parallel.cfg as described in the urpmi.files manpage.

   --downloader program name
       Use a specific program for downloading distant files via http or ftp.  By default curl is used if available, or wget instead.

–curl-options ‘options’
–rsync-options ‘options’
–wget-options ‘options’
Specify additional command-line options to be passed to curl, rsync or wget when retrieving files. If several options are to be passed, separate them with
spaces and enclose them in quotes.

       Note that the rsync options will also be used for ssh media (since it's actually rsync over ssh).

   --limit-rate rate
       Try to limit the download speed. rate is given in bytes/sec. This option is not active by default.

   --resume
       Resume transfer of partially-downloaded files.

   --retry times
       Retries to download files over FTP or HTTP the specified number of times.

   --proxy proxyhost[:port]
       Use specified HTTP proxy.

   --proxy-user user:password
       Use specified user and password to use for proxy authentication.  Specifying --proxy-user=ask will cause urpmi to prompt for a username and a password.

I just tried and ‘urpmi --wget --auto-update’ works here (Post-edit: ‘urpmi --aria2 --auto-update’ and ‘urpmi --curl --auto-update’ also work):

$ urpmi --wget --auto-update
medium "main2" is up-to-date
medium "main updates2" is up-to-date
medium "contrib2" is up-to-date
medium "contrib updates2" is up-to-date
medium "non-free2" is up-to-date
medium "non-free updates2" is up-to-date
medium "restricted2" is up-to-date
medium "restricted updates2" is up-to-date
medium "MAIN-TESTING-2" is up-to-date
medium "CONTRIB-TESTING-2" is up-to-date
medium "NONFREE-TESTING-2" is up-to-date
medium "RESTRICTED-TESTING-2" is up-to-date
To satisfy dependencies, the following packages are going to be installed:

I just have never thought to use it since I use aria2 and set that in Global Options in drakrpm-edit-media.

Post-edit: To be honest I don’t know if any of the options curl, wget, or aria2 are better or worse. I doubt most users would know the difference regardless of which they use. rsync is different and does have it’s advantages and perhaps (not sure) disadvantages.

Back in Mandriva days I was told by someone more knowledgeable that aria2 was to be preferred but do not know what our current developers would say on this.

As for now, the wget option is not getting the list of packages to update yet.

The reason I do

urpmi --wget ....

is that the default (curl or aria2?) did not handle low profile internet connections as wget does. It happened many times that, on a low velocity connection, the package download was stopped and I had to start all over again. Using wget, the process just wait much longer for the download to finish …

Worth noting for all users posting about technical problems in forum>

There are very important reasons why I keep asking user to post all of the output of a command and to do so exactly. If the output is to long (more than about 15 lines) please put it in a file and post the file here. Also users with non-English computers don’t forget to preface commands with LC_ALL=C so output is in C so people trying to help you can read the output.

curl is the default.

I’m not asking why you use wget I am asking why don’t you set that globally in drakrpm-edit-media. Then the command option is no longer needed.

And again the commands works here. Perhaps something besides the command is amiss.

Just give aria2 at try. It worked fine. By the way, the wget option is not finding available updates since a couple of weeks for some repositories!

Then file a but report. And document the problem in the report.

I have tried several mirrors and can not duplicate the problem here.

FWIW: The output should look something like:

# urpmi --wget --auto-update
medium "main" is up-to-date
medium "main updates" is up-to-date
medium "contrib" is up-to-date
medium "contrib updates" is up-to-date
medium "non-free" is up-to-date
medium "non-free updates" is up-to-date
medium "restricted" is up-to-date
medium "restricted updates" is up-to-date
Packages are up to date

Not:

# urpmi --wget --auto-update
Packages are up to date

But if you were using this in the past I don’t know what would have changed.

Post-edit: Bug report. Having a conversation with me on the forum won’t get this resolved.

Not sure how to check that anyway? How can anyone check?

Post-edit: And thinking some more if you posted the exact URL’s for all the repos in question perhaps some users here could check and see if they also have the same problem before you file a bug report.

I’ve omitted the output about the media just for brevity. Sorry if this led to misunderstood. The output with --wget here is as yours. The point is that with curl or aria2 the list of packages for update was not empty…

No I mean what mirrors aren’t working? How can I check with out the URL?

I agree this is a incomplete report. In fact, I just guess this has something to do with which repositories are being used because I get different results in two different OMV installations. What I have now is only that,

  • Sometimes one computer sees the available updates with --wget and the other doesn’t.
  • Discovery sees the updates and urpmi --wget --auto-updates doesn’t in both computers.

As soon as I have more information on this I’ll file a bug report.

Thanks

But i wanted to get the exact URL’s so I could check the mirrors myself.

Also you haven’t mentioned if you are/aren’t using testing repos.

Try the following commands:

$ urpmq --list-url
and
$ urpmq --list-media active

2 Likes

Easy!

Computer 1 is the one with --wget working better. Its files are,
list-url-comp1.txt (1,7 KB)
list-media_active-comp1.txt (253 Bytes)

Computer 2 is the one where --wget seems not to find the current list of updates. Its files are,

list-url-comp2.txt (1,6 KB)

list-media_active-comp2.txt (253 Bytes)

The first thing to be noted is that on comp2 you have " mirrorservice " set whereas on comp1 you have a specified mirror (coffee.ipsl.jussieu.fr).

So you can try with setting the same as on comp1

urpmi.removemedia -a
urpmi --clean -av
urpmi.addmedia --update main http://distrib-coffee.ipsl.jussieu.fr/pub/linux/openmandriva/3.0/repository/x86_64/media/main/release
urpmi.addmedia --update main_up http://distrib-coffee.ipsl.jussieu.fr/pub/linux/openmandriva/3.0/repository/x86_64/media/main/updates
urpmi.addmedia --update contrib http://distrib-coffee.ipsl.jussieu.fr/pub/linux/openmandriva/3.0/repository/x86_64/media/contrib/release
urpmi.addmedia --update contrib_up http://distrib-coffee.ipsl.jussieu.fr/pub/linux/openmandriva/3.0/repository/x86_64/media/contrib/updates
urpmi.addmedia --update non-free http://distrib-coffee.ipsl.jussieu.fr/pub/linux/openmandriva/3.0/repository/x86_64/media/non-free/release
urpmi.addmedia --update non-free_up http://distrib-coffee.ipsl.jussieu.fr/pub/linux/openmandriva/3.0/repository/x86_64/media/non-free/updates
urpmi.addmedia --update restricted http://distrib-coffee.ipsl.jussieu.fr/pub/linux/openmandriva/3.0/repository/x86_64/media/restricted/release
urpmi.addmedia --update restricted_up http://distrib-coffee.ipsl.jussieu.fr/pub/linux/openmandriva/3.0/repository/x86_64/media/restricted/updates
urpmi.addmedia --update --raw main_testing http://abf-downloads.openmandriva.org/3.0/repository/x86_64/main/testing
urpmi.addmedia --update --raw contrib_testing http://abf-downloads.openmandriva.org/3.0/repository/x86_64/contrib/testing
urpmi.addmedia --update --raw non-free_testing http://abf-downloads.openmandriva.org/3.0/repository/x86_64/non-free/testing
urpmi.addmedia --update --raw mandian_personal http://abf-downloads.openmandriva.org/mandian_personal/repository/3.0/x86_64/main/release
urpmi.update -a

Note that repositories configured with --raw option are set but not enabled. If/when you need, you can/have to enable them.
Read also: https://forum3.openmandriva.org/t/how-to-update-openmandriva-lx-3/1764

2 Likes

You may also check you haven’t a personalized user startup file for wget: usually it is paced at $HOME/.wgetrc (where in this case home may be /root).

1 Like

@adelson.oliveira any news?