Apologies if I seem dense but not sure what is being asked. My guess is you think you need different version of lib64webkitgtk but which version? And for what reason? No package “devel” available in same version as what? Will just any other version of lib64webkitgtk work for your needs?
Edit: For different versions of any package you can look here and here.
Also to make a request for developers to upgrade a given package the procedure is to file a bug report and explain in detail what you need and why you need it and under “Importance” select “trivial/enhancement”.
I need at least, this package : lib64webkitgtk3.0-devel
Because I want to install " wxPython Phoenix ".
So, to compile wxPython, a “libwebkitgtk” is needed, more precisely the “devel” package, otherwise the compilation is failing.
the lib64webkitgtk3.0_0 is 1:2.4.11-2:2015.0
but the lib64webkitgtk3.0-devel available is only 1:2.4.11-1:2015.0
so I can’t install this “devel” package, OpenMandriva refuses to install it because it’s not the same version of lib64webkitgtk3.0_0
First know that I’m a user like you not a developer and a developer would know more about this. If you want to talk to a developer about this you could try on #openmandriva-cooker on Freenode IRC. And be prepared to wait for an answer, sometimes you get one right away and sometimes it takes a couple of days.
As far as I can tell the solution remains to remove or downgrade the 2.4.11-2 to 2.4.11-1. The fact that the 2.4.11-2 packages are no longer in the repos possibly indicates something was wrong with them.
Edit: If you do go on IRC by all means post the link to your bug report on this issue.
Thank you ben79 for your help.
I tried a new build, and all is ok now : I could install the ‘libwebkit-devel’ package with that new version, and run my python2.7 program. As you told me on IRC channel.