VM's will not boot /w virtualbox-5.2.16-1 on ASUS X550C notebook

virtualbox
testing
resolved
omlx-3
Tags: #<Tag:0x00007fb7216fc720> #<Tag:0x00007fb7216fc540> #<Tag:0x00007fb7216fc360> #<Tag:0x00007fb7216fc1a8>

(Ben Bullard) #1

I have one computer where VM’s will not boot with this package. I mean that I select to boot from grub2 menu and and the screen changes to what it normally does when first booting and it stops, just nothing. Not sure what logs to provide for this? If someone could advise? On my desktop I am using VBox 5.12.3 with no issue so don’t know why it’s only on my Notebook that this occurs. The notebook does have a much less capable CPU i5 3337U vs. Desktop i5 4590. Notebook has 12 GB memory vs. 16 GB for desktop. I set the VM’s to have 4 GB memory and then after installation set that to 3 GB.


(Ben Bullard) #2

As I recall I was able to boot the ISO and install Lx 3 using ISO build # 1915. It is the installed system that will not boot. Will not even begin to boot. I will reinstall VBox 5.12.3 and test this sometime later today or tomorrow. And get some logs and a screen shot.


(Ben Bullard) #3

Of note is that this VM has 2 of 4 cpu cores available and when it tries to boot it uses 100% of those 2 cores so something is borked. Also I can boot the Live ISO of build # 1915 and install the system it is only when I try to boot the installed system that there is a problem. Here is screen shot of where boot process stops, or more accurately never starts:

And here is VBox.log.2 (I think that is the right one) while VM is in the state shown in the screen shot.

VBox.log.2.txt (155.2 KB)

And the other available logs:

VBox.log.txt (89.8 KB)

VBox.log.1.txt (135.2 KB)

there is not a VBox.log.4 for the VM yet.


(Ben Bullard) #4

And FWIW a screen shot showing VBox using 50% of total machine CPU that is !00% of 2 cores out of 4. Memory use shown too. I don’t think the memory use is unusual.


(Colin Close) #5

I don’t know whart to make of this Ben. I’m seeing all kinds of strange stuff on my cooker install under vbox. I think it’s related to the illegal instruction business. I just don’t have time to mess with it at the moment.


(Ben Bullard) #6

I don’t think so the same VM’s with the same settings will boot just fine with Vbox 5.8.2. I am referring to OMV VBox packages not Oracle ones. So this makes me think the problem is specific to OMV VBox 5.12.3 ergo an issue for @TPG perhaps. An additional factor is that this only happens on one computer (so far), on my desktop OMV VBox 5.12.3 appears to work OK and VM’s boot normally.

Could it be that some of the changes in Cooker with how packages are built globally has filtered in to Lx 3 package building. That I don’t know.

Another possibility is that I’m wrong about everything. :face_with_hand_over_mouth:


#7

What about is you remove quite and add rd.debug to your boot cmdline?


(Ben Bullard) #8

Nothing happens because the VM’s don’t even begin to boot. If you check screen shot above
booting stops at “Booting a command list” which is the same as not starting to boot as far as I know. I’ve waited as long as 7 minutes and nothing happens except something is using 100% of the CPU available to the VM.

Post-edit: I’m almost certain this is an issue with the VirtualBox-5.12.3 package not an issue with the system booting. As I have said it boots just fine with our VirtualBox-5.8.2 package.

:monkey:


(Ben Bullard) #9

The problem remains the same with virtualbox-5.2.16-1-omv2015.0.x86_64.


#10

Well, it stops just after boot kernel and ramdisk are loaded.


(Ben Bullard) #11

I suspect it stops while they are trying to load and something happens, maybe a race condition, that takes 100% of CPU and never finishes.


(Ben Bullard) #12

This is from this here.

12.4.1. Linux guests may cause a high CPU load

Some Linux guests may cause a high CPU load even if the guest system appears to be idle. This can be caused by a high timer frequency of the guest kernel. Some Linux distributions, for example Fedora, ship a Linux kernel configured for a timer frequency of 1000Hz. We recommend to recompile the guest kernel and to select a timer frequency of 100Hz.

Linux kernels shipped with Red Hat Enterprise Linux (RHEL) as of release 4.7 and 5.1 as well as kernels of related Linux distributions (for instance CentOS and Oracle Linux) support a kernel parameter divider=N. Hence, such kernels support a lower timer frequency without recompilation. We suggest to add the kernel parameter divider=10 to select a guest kernel timer frequency of 100Hz.

I have no idea if this relates to my issue but I don’t think so since VBox works on my Desktop and does not work on my notebook.


(Ben Bullard) #13

Post-edit: OK, this post was more or less meant in humor. A real and better work around is below somewhere. :monkey:

Found Workaround.

But now I have 3rd party software on my machine.

(Um, yeah, I removed OMV VirtualBox and installed the Oracle VirualBox.)

:gorilla:


(Ben Bullard) #14

But I can and will reinstall OMV VirtualBox if anyone wants me to do any tests or try to gather information. Posting VBox logs is easy of course.


(Ben Bullard) #15

There are new VirtualBox packages in main-testing repo version 5.2.16-2. On my desktop they work fine as did previous package. So I installed on my ASUS notebook and my “VM’s won’t boot” issue persisted.

Then I had a brain fart and changed one setting. Normally I set my guest VM’s to have 4 GB memory for installation and then lower that to 3 GB for use, 20 or 15 GB disk space, and 2 (of 4) cpu’s. Like this:

On my notebook I changed this 1 cpu and my VM’s boot now. Like this:

So I don’t know what caused this or if this may indicate some regression on VBox code. I’ll look into it more as time passes. But the net result is that my issue is Resolved.

:see_no_evil: :hear_no_evil: :speak_no_evil:


(Ben Bullard) #16

Also worth mentioning is the the reason for the new virtualbox-5.2.16-2 package is that either the module ‘vboxpci’ was not loading or was not where it should be or something. At any rate for proper functioning we should see these for virtualbox:

$ lsmod | grep vbox
vboxpci                28672  0
vboxnetadp             28672  0
vboxnetflt             32768  0
vboxdrv               483328  3 vboxpci,vboxnetadp,vboxnetflt

:monkey:


(Ben Bullard) #17