Vivaldi Browser installation failed

I have a problem with installation of Vivaldi Browser. I downloaded the rpm package from their website, I ran urpmi vivaldi-stable-1.8.770.56-1.x86_64.rpm and I got the following error:
Installation failed: vivaldi-beta conflicts with vivaldi-stable-1.8.770.56-1.x86_64.rpm error while checking dependencies
The problem is, I have never installed Vivaldi Beta (it’s a clean OS installation). I even tried running urpme vivaldi-beta but it says that the packet is unknown. I am really confused.

EDIT: After reading this:
I think the problem is with the spec file:

$ rpm -q -p --provides vivaldi-stable-1.8.770.56-1.x86_64.rpm vivaldi-beta = 1.8.770.56 vivaldi-stable = 1.8.770.56-1 vivaldi-stable(x86-64) = 1.8.770.56-1

rpm -q -p --conflicts vivaldi-stable-1.8.770.56-1.x86_64.rpm vivaldi-beta xorg-x11-libX11 < 7.6_1 libX11 < 1.4.99

I don’t know how to edit the spec file though :confused:

and with

urpmi vivaldi-stable-1.8.770.56-1.x86_64.rpm --allow-force

1 Like

Thank you, it worked! I have to learn urpmi options :wink:

Thanks to you. I did not even know that there was a vivaldi-browser :wink:

If you like Opera you should definitely give it a try :slight_smile:

I use opera-developer( every day, so I’ll surely give it a try.

I have this issue too half month ago and repoting bug here: and directly to Vivaldi developers.

If you can, please report this bug to Vivaldi Devs also because look like it Vivaldi bug not distro. Report a Bug | Vivaldi Browser