Version 4.3, flathub not configured


  • OpenMandriva Lx version:

  • Desktop environment (KDE, LXQT…):

  • Description of the issue (screenshots if relevant):
    Flatpak is not integrated into discover and no default repository is set up

  • Relevant informations (hardware involved, software version, logs or output…):

I have never used flatpak and do not know much about it. I also do not use Discover.

There is a package called discover-backend-flatpak. It is not installed by default with flatpak. flatpak is not installed by default in OM Lx.


$ dnf search flatpak

Hi. This is a purposeful action.
Flatpak is not installed on the system ISO by default. Many of us think Flatpak is a great technology, but it can also lead to security issues. Hence the decision. We respect the will of the users, so we let them decide whether they want to use Flatpak or not.
Those who want can install it without any problems with one command
sudo dnf install flatpak
or by searching and installing in a graphical GUI dnf-frontend called dnfdragora.

Also, adding a Flathub repository is an individual matter. We apply the principle of neutrality - just as its creators themselves recommend. We allow users to choose whether they want to add a Flathub repo or some other, e.g. private. Just like as most distros do.
Repo Flathub can be added easily as:
flatpak remote-add --if-not-exists flathub

then you can use flatpak both via the command line - CLI and via the GUI in Discover, Gnome-Software or Appcenter.

Thank you. I had thought that Open Mandriva had integrated Flatpak. My apologies.

I’m quite new to OpenMandriva. Now I have a little problem with flatpak. I have installed flatpak and added the repo. But, alas, Discover can’t find it. And that’s strange, because I can see flathub within the repos, if I klick on settings It’s there and it’s active, but Discover tells me, that there is no flathub. And discover can’t find any flatpak app. And yes, I restartet the system. Not only once, in the meantime.
What can I do?
Thank you!

Make sure to install: discover-backend-flatpak

Welcome @DarkWriter to OpenMandriva.

1 Like

Thank you, I’ll ckeck it!

Hello, finally it’s working :slight_smile:
It wasn’t the backend and to be honest, I have no clue why it hadn’t worked in the first place. After nothing worked, I deleted the flathub repo and used the console to add it again. I just used the old command (arrow up) and behold - suddenly it worked. Maybe the ghost of Christmas yet to come visited Openmandriva and showd it the very same partition with another Distro. :wink: Thank you again for your help.