Util-linux installed but no blkid command

Operating System: OpenMandriva Lx 4.0
Kernel Version: 5.1.2-desktop-2omv4000


This isn’t a huge deal for me, but i though I’d make a post about it anyways…

When trying to run blkid i encountered this:

[brian@brian-ms7b87 ~]$ blkid
bash: blkid: command not found...
Install package 'util-linux' to provide command 'blkid'? [N/y] y

 * Waiting in queue... 
 * Loading list of packages.... Failed to install packages: util-linux-2.33.2-1.znver1 is already installed

[brian@brian-ms7b87 ~]$ 

Perhaps a repo quirk?

Apparently you need to be root to run the command:

$ sudo blkid
[sudo] password for ben79: 
/dev/sda1: UUID="fd099c81-9f23-41d3-a607-00349d56bf3b" TYPE="ext4" PARTUUID="d9659b7e-aadc-448c-b728-7c33e4de3182"
/dev/sda2: UUID="a4ad7c74-f833-44f2-a392-83390a863183" TYPE="ext4" PARTUUID="285bdb0e-d9b5-42f1-b535-01275f84e66f"

Interesting. Worked in the past on some distros without root. Weird message there too. Thanks!

I get the same message if I run it as user and I also find the message weird and not informative.

If a command needs to be run as root it seems like the error message should say something like:

This command needs to be run as root (sudo or su)

Dadgummit! :wink:

I don’t know if this should work as user I was just posting what I found.

Observation: To me it seems that to be consistent in Linux things that change the system should always require root password. Things that merely list what is present should run as user. But my experience is that this is inconsistent in Linux.