Updating i586 in a x86_64 installation, is it right?


#1

Hello,

OMV LX 3.03 (after updating from LX 3.02)

KDE

As usual, today I use the command,

urpmi --auto-update

but this time I was asked to choose one of the following i586 libraries:

GOT: libqt5gui5-eglfs-5.8.0-4-omv2015.0.i586
GOT: libqt5gui5-linuxfb-5.8.0-4-omv2015.0.i586
GOT: libqt5gui5-minimal-5.8.0-4-omv2015.0.i586
GOT: libqt5gui5-minimalegl-5.8.0-4-omv2015.0.i586
GOT: libqt5gui5-offscreen-5.8.0-4-omv2015.0.i586
GOT: libqt5gui5-vnc-5.8.0-4-omv2015.0.i586
GOT: libqt5gui5-x11-5.8.0-4-omv2015.0.i586
In order to satisfy the 'libqt5-output-driver[== 5.8.0-4:2015.0]' dependency, one of the following packages is needed:
 1- libqt5gui5-eglfs-5.8.0-4-omv2015.0.i586: EGL fullscreen output driver for QtGui v5 (to install)
 2- libqt5gui5-linuxfb-5.8.0-4-omv2015.0.i586: Linux Framebuffer output driver for QtGui v5 (to install)
 3- libqt5gui5-minimal-5.8.0-4-omv2015.0.i586: Minimal (Framebuffer based) output driver for QtGui v5 (to install)
 4- libqt5gui5-minimalegl-5.8.0-4-omv2015.0.i586: Minimalistic EGL output driver for QtGui v5 (to install)
 5- libqt5gui5-offscreen-5.8.0-4-omv2015.0.i586: Offscreen output driver for QtGui v5 (to install)
 6- libqt5gui5-vnc-5.8.0-4-omv2015.0.i586: VNC output driver for QtGui v5 (to install)
 7- libqt5gui5-x11-5.8.0-4-omv2015.0.i586: X11 output driver for QtGui v5 (to install)
What is your choice? (1-7)

It is really confusing since I already have x86_64 corresponding packages installed:

$ rpm -qa|grep qt5gui
lib64qt5gui5-5.8.0-4-omv2015.0.x86_64
lib64qt5gui5-x11-5.8.0-4-omv2015.0.x86_64
lib64qt5gui5-eglfs-5.8.0-4-omv2015.0.x86_64
lib64qt5gui5-offscreen-5.8.0-4-omv2015.0.x86_64
lib64qt5gui5-minimalegl-5.8.0-4-omv2015.0.x86_64
lib64qt5gui5-minimal-5.8.0-4-omv2015.0.x86_64
lib64qt5gui5-vnc-5.8.0-4-omv2015.0.x86_64
lib64qt5gui5-linuxfb-5.8.0-4-omv2015.0.x86_64
lib64qt5gui-devel-5.8.0-4-omv2015.0.x86_64

Is it right?

Thanks


#2

Another computer, where the packages below (all x86_64) are not installed, does not require installation of i586 packages for qt5gui:

openscenegraph-devel 
lib64osgQt-devel-3.4.0-1-omv2015.0.x86_64
lib64qt5gui-devel-5.8.0-4-omv2015.0.x86_64
lib64qt5gui5-linuxfb-5.8.0-4-omv2015.0.x86_64
lib64qt5gui5-minimal-5.8.0-4-omv2015.0.x86_64
lib64qt5gui5-minimalegl-5.8.0-4-omv2015.0.x86_64
lib64qt5gui5-offscreen-5.8.0-4-omv2015.0.x86_64
lib64qt5gui5-vnc-5.8.0-4-omv2015.0.x86_64
lib64qt5opengl-devel-5.8.0-4-omv2015.0.x86_64
lib64qt5widgets-devel-5.8.0-4-omv2015.0.x86_64

why, anyway, would I need to install equivalent i586 packages?


(rugyada) #3

Yes it’s confusing.
Disable all 32 bit repos. You can enable again if needed.
They should not be enabled by default on 64 bit imho


#4

Thanks,

I’ve found out about 5 i586 packages installed. I urpme’d them. Next step, comment i586 repositories.


#5

For my own experience this may happen when the local RPM database is (or was if it has been fixed) corrupted. You may enable 32bit repository if you use some special program (usually wine) and this should not conflict with 64bit repository, otherwise, as suggested by @rugyada, you may keep it disabled.


(Ben Bullard) #6

@adelson.oliveira did this work out OK for you?

As I understand it in OM Lx 3 if one has an x86_64 install there should be no need at all for any i586 packages or repos except to install 3rd party software. And devs cautioned me to remind users that if you are installing software that is 32-bit only you should be very wary of how out of date the software is likely to be.

As I understand things OpenMandriva will support and have ISO’s and repos for i686. However as of right now there aren’t any i686 ISO’s but there are i686 repos.


#7

Well, everything seems to be working fine here now.


(Ben Bullard) #8