Updated to Kernel 4.7.3-desktop-1omv and the screen shows several small desktops

Greetings to everybody, I tried to update my openmadriva installation and got kernel update to 4.7.3, when I tried to boot in this new kernel my screen showed several small desktop spaces, in other words, my display is divided and showing repeated screens.
I can attach a picture of my screen. I have not found any help on this topic.

My Graphics card is an Intel Corporation Mobile 4 series. Any help will be welcome!

J. M.

1 Like


that seems very weird :confused:

Can you try loading with previous kernel at Grub?

Thank you raphael for the reply. I can boot the old kernel, and I could load the graphics mode as usual, however, something has happened that I can only get a text console. I login and try to run startx, and sometimes I get a red screen with two terminals. As root I can run startx and from the red screen using one of the terminals, I run starkde and got the system running, but obviously it is not a solution.

Apparently the new kernel is not loading the intel graphics driver correctly, or there is a driver that should be blacklisted I am really puzzled by this problem.
I have been a Mandriva and openmandriva user since the beginning and it is really annoying that this kind of weird things make me change my OS, but I really need to keep working and I need my system ready.

Thank you very much!!

J. M. Islas

Is sddm service runnig?

Thank you Luca for the reply. No, sddm service is not running and:
#systemctl enable sddm.service
gives me no output, and when I run:

#service --status-all | grep sddm
There is no output either.

Thank you for the hint. I will try to enable the service somehow.

J. M. Islas

1 Like

# systemctl enable sddm
# systemctl start sddm

# systemctl status sddm


Thank you Luca, now I could get into graphics mode in old kernel. The problem with newest kernel 4.7.3 persists, so I guess I’ll have to wait till an update fix my weird problem.

J. M. Islas

Hi @jmislas,
happy you can work now.

Probably intel video driver need an update for kernel 4.7 version.
You can report your issue here:


1 Like

I’ll write the issue tomorrow if you have no time.

Thank you again Luca. I was planning to write the issue tonight, but given
you expertise and your excellent English maybe it would be better if you do
it so everybody understands and luckily give a clue on what is going on
with my graphics card and kernel 4.7.3.

Once again thank you!

J. M. Islas

I have an intel graphic card, maybe older than that of @jmilslas, and updated to kernel 4.7.3. No problem.

Unless there are more than one single intel graphic module, I cannot understand why it works here and not for @jmislas.

Here I have
Intel 2nd Generation Core Processor Family Integrated Graphics Controller

1 Like

Thank you very much for the feedback adelson.oliveira, I have to say that
this is the first time I see this kind of issue with an intel graphics
card. I tried to update again my system in order to check if the new intel
graphics driver fix the problem but no luck.

J. M. Islas

1 Like

I imagine it should not be easy with no direct access to graphical environment, but can you try a normal boot, do CTRL+ALT+F2 to enter shell and save the output of journalctl?

Also the output of inxi -G may help

I’m stupid :eggplant:
If you can access graphic display with old kernel:

  • please try to connect with new kernel, of course it will fail
  • reboot with previous kernel, the one working
  • then do journalctl -b -1 (the digit one, not letter l)to get logs from previous boot (the one which failed)

This doesn’t mean anything to me. I may have a computer with same graphics as yours but can’t tell without accurate information. If you would please be so kind to post the information Raphael asked for it would help us to help you.


Thank you for the replies Ben79, here is the output of the command:

$ inxi -G
Graphics: Card: Intel Mobile 4 Series Integrated Graphics Controller
Display Server: OpenMandriva X.org 118.4 driver: intel
Resolution: 1280x800@59.94hz
GLX Renderer: Mesa DRI Mobile Intel GM45 Express
GLX Version: 2.1 Mesa 12.0.3

Thank you again, and I am sorry for not supplying the information

J. M. Islas

1 Like

Raphael here I attach the output of the command journalctl -b -1 in a text

Thank you for taking the time to help!

J. M. Islas

This is the output from journalctl -b -1 as root.

J. M. Islas

Please can you retry, txt files were not allowed as attachment, I changed the behaviour :slight_smile: