System-config-printer and hplip will not install. (Cooker and ISO 2342)

cooker
omlx-4
printing
Tags: #<Tag:0x00007fabe3df8180> #<Tag:0x00007fabd9577f10> #<Tag:0x00007fabd9577d08>

(Ben Bullard) #1

As I write this ABF is down and has been for at least 3 days. Am using a mirror for Cooker http://ftp-stud.hs-esslingen.de/pub/Mirrors/openmandriva/cooker/repository/x86_64/

System is installed on hardware/desktop from most recent ISO Build-ID 2342 and as updated as I can get it. system-config-printer and hplip are missing from this ISO. When I attempt to install I get:

# dnf install system-config-printer
Last metadata expiration check: 0:00:15 ago on Wed 12 Dec 2018 05:27:43 PM CST.
Error: 
 Problem: package system-config-printer-1.5.11-5.x86_64 requires libhpmud.so.0()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libnetsnmp.so.30()(64bit) needed by lib64hpmud0-3.17.10-1.x86_64

# dnf install hplip
Last metadata expiration check: 0:08:53 ago on Wed 12 Dec 2018 05:27:43 PM CST.
Error: 
 Problem: package hplip-3.17.10-1.x86_64 requires libhpmud.so.0()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libnetsnmp.so.30()(64bit) needed by lib64hpmud0-3.17.10-1.x86_64

I don’t yet know if there are any other missing dependencies. Don’t know if there is a dnf command that would list those if they exist?

Post-edit: I tried also with http://distro.ibiblio.org to, I hope, eliminate the possibility this is somehow a problem with a mirror.

Post-edit-2: This is kind of obvious but the above means task-printing won’t install, also with the same error.


(Ben Bullard) #2

It is worth mentioning that otherwise this ISO and installed system seem to be working well.

A multitude of thanks to our hardworking developers.


(Tomasz Paweł Gajc) #3

I wonder if s-c-p is still needed on Plasma iso.
Anyways someone needs to fix both packages,


(Ben Bullard) #4

Good question. I just need a way to add and manage a printer.


(Tomasz Paweł Gajc) #5

bero fixed hplip


(Ben Bullard) #6

Yes, thanks @bero and @TPG. s-c-p and hplip packages install now. Also I believe these packages are on the most recent ISO # 2348.

system-config-printer still won’t open.

# system-config-printer
Traceback (most recent call last):
  File "/usr/share/system-config-printer/system-config-printer.py", line 84, in <module>
    import jobviewer
  File "/usr/share/system-config-printer/jobviewer.py", line 57, in <module>
    gi.require_version('Secret', '1')
  File "/usr/lib64/python3.7/site-packages/gi/__init__.py", line 129, in require_version
    raise ValueError('Namespace %s not available' % namespace)
ValueError: Namespace Secret not available

After setting up printer and setting it as default with hp-toolbox it still won’t print. Here’s one printing example:

$ lp konsole.txt
lp: Unsupported document-format "text/plain".

$ lp InsuranceIDCard.pdf
lp: Unsupported document-format "application/pdf".

The utility in SystemSettings5 kcm-printer-manager will work EXCEPT that it does not discover the correct driver so user will have to select the correct driver, otherwise it seems to work and prints test page for my printer.

Post-edit: The above system is installed from ISO 2348 and fully updated as of this post.


(Ben Bullard) #7

cups-filters was not installed. I installed that and now it prints. Perhaps that package needs to be installed by default with cups? Or is installing it hardware dependent?

So now for me printing is working in Lx 4 Alpha.

FWIW: As I recall it is normal for not everything about printing to be working in an Alpha release. We can expect most if not all of this to be fixed by RC release. However, testing and reporting helps developers to know what to fix. Also testing and reporting is the only way to discover problems with specific hardware. So everyone please do test this.


(Ben Bullard) #8

We know now that @bero had fixed hplip so hp-toolbox works here and prints if I install cups-filters manually.

Here’s what crazy and I found. If I install cups-filters and lib64secret-gir1 all this stuff works. S-c-p works and discovers correct driver. kcm_print_manager (SystemSettings>Printing) works and selects correct driver. At least for me. And both print test page as they should. So here for now the workaround is:

# dnf install cups-filters lib64secret-gir1

Also @bero changed OM-Welcome to use kcm_print_manager (like SystemSettings does).

Note: In SystemSettings I can add and remove printer without root password. Don’t know if that is intended behavior or not.

Note-2: In OM-Welcome it does not ask for root password for kcm_print_manager but it opens it as root anyway. (I set ‘kdesu systemsettings5’ to open any GUI windows as red, works for KDE/Qt stuff but not for GTK stuff. This way if anything opens in a red window I know to stop and think because I am root.) (Seems like a great idea to make default any GUI opened as root to be a bright red window…) (Just an idea.)


(Ben Bullard) closed #9