Spell check not working in LibreOffice (2014)?

In 2014 in LibreOffice Writer my spell check isn’t working. Or maybe I don’t have something set correctly? Oddly it is working in OM Lx 3. Anyone else seeing this? Any ideas how to get it to work?

$ rpm -qa | grep kde-l10n

Full disclosure: I don’t know the use these type of apps very well and am in need of some learning. LIke why in KDE apps there are no red squiggly underlines for misspelled words. Also I really need spellcheck with the red squiggly underlines so I know if I’ve misspelled a word as I’m not a good speller.

Here’s this possibly misbegotten attempt at a bug report so Y’all can see what type of training and education I’m in need of…


F7 , shift F7 don’t work ?

for beta and kate
setting > configure kate > editing >spellcheck choose default language check different options >ok

after in menu >Tools > spelling and check automatic spell

To get the squiggly underlines in kate or kwrite (2014.2), I had to install the aspell package corresponding to my language et set “automatic spell checking” in systemconfig/locale/spell checker.

Thanks, I had the aspell packages but had to install the myspell EN_US package. That got red squiggly underlines back in KDE apps in 2014. Unfortunately that doesn’t work in OM Lx 3.

IMPORTANT: Thanks to the red squiggly underline I now know that squiggly is a real word with a proper spelling in US English!

Thanks, that stuff is all set in Kate, Kwrite, and SystemSettings. And as such no F7 and shift>F7 don’t work in the sense that there are no red squiggly underlines.